X
Tap here to go to the mobile version of the site.

Support Forum

in firefox 65 64 bit STOP VIDEO FROM AUTOMATCALLY PLAYING VERY ANNYOYING

Posted

I cannot stop videos from automatically playing when I click on an article to read when there is a video available to play. It just starts playing If this is not corrected I am not using Firefox anylonger.

I cannot stop videos from automatically playing when I click on an article to read when there is a video available to play. It just starts playing If this is not corrected I am not using Firefox anylonger.

Chosen solution

this seemed to help but cannot wait until the next upgrade when this isnt going to be an issue.

Thanks for your assistance

Read this answer in context 0
Quote

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:65.0) Gecko/20100101 Firefox/65.0

More Information

WestEnd
  • Top 25 Contributor
61 solutions 5303 answers

So where is the troubling link?

So where is the troubling link?
Was this helpful to you? 0
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17267 solutions 156055 answers

Try this extension:

Try this extension: *Disable HTML5 Autoplay https://addons.mozilla.org/firefox/addon/disable-autoplay/
Was this helpful to you?
Quote
McCoy
  • Top 10 Contributor
464 solutions 4224 answers

Hello blackeart,

This will not stop the annoying autoplay just yet, but soon :

https://support.mozilla.org/en-US/kb/block-autoplay


For now (apart from installing an add-on) :

Would you check this please :

Type in the address bar about:config and press Enter (promise to be careful, if asked)

Type in the search bar media.autoplay.

and check these settings :

media.autoplay.enabled.user-gestures-needed = true

media.autoplay.ask-permission = true

media.autoplay.default = 0 [0=Allowed, 1=Blocked, 2=Prompt]

media.autoplay.allow-muted = false

media.autoplay.allow-extension-background-pages = false

If you have to change anything, then close and restart Firefox.

Hello blackeart, This will not stop the annoying autoplay just yet, but soon : https://support.mozilla.org/en-US/kb/block-autoplay ---------------------------------------------------------------------------------------- For now (apart from installing an add-on) : Would you check this please : Type in the address bar '''about:config''' and press Enter (promise to be careful, if asked) Type in the search bar '''media.autoplay.''' and check these settings : '''media.autoplay.enabled.user-gestures-needed''' = true '''media.autoplay.ask-permission''' = true '''media.autoplay.default''' = 0 [0=Allowed, 1=Blocked, 2=Prompt] '''media.autoplay.allow-muted''' = false '''media.autoplay.allow-extension-background-pages''' = false If you have to change anything, then close and restart Firefox.

Modified by McCoy

Was this helpful to you? 1
Quote

Chosen Solution

this seemed to help but cannot wait until the next upgrade when this isnt going to be an issue.

Thanks for your assistance

this seemed to help but cannot wait until the next upgrade when this isnt going to be an issue. Thanks for your assistance
Was this helpful to you?
Quote
LilBro 0 solutions 13 answers

Helpful Reply

I followed all of the steps shown and they have NO effect in FF 66.0.2

I followed all of the steps shown and they have NO effect in FF 66.0.2
Was this helpful to you? 1
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17267 solutions 156055 answers

You can look at these prefs on the about:config page to see if these values work for you.

  • media.autoplay.default = 1 [0=Allowed, 1=Blocked, 2=Prompt]
  • media.autoplay.allow-muted = false
  • media.autoplay.enabled.user-gestures-needed = false

For user-gestures-needed you can try false and true to see what works for you.

It is possible that the media isn't detected and the media still starts playing and the block media icon on the location bar is missing.

You can also try the extension I mentioned above.

You can look at these prefs on the about:config page to see if these values work for you. *media.autoplay.default = 1 [0=Allowed, 1=Blocked, 2=Prompt] *media.autoplay.allow-muted = false *media.autoplay.enabled.user-gestures-needed = false For user-gestures-needed you can try false and true to see what works for you. It is possible that the media isn't detected and the media still starts playing and the block media icon on the location bar is missing. You can also try the extension I mentioned above. *Disable HTML5 Autoplay https://addons.mozilla.org/firefox/addon/disable-autoplay/
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.