X
Tap here to go to the mobile version of the site.

Support Forum

My system doesn't meet upgrade requirements. What do I do?

Posted

I have a "late 2008" macbook. I cannot upgrade this machine to mac 10.9 or later. How can I continue to operate Firefox?

I have a "late 2008" macbook. I cannot upgrade this machine to mac 10.9 or later. How can I continue to operate Firefox?

Additional System Details

Installed Plug-ins

  • Displays Java applet content, or a placeholder if Java is not installed.
  • Picasa plugin.
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 32.0 r0
  • iPhoto6

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:48.0) Gecko/20100101 Firefox/48.0

More Information

McCoy
  • Top 10 Contributor
521 solutions 4903 answers

Tweedboy said

I have a "late 2008" macbook. I cannot upgrade this machine to mac 10.9 or later. How can I continue to operate Firefox?

Hello Tweedboy,

If it's impossible for you to upgrade your system, instead of using Firefox version 48.0, you could use Firefox version 45.9.0esr :

http://ftp.mozilla.org/pub/firefox/releases/45.9.0esr/mac/en-US/

You'll probably already know everything that's mentioned in this article, but I'm giving you this link anyway :

https://support.mozilla.org/en-US/kb/firefox-osx

''Tweedboy [[#question-1248187|said]]'' <blockquote> I have a "late 2008" macbook. I cannot upgrade this machine to mac 10.9 or later. How can I continue to operate Firefox? </blockquote> Hello Tweedboy, If it's impossible for you to upgrade your system, instead of using Firefox version 48.0, you could use Firefox version 45.9.0esr : http://ftp.mozilla.org/pub/firefox/releases/45.9.0esr/mac/en-US/ You'll probably already know everything that's mentioned in this article, but I'm giving you this link anyway : https://support.mozilla.org/en-US/kb/firefox-osx