Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

latest flash not working

  • 39 replies
  • 1 has this problem
  • Last reply by richwalters

more options

Lets try here, here is the pic below. Tried everything even addon permissions, reloading Adobe flash, darned everything. I don't know who^s to blame, Firefox or Adobe or both ?


Attached screenshots

All Replies (20)

more options

Hello again. Did you check out what I posted before?

FredMcD said

Type about:addons<enter> in the address bar to open the Add-ons Manager. Hot key; <Control> (Mac=<Command>) <Shift> A) On the left side of the page, select Plugins. Make sure the ones you want to use are set to Ask or Allow. ++++++++++++++++++++++++++++++++++++++++
Go to the web page. Once the page is loading, mouse to the address bar and Left-click the icon. Select Permissions. In the menu, Make sure the ones you want to use are set to Ask or Allow.

Modified by FredMcD

more options

Yes Fred, thanks for reply... did as you suggest and the same result in pic...this time I delete and downloaded fresh flash from the joy.

This local storage question from Adobe is horribly complex which takes even a fair /experienced person round the clock in time terms. The other add-ons are disabled to avoid conflicts.

This main 489event.license that appears is boggling...are we on to something quite rare and awkward ?

more options

Hello Richy,

When Flash won't install ('application initialisation failure/error') would you please try to install using this link :

more options
more options

Sorry both don't work.....Adobe article mentions using Int explorer where the boxes showing Active X are visible as it is included with IExplorer but not for Firefox. When I go to I Explorer, it rightly mentions Flash is disabled as it is located on Firefox instead. Here is hardly nothing on the options page of the add-ons regarding it... and I've played on this to no bettering. The same logo of 'data storage' appears.


more options

Bummer  !

I hope someone else will come up with the perfect solution
for you .......

more options

There are probably several issues here; there is no way of attacking ActiveX or related when using Firefox... all that appears on the about:addons _options is a small box to block obtrusive content..Malware is out of the question.


more options

Hi richy, I feel like I'm missing part of the conversation. Is the problem that your Flash plugin is not storing the data the site wants to store, or that you don't want to be prompted (data should be stored automatically), or something else?

General comments:

(1) If Firefox is set not to save cookies, or set to clear cookies at shutdown, that also can affect Flash local storage and also Firefox (DOM) local storage. This article describes how to make cookie settings more permissive if needed: Websites say cookies are blocked - Unblock them.

(2) Private windows (either the kind you open yourself or the kind created with automatic private browsing) may block use of local storage.

(3) You can check and change your Flash plugin storage settings using Adobe's management tool (which is a Flash program):

(4) Adobe still releases an ActiveX version of Flash for Internet Explorer: -- it is a separate install than the Flash plugin for Firefox

more options

jscher2000 said

Hi richy, I feel like I'm missing part of the conversation

We got started here; Adobe flash not working anymore Win8.1

more options

Apols for the confusion, initially not finding the posting link way down the bottom of the page. Annoyed I was and got on something off beat..Now a whole days work is lost.

I examined the Adobe storage area and despite clicking 'agreed or the green tick' still, Flash doesn't work on the site. I deleted Adobe from the machine and reloaded; got same problem. Is there a sneak folder that 'delete' misses ? I don't understand where the fault really lies, only could be a bug on the site where the application program is, but then everyone else would start complaining. Is it my system ? Win 8.1 FFox Quantum, everything else bog normal. I remain curious.

more options

richwalters said

I examined the Adobe storage area and despite clicking 'agreed or the green tick' still, Flash doesn't work on the site.

In what way does it not work? You posted screenshots of the site's Flash content requesting to store data, but the text behind it says Please try again later, which indicates it could be a problem on their end.

Could you install the ActiveX version of Flash and test in IE?

more options

In addition to the above :

When you're on that site, click on the 'i' in a circle, next to the padlock at the left side of the address bar.

Then click on the little black arrow on the dropdown and then on "More Information", which will take you to "Page Info".

Click on the 'Permissions" tab and scroll down to "Run Adobe Flash". Uncheck "Use Default" and check "Allow".

Then close and restart Firefox.

If everything else fails, maybe you could ask advice here :

more options

I tried using internet explorer to circumvent to no success. The issue appears to be in Flash storage not responding to specific website addresses by not saving the details as permission. This is confusing as I thought the high possibility of the target website being the cause; but since local Flash storage won't let me add data, it looks very much the bug is there. I reloaded Flash Napi32 version too to no effect. It's mighty confusing when sites want to save some small data 100k on users machines. I'm going to flush out all AdobeFlash and reload it. Shall keep informed.

more options

Please provide a public link (no password) that we can check out. No Personal Information Please !

more options

McCoy....Click on the 'Permissions" tab and scroll down to "Run Adobe Flash". The permissions tag is dull grey; won't respond. The sun asterisk opposite will.That takes me to FF preferences options.

FredMcD double check this you mean the site where I am seeking Flash to run ?

Where I do need help is permissions....this is a closet full of dangerous traps.


more options

BTW I've already sent a query to the site in question regarding the flash function.

more options

richwalters said

Two things :

I see this icon that looks like a Lego piece that you're supposed to click on to allow Adobe Flash to run on that site. You will not see it if you don't have Shockwave Flash set to 'Always Activate'. (3-bar menu button => Add-ons => Plugins)

And : You mentioned that the Permissions tab in Page Info is
greyed out - not when I go to that tab ......

more options

Re 3 bar tab..If I disable the shockwave flash on my FF and then the site quite rightly asks for Adobe Flash to work. I get no 'lego' bit. If one clicks 'asks to activate' then I get a huge black page. ..the final one 'always activated' then the error caption arrives.


more options

What shows on your screenshot is not the Permissions tab ..... Would you please read my post again where I explain how to get to the Permissions tab  ?

As for Shockwave Flash and you not seeing that 'Lego piece':

Like I said in my last post : you need to set Shockwave Flash to 'Always Activate' ....

You've been struggling with this for hours now - maybe it's time for you to take a break, relax some and then try again later ..... (it's a lot to take in)

  1. 1
  2. 2