X
Tap here to go to the mobile version of the site.

Support Forum

Firefox build 63 won't work on my Mac OS High Sierra Macbook Retina

Posted

Firefox has been my default browser for years and it was working super fine until built 63 rolled out (and yes, I've tried all the sub-builds released under 63 and all have the same problem). I'm stuck on Firefox 62.0.3 for now and I keep getting updtate warnings from Firefox and a beating heart banner on top of all my tabs but the reason I can't move up is Firefox itself. And yes, I tried all the fixes I could find here before I posted my question. I update to 63 (even the most recent. 0.1 or whatever) and the exact same thing happen: Google, YoutTube and a Forum account I need to log into for work turn into blank pages. I get no error message, when I enter the address on the toolbar all I get is a blank page with nothing on it and the address bar showing (google, youtube and that forum site). Some websites work, like a news portal I look at, some don't, but, most importantly the triad I mentioned above doesn't, and I need them for work. They'll work on Chrome, Safari but not on Firefox 63. I turned off Ipv6 thinking this might be it (it wasn't), turned off Little Snitch (nothing changed), turned off BitDefender (still nothing), turned off hardware acceleration, accessibility stuff, you name it, I've done it. Then the moment I run the installer for Firefox 62 I'm back on all the sites, can see everything. No idea what this bug is and why is it is only happening on build 63 onwards, but something major changed between 62 and 63 and that something is what is giving me all this grief. Would a appreciate a suggestion and also would appreciate for people to look into this and try to fix it on a future Firefox update. Thanks.

Firefox has been my default browser for years and it was working super fine until built 63 rolled out (and yes, I've tried all the sub-builds released under 63 and all have the same problem). I'm stuck on Firefox 62.0.3 for now and I keep getting updtate warnings from Firefox and a beating heart banner on top of all my tabs but the reason I can't move up is Firefox itself. And yes, I tried all the fixes I could find here before I posted my question. I update to 63 (even the most recent. 0.1 or whatever) and the exact same thing happen: Google, YoutTube and a Forum account I need to log into for work turn into blank pages. I get no error message, when I enter the address on the toolbar all I get is a blank page with nothing on it and the address bar showing (google, youtube and that forum site). Some websites work, like a news portal I look at, some don't, but, most importantly the triad I mentioned above doesn't, and I need them for work. They'll work on Chrome, Safari but not on Firefox 63. I turned off Ipv6 thinking this might be it (it wasn't), turned off Little Snitch (nothing changed), turned off BitDefender (still nothing), turned off hardware acceleration, accessibility stuff, you name it, I've done it. Then the moment I run the installer for Firefox 62 I'm back on all the sites, can see everything. No idea what this bug is and why is it is only happening on build 63 onwards, but something major changed between 62 and 63 and that something is what is giving me all this grief. Would a appreciate a suggestion and also would appreciate for people to look into this and try to fix it on a future Firefox update. Thanks.
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:62.0) Gecko/20100101 Firefox/62.0

More Information

Tyler Downer
  • Top 25 Contributor
  • Moderator
1499 solutions 10406 answers

Helpful Reply

Can you please try Firefox 64, which was just released today?

Can you please try Firefox 64, which was just released today?
Was this helpful to you? 1
Quote

Question owner

Tyler Downer said

Can you please try Firefox 64, which was just released today?

Tyler,

Thank you for your suggestion. Just tried it and same results on Firefox 64. Firefox 62 is the only build I can use for some reason. YouTube, Google search page, and I checked this time even Instagram all show up as a completely blank page. NYTimes loads normally by the way as do a few other news sites and portals. But I really need the first two plus my forum (and instagram to a degree) to use for work so I can't afford to use 63 or 64. No errors, the https// green lock is on and I even have a roll tab, nothing is displayed on the page, just a huge completely white space.

''Tyler Downer [[#answer-1180380|said]]'' <blockquote> Can you please try Firefox 64, which was just released today? </blockquote> Tyler, Thank you for your suggestion. Just tried it and same results on Firefox 64. Firefox 62 is the only build I can use for some reason. YouTube, Google search page, and I checked this time even Instagram all show up as a completely blank page. NYTimes loads normally by the way as do a few other news sites and portals. But I really need the first two plus my forum (and instagram to a degree) to use for work so I can't afford to use 63 or 64. No errors, the https// green lock is on and I even have a roll tab, nothing is displayed on the page, just a huge completely white space.
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17003 solutions 153533 answers

Helpful Reply

You can check the Web Console (Tools -> Web Developer) for messages about blocked content and about the presence of mixed or unsafe content.

You can check the Network Monitor to see if content is blocked or otherwise fails to load.

If necessary use "Ctrl+F5" or "Ctrl+Shift+R" (Mac: Command+Shift+R) to reload the page and bypass the cache to generate a fresh log.

What security software do you have on your Mac?

There is security software that intercepts secure connections and sends their own certificate or that incorporates special web shielding features that can block content.


Clear the Cache and remove the Cookies from websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Remove the Cookies" from websites that cause problems:

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Manage Data

"Clear the Cache":

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Clear Data -> Cached Web Content: Clear

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
You can check the Web Console (Tools -> Web Developer) for messages about blocked content and about the presence of mixed or unsafe content. *https://developer.mozilla.org/en/Tools/Web_Console You can check the Network Monitor to see if content is blocked or otherwise fails to load. *https://developer.mozilla.org/en/Tools/Network_Monitor If necessary use "Ctrl+F5" or "Ctrl+Shift+R" (Mac: Command+Shift+R) to reload the page and bypass the cache to generate a fresh log. What security software do you have on your Mac? There is security software that intercepts secure connections and sends their own certificate or that incorporates special web shielding features that can block content. *https://support.mozilla.org/en-US/kb/troubleshoot-SEC_ERROR_UNKNOWN_ISSUER ---- Clear the Cache and remove the Cookies from websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences). "Remove the Cookies" from websites that cause problems: *Options/Preferences -> Privacy & Security<br>Cookies and Site Data -> Manage Data "Clear the Cache": *Options/Preferences -> Privacy & Security<br>Cookies and Site Data -> Clear Data -> Cached Web Content: Clear Start Firefox in <u>Safe Mode</u> to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if <u>hardware acceleration</u> is is causing the problem. *switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance *do NOT click the "Refresh Firefox" button on the Safe Mode start window *https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems
Was this helpful to you? 1
Quote

Question owner

cor-el said

You can check the Web Console (Tools -> Web Developer) for messages about blocked content and about the presence of mixed or unsafe content. You can check the Network Monitor to see if content is blocked or otherwise fails to load. If necessary use "Ctrl+F5" or "Ctrl+Shift+R" (Mac: Command+Shift+R) to reload the page and bypass the cache to generate a fresh log. What security software do you have on your Mac? There is security software that intercepts secure connections and sends their own certificate or that incorporates special web shielding features that can block content.

Clear the Cache and remove the Cookies from websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Remove the Cookies" from websites that cause problems:

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Manage Data

"Clear the Cache":

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Clear Data -> Cached Web Content: Clear

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window

That was a very interesting experience. Firefox 64 won't work on the 3 sites I need it to after I go through all the steps you outlined and now, thanks to you, I found out that any of the developer tools won't work either on my 64. I can't see any of them when I select them from the menu (even in sites that are loading like in 64 like the NYTimes) and I still can't the see the dev tools pop up window when I use Mac shortcuts. Safe mode restart made no difference in seeing the tools or seeing the sites on 64. When I'm back to Firefox 62 I can see all the sites and see all the developer tools windows when I select them for use. Will post pictures of the Safe Mode blank pages on 64 and the safe mode with developer tool pages on 62 - my last stable and only usable version. I just have two extensions (flash which is on a always ask plug, and my BitDefender add on, plus something automatically installed by Firefox to play DRM content). I have Little Snitch and Bit Defender but disabling them doesn't change the status of Firefox 64, still unusable. Thank you for your help.

''cor-el [[#answer-1180447|said]]'' <blockquote> You can check the Web Console (Tools -> Web Developer) for messages about blocked content and about the presence of mixed or unsafe content. *https://developer.mozilla.org/en/Tools/Web_Console You can check the Network Monitor to see if content is blocked or otherwise fails to load. *https://developer.mozilla.org/en/Tools/Network_Monitor If necessary use "Ctrl+F5" or "Ctrl+Shift+R" (Mac: Command+Shift+R) to reload the page and bypass the cache to generate a fresh log. What security software do you have on your Mac? There is security software that intercepts secure connections and sends their own certificate or that incorporates special web shielding features that can block content. *https://support.mozilla.org/en-US/kb/troubleshoot-SEC_ERROR_UNKNOWN_ISSUER ---- Clear the Cache and remove the Cookies from websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences). "Remove the Cookies" from websites that cause problems: *Options/Preferences -> Privacy & Security<br>Cookies and Site Data -> Manage Data "Clear the Cache": *Options/Preferences -> Privacy & Security<br>Cookies and Site Data -> Clear Data -> Cached Web Content: Clear Start Firefox in <u>Safe Mode</u> to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if <u>hardware acceleration</u> is is causing the problem. *switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance *do NOT click the "Refresh Firefox" button on the Safe Mode start window *https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems </blockquote> That was a very interesting experience. Firefox 64 won't work on the 3 sites I need it to after I go through all the steps you outlined and now, thanks to you, I found out that any of the developer tools won't work either on my 64. I can't see any of them when I select them from the menu (even in sites that are loading like in 64 like the NYTimes) and I still can't the see the dev tools pop up window when I use Mac shortcuts. Safe mode restart made no difference in seeing the tools or seeing the sites on 64. When I'm back to Firefox 62 I can see all the sites and see all the developer tools windows when I select them for use. Will post pictures of the Safe Mode blank pages on 64 and the safe mode with developer tool pages on 62 - my last stable and only usable version. I just have two extensions (flash which is on a always ask plug, and my BitDefender add on, plus something automatically installed by Firefox to play DRM content). I have Little Snitch and Bit Defender but disabling them doesn't change the status of Firefox 64, still unusable. Thank you for your help.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.