X
Tap here to go to the mobile version of the site.

Support Forum

My preferences keep reverting to the defaults. How can I stop this from happening?

Posted

Almost daily, I find that my preferences for Search and my Home page revert to the Firefox default. How do I make my custom settings stick?

Almost daily, I find that my preferences for Search and my Home page revert to the Firefox default. How do I make my custom settings stick?

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.14; rv:63.0) Gecko/20100101 Firefox/63.0

More Information

FredMcD
  • Top 10 Contributor
4222 solutions 58926 answers

https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save

Note: Some software, like Advanced SystemCare with Surfing Protection, can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.

https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save '''Note:''' Some software, like Advanced SystemCare with Surfing Protection, can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.

Question owner

That doesn't help. I can't fix the user.js file because I don't have one in my profile folder. I looked at the prefs.js (or whatever it was called), and right now it's showing the propeer search prefs. I'll just see if it continues happening. I know I haven't recently added new software, but I did update my Mac OS to the latest version. If that's the problem, then Mozilla needs to fix Firefox so it works with the latest Mac OS.

That doesn't help. I can't fix the user.js file because I don't have one in my profile folder. I looked at the prefs.js (or whatever it was called), and right now it's showing the propeer search prefs. I'll just see if it continues happening. I know I haven't recently added new software, but I did update my Mac OS to the latest version. If that's the problem, then Mozilla needs to fix Firefox so it works with the latest Mac OS.
FredMcD
  • Top 10 Contributor
4222 solutions 58926 answers

SaraLeigh said

my preferences for Search and my Home page revert to the Firefox default

What about the rest of your profile? other settings, passwords, bookmarks . . . .

Are you using sync? If so, shut it down.

Open Firefox normally. Make whatever changes you need. After Close Firefox.

Give the browser 20 + seconds to close. Then,

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

''SaraLeigh [[#question-1243297|said]]'' <blockquote> my preferences for Search and my Home page revert to the Firefox default </blockquote> What about the rest of your profile? other settings, passwords, bookmarks . . . . Are you using sync? If so, shut it down. Open Firefox normally. Make whatever changes you need. After '''Close Firefox.''' Give the browser 20 + seconds to close. Then, [https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} by holding down the '''<Shift> ''(Mac=Options)''''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there?