X
Tap here to go to the mobile version of the site.

Support Forum

Search suggestions NOT turning off on ALL search sites

Posted

Win 7pro 64bit

I've tried unchecking the boxes, disabled search suggestions in options and in 'about:config' everything that is related shows false....! This happens on various search engines not just Google.

It's the same on FF 63 browser as well.... there may be a clue however, the desktop icon for Firefox 63 is just a white square with four or so coloured dots rather than the usual round icon, this is clickable and opens OK.

Could someone throw some light please?

Thanks, Dave.

Win 7pro 64bit I've tried unchecking the boxes, disabled search suggestions in options and in 'about:config' everything that is related shows false....! This happens on various search engines not just Google. It's the same on FF 63 browser as well.... there may be a clue however, the desktop icon for Firefox 63 is just a white square with four or so coloured dots rather than the usual round icon, this is clickable and opens OK. Could someone throw some light please? Thanks, Dave.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 31.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:46.0) Gecko/20100101 Firefox/46.0

More Information

jscher2000
  • Top 10 Contributor
8643 solutions 70721 answers

Hi Dave, a few things.

First, Firefox has a form history feature that can show previous form field entries in a drop-down. I don't think that's what you're seeing but if they are, you can remove them by pressing the down arrow to select one and then press the Delete key. If that doesn't have any effect, they are probably suggestions provided by the website.

To disable suggestions on a search website, they may offer a setting. I don't think Google lets you disable suggestions in the search boxes on their site, but I haven't checked recently.

Second, the Firefox desktop shortcut (or pinned taskbar shortcut) usually looks like a fox wrapped around a blue globe. If your shortcut has changed, you can learn more about it using right-click > Properties. The Firefox program shortcut will show a Shortcut tab with "Target type: Application" and a Target similar to either:

  • "C:\Program Files\Mozilla Firefox\firefox.exe"
  • "C:\Program Files (x86)\Mozilla Firefox\firefox.exe"

If it's something else, what does yours show? Is it a website shortcut??

Third, your Firefox identified itself to the forum as version 46. Most likely that is not correct, since that version is obsolete and very outdated now. Sometimes Firefox reports the wrong version because that information was saved in a preferences file. You may need to clear out that incorrect information to avoid sites telling you that you need to update your browser, or denying access to certain add-ons. See: How to reset the default user agent on Firefox.

Hi Dave, a few things. First, Firefox has a form history feature that can show previous form field entries in a drop-down. I don't think that's what you're seeing but if they are, you can remove them by pressing the down arrow to select one and then press the Delete key. If that doesn't have any effect, they are probably suggestions provided by the website. To disable suggestions on a search website, they may offer a setting. I don't think Google lets you disable suggestions in the search boxes on their site, but I haven't checked recently. Second, the Firefox desktop shortcut (or pinned taskbar shortcut) usually looks like a fox wrapped around a blue globe. If your shortcut has changed, you can learn more about it using right-click > Properties. The Firefox program shortcut will show a Shortcut tab with "Target type: Application" and a Target similar to either: * "C:\Program Files\Mozilla Firefox\firefox.exe" * "C:\Program Files (x86)\Mozilla Firefox\firefox.exe" If it's something else, what does yours show? Is it a website shortcut?? Third, your Firefox identified itself to the forum as version 46. Most likely that is not correct, since that version is obsolete and very outdated now. Sometimes Firefox reports the wrong version because that information was saved in a preferences file. You may need to clear out that incorrect information to avoid sites telling you that you need to update your browser, or denying access to certain add-ons. See: [[How to reset the default user agent on Firefox]].

Question owner

Yes I used FF46.01 this was working correctly until about a week ago.

To clarify, I cloned a disc then uninstalled FF 46.01, I then searched the registry for ALL Mozilla and Firefox entries and deleted them, I then searched for all folders and those in the 'hidden files' and deleted them.... OK so far?

I installed the latest FF and get exactly the same results with ALL the suggestions boxes unticked, in both cases I have history and cookies deleted upon exit, I then checked 'about:config' and the relevant browser entries are set to false.

I tried various Google URL's to combat search suggestions, they still show up on other browsers.... as said I was quite happy a week ago with the old version.

And the funny part is my XP 32bit installation and an even older copy of FF works OK. It can't be a Windows update as I have it turned off and very selective on the ones I allow.

Right now I'm not worried about the icon problem on FF63 but I am concerned about search suggestions popping up which is very annoying.

When time permits I'll try a different browser to see what happens, just that I thought there was 'some quick fix' I knew nothing about, pity because FF as served me well over the years whether a mod-con or outdated version.

Thank you for your time, if there are any suggestions I'll give them a try.

Regards, Dave

Yes I used FF46.01 this was working correctly until about a week ago. To clarify, I cloned a disc then uninstalled FF 46.01, I then searched the registry for ALL Mozilla and Firefox entries and deleted them, I then searched for all folders and those in the 'hidden files' and deleted them.... OK so far? I installed the latest FF and get exactly the same results with ALL the suggestions boxes unticked, in both cases I have history and cookies deleted upon exit, I then checked 'about:config' and the relevant browser entries are set to false. I tried various Google URL's to combat search suggestions, they still show up on other browsers.... as said I was quite happy a week ago with the old version. And the funny part is my XP 32bit installation and an even older copy of FF works OK. It can't be a Windows update as I have it turned off and very selective on the ones I allow. Right now I'm not worried about the icon problem on FF63 but I am concerned about search suggestions popping up which is very annoying. When time permits I'll try a different browser to see what happens, just that I thought there was 'some quick fix' I knew nothing about, pity because FF as served me well over the years whether a mod-con or outdated version. Thank you for your time, if there are any suggestions I'll give them a try. Regards, Dave

Question owner

-SORTED-

To get rid of the Googles search suggestion is like shelling peas with Ad Block. Normally adding webhp?complete=0 to Googles search URL would get rid of this

Simply type a letter or word in Google search when the suggestions open, open blockable items in Ad block, select all and add new rule, no doubt other ad blockers will work too, you simply create a new rule for the blocker used.

This is NOT a FF issue but a Google issue.

Thank you all for your perseverance. Dave

-SORTED- To get rid of the Googles search suggestion is like shelling peas with Ad Block. Normally adding webhp?complete=0 to Googles search URL would get rid of this Simply type a letter or word in Google search when the suggestions open, open blockable items in Ad block, select all and add new rule, no doubt other ad blockers will work too, you simply create a new rule for the blocker used. This is NOT a FF issue but a Google issue. Thank you all for your perseverance. Dave