X
Tap here to go to the mobile version of the site.

Support Forum

This thread was closed and archived. Please ask a new question if you need help.

Firefox won't autoscroll.

Posted

When I middle click, I can't get the autoscroll to stay on firefox. I've removed it, reinstalled it, done a full system sweep with Revo to remove remnants, tried a different mouse, gone into the firefox settings and preferences, even the code, tried incognito mode, tried safe mode, and tried removing all add-ons but to no avail.

It works on my laptop, and it will show the autoscroll image briefly then it disappears after I let go of the middle mouse.

When I middle click, I can't get the autoscroll to stay on firefox. I've removed it, reinstalled it, done a full system sweep with Revo to remove remnants, tried a different mouse, gone into the firefox settings and preferences, even the code, tried incognito mode, tried safe mode, and tried removing all add-ons but to no avail. It works on my laptop, and it will show the autoscroll image briefly then it disappears after I let go of the middle mouse.
WestEnd 60 solutions 5387 answers

That is a mouse driver issue not a firefox issue. Most common for PC are two button.

That is a mouse driver issue not a firefox issue. Most common for PC are two button.
FredMcD
  • Top 10 Contributor
4261 solutions 59658 answers

Reinstall you mouse programs.

Reinstall you mouse programs.
James
  • Top 25 Contributor
  • Moderator
1598 solutions 11291 answers

Have you have checked "Use Autoscrolling" in Options?

https://support.mozilla.org/en-US/kb/firefox-options-preferences-and-settings

Have you have checked "Use Autoscrolling" in Options? https://support.mozilla.org/en-US/kb/firefox-options-preferences-and-settings

Modified by James

James
  • Top 25 Contributor
  • Moderator
1598 solutions 11291 answers

WestEnd said

Most common for PC are two button.

For laptops maybe however mice with scroll wheels (as they have middle-click) have existed since 1998 on. My Logitech MX500 from 2002 had eight buttons.

''WestEnd [[#answer-1165951|said]]'' <blockquote>Most common for PC are two button. </blockquote> For laptops maybe however mice with scroll wheels (as they have middle-click) have existed since 1998 on. My Logitech MX500 from 2002 had eight buttons.

Question owner

FredMcD said

Reinstall you mouse programs.

Did that. No luck.

James said

Have you have checked "Use Autoscrolling" in Options? https://support.mozilla.org/en-US/kb/firefox-options-preferences-and-settings

Yes, did that. No fix.

''FredMcD [[#answer-1166005|said]]'' <blockquote> Reinstall you mouse programs. </blockquote> Did that. No luck. ''James [[#answer-1166027|said]]'' <blockquote> Have you have checked "Use Autoscrolling" in Options? https://support.mozilla.org/en-US/kb/firefox-options-preferences-and-settings </blockquote> Yes, did that. No fix.
cor-el
  • Top 10 Contributor
  • Moderator
17541 solutions 158616 answers

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
Start Firefox in <u>Safe Mode</u> to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if <u>hardware acceleration</u> is is causing the problem. *switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance *do NOT click the "Refresh Firefox" button on the Safe Mode start window *https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems

Question owner

cor-el said

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is is causing the problem.
  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window

Did all that. Nothing.

''cor-el [[#answer-1166126|said]]'' <blockquote> Start Firefox in <u>Safe Mode</u> to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if <u>hardware acceleration</u> is is causing the problem. *switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance *do NOT click the "Refresh Firefox" button on the Safe Mode start window *https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems </blockquote> Did all that. Nothing.
cor-el
  • Top 10 Contributor
  • Moderator
17541 solutions 158616 answers

The autoscroll icon should normally stay visible after you click the middle mouse button until you press another button.

Does that laptop has a scroll pad that you might activate and that is causing the auto-scroll to abort?

The autoscroll icon should normally stay visible after you click the middle mouse button until you press another button. Does that laptop has a scroll pad that you might activate and that is causing the auto-scroll to abort?

Question owner

cor-el said

The autoscroll icon should normally stay visible after you click the middle mouse button until you press another button. Does that laptop has a scroll pad that you might activate and that is causing the auto-scroll to abort?

The laptop is where it works. It's on my desktop that it doesn't.

The autoscroll works in chrome, and I tried with a different mouse, so I don't think it's a button unclicking.

''cor-el [[#answer-1166140|said]]'' <blockquote> The autoscroll icon should normally stay visible after you click the middle mouse button until you press another button. Does that laptop has a scroll pad that you might activate and that is causing the auto-scroll to abort? </blockquote> The laptop is where it works. It's on my desktop that it doesn't. The autoscroll works in chrome, and I tried with a different mouse, so I don't think it's a button unclicking.

Question owner

Little bump here, still no luck after the update to 63.03.

It still works on my laptop but neither mouse works on my desktop, I've tried uninstalling all drivers and updating them, I've uninstalled firefox completely with Revo including registry, so I still don't know what to do.

Little bump here, still no luck after the update to 63.03. It still works on my laptop but neither mouse works on my desktop, I've tried uninstalling all drivers and updating them, I've uninstalled firefox completely with Revo including registry, so I still don't know what to do.
cor-el
  • Top 10 Contributor
  • Moderator
17541 solutions 158616 answers

Locking, continued here:

Locking, continued here: *[/questions/1246038] Can't Autoscroll