X
Tap here to go to the mobile version of the site.

Support Forum

Memory leak in Private mode

Posted

Hello, I'm here more to report a bug than to ask a question, but I couldn't get myself to work with Bugzilla, it asks too many things.

So you know how sometimes you open a bunch of tabs in "Private Browsing" just so you have a separate window to close everything at once when it's not needed anymore, well usually in the case of Chrome and Edge, it clears the ram that window was using, instantly no problem... Firefox doesn't really do that and I find it quite worrying if you call it "Private browsing", in fact, closing tabs doesn't really seem to close them at all!

In chrome, when you close 10 tabs you see the ram usage dropping quite clearly, with Firefox it just stays there and it's even worse when I close the whole private window and because I have a normal Firefox window still open, it doesn't clear any ram!

Yesterday I had windows explorer crash because of this and it closed word while I was working on it, go to task manager and Firefox is using 5GB of ram with 5 tabs open... Every damn day I use lots of tabs I have to close Firefox completely and open it again with the same goddamn saved tabs to clear 3gb of memory or more!

Really I want to like this browser, but first of all, this must be a horrible programming practice and second I doubt this is safe at all, keeping closed tabs for hours in memory waiting for the program to close can't be safe, it just can't!

How to reproduce this memory leak? Have Firefox with a normal window open, then open another normal or private browsing window, open a bunch of tabs there, watch memory usage rise, then close that window and watch it not drop at all. Way around it? Close Firefox and re-open. Could it be an add-on bug? Maybe, you tell me if it works with you, but it would still mean there's a bug with Firefox itself.

Really simple, I have no idea why this is a thing, isn't it supposed to have a separate process that clears memory when you close it? I have my doubts it's working like that.

Hello, I'm here more to report a bug than to ask a question, but I couldn't get myself to work with Bugzilla, it asks too many things. So you know how sometimes you open a bunch of tabs in "Private Browsing" just so you have a separate window to close everything at once when it's not needed anymore, well usually in the case of Chrome and Edge, it clears the ram that window was using, instantly no problem... Firefox doesn't really do that and I find it quite worrying if you call it "Private browsing", in fact, closing tabs doesn't really seem to close them at all! In chrome, when you close 10 tabs you see the ram usage dropping quite clearly, with Firefox it just stays there and it's even worse when I close the whole private window and because I have a normal Firefox window still open, it doesn't clear any ram! Yesterday I had windows explorer crash because of this and it closed word while I was working on it, go to task manager and Firefox is using 5GB of ram with 5 tabs open... Every damn day I use lots of tabs I have to close Firefox completely and open it again with the same goddamn saved tabs to clear 3gb of memory or more! Really I want to like this browser, but first of all, this must be a horrible programming practice and second I doubt this is safe at all, keeping closed tabs for hours in memory waiting for the program to close can't be safe, it just can't! How to reproduce this memory leak? Have Firefox with a normal window open, then open another normal or private browsing window, open a bunch of tabs there, watch memory usage rise, then close that window and watch it not drop at all. Way around it? Close Firefox and re-open. Could it be an add-on bug? Maybe, you tell me if it works with you, but it would still mean there's a bug with Firefox itself. Really simple, I have no idea why this is a thing, isn't it supposed to have a separate process that clears memory when you close it? I have my doubts it's working like that.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 31.0 r0

uBlock Origin Tampermonkey (No scripts running) Search Image Google reverse image search Gnome Shell integration FoxyTab Enhancer for Youtube Download all images Bitdefender Wallet

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:62.0) Gecko/20100101 Firefox/62.0

More Information

Shadow110 1072 solutions 14836 answers

Hi, can you check a few things please :

Set this up and see what;s going on : https://docs.microsoft.com/en-us/sysinternals/downloads/process-explorer

To be Checked and turned off unless needed for accessibility : Please : go to the Firefox 3 Bar Menu --> Options --> Privacy & Security panel and under Permissions check (put a tick in the box) the setting to Prevent Accessibility Services from accessing your browser.

Multi-Processor Support : Go to the 3 Bar Menu then Options --> General --> Performance and untick everything. change the recommended size lower then see how it runs. Note: 1 = No Multiprocessor = slow again. Try 2 Restart Firefox after making these changes please. Note : Hardware Acceleration is for Video Card, Monitor to see if remain off or to turn back on.

Test in : SAFE MODE

In Firefox Safe mode these changes are effective:

  • all extensions are disabled (about:addons)
  • default theme is used (no persona)
  • userChrome.css and userContent.css are ignored (chrome folder)
  • default toolbar layout is used (file: localstore-safe.rdf)
  • Javascript JIT compilers are disabled (prefs: javascript.options.*jit)
  • hardware acceleration is disabled (Options > Performance > Uncheck to view)
  • plugins are not affected
  • preferences are not affected

TEST''''is issue still there ?

Hi, can you check a few things please : Set this up and see what;s going on : https://docs.microsoft.com/en-us/sysinternals/downloads/process-explorer '''''To be Checked and turned off unless needed for accessibility : ''''' Please : go to the Firefox 3 Bar Menu --> Options --> Privacy & Security panel and under Permissions check (put a tick in the box) the setting to Prevent Accessibility Services from accessing your browser. '''''Multi-Processor Support : ''''' Go to the 3 Bar Menu then Options --> General --> Performance and untick everything. change the recommended size lower then see how it runs. Note: 1 = No Multiprocessor = slow again. Try 2 Restart Firefox after making these changes please. Note : Hardware Acceleration is for Video Card, Monitor to see if remain off or to turn back on. Test in : SAFE MODE *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes In Firefox Safe mode these changes are effective: *all extensions are disabled (about:addons) *default theme is used (no persona) *userChrome.css and userContent.css are ignored (chrome folder) *default toolbar layout is used (file: localstore-safe.rdf) *Javascript JIT compilers are disabled (prefs: javascript.options.*jit) *hardware acceleration is disabled (Options > Performance > Uncheck to view) *plugins are not affected *preferences are not affected TEST'''''''''is issue still there ?
cor-el
  • Top 10 Contributor
  • Moderator
17424 solutions 157436 answers

You can check the about:memory page via the location/address bar. This page has buttons to free memory.

You can check the <b>about:memory</b> page via the location/address bar. This page has buttons to free memory.

Question owner

cor-el said

You can check the about:memory page via the location/address bar. This page has buttons to free memory.

I tried that yesterday, doesn't work, not even a little unfortunaly.

''cor-el [[#answer-1158673|said]]'' <blockquote> You can check the <b>about:memory</b> page via the location/address bar. This page has buttons to free memory. </blockquote> I tried that yesterday, doesn't work, not even a little unfortunaly.
FFus3r 50 solutions 757 answers
see this page: * https://blog.mozilla.org/security/2018/01/31/preventing-data-leaks-by-stripping-path-information-in-http-referrers/