Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox Reader Text-to-Speach is gone on macOS Mojave

  • 5 replies
  • 1 has this problem
  • 7 views
  • Last reply by Shadow110

more options

Hey,

So Firefox Reader View had a Text-to-Speach feature that highlighted the word while reading and it was super useful for me, now after updating to macOS Mojave (Current version is 10.14), it's gone and I can't find it anywhere.

I reinstalled everything, purged all folders, downloaded the different versions of Firefox and without any luck.

Thank you.

All Replies (5)

more options

These maybe breaking it. DuckDuckGo Privacy Essentials Privacy Badger

As Reader Mode is a internal Firefox page Extensions do not work on it. Are you sure it was not something Apple Specific ?

more options

I just ran Firefox in safe-mode – with addons disabled – and it didn't work.

So I think Firefox isn't recognizing the Text-To-Speach features in macOS Mojave, because I just tested Firefox 62.0 in BrowserStack (Web development tool) and the feature works.

Reading up in the docs, it says under the TTS feature: "This button will show up only if Windows/Mac/Linux has Text-to-speech information in the language that the article is in."

more options

Hey donpapa,

I will try to help you.

I am using macOS High Sierra (10.13.6) and I tried Reader View option Text-to-Speach.

  1. First that is coming to my head and I checked it on other websites, maybe you can force this extension to appear by adding before URL line: about:reader?url=
  2. Then change theme to dark if you didn't done that.
  3. If still problem occurs I found that there is register information

Greetings, Jakub

more options

Yeah still no luck.

I have a strong feeling that the problem is with Firefox failing to reach the correct APIs that deals with Speech on macOS. It's either Apple has changed them slightly or Firefox was using a sketchy method before to connect to them and now it's made obsolete.

more options

Hi, please try a Refresh but Note that this does more than uninstalling and re-installing does. Normal uninstalling does not remove some preferences which may have become corrupt. Please Refresh but do this 1st:

then