X
Tap here to go to the mobile version of the site.
Scheduled maintenance: Thursday, April 2, between 3pm and 5pm UTC. This site will have limited functionality while we undergo maintenance to improve your experience. If an article doesn’t solve your issue and you want to ask a question, we have our support community waiting to help you at @firefox on Twitter

Support Forum

How can I keep the search options page from randomly coming up when I am trying to search?

Posted

Sometime when I type into the search bar or address bar firefox takes me to the search options page (have it set the way I want it) and then I have to reenter my search to continue. I would like firefox to just let me search without second guessing my search options.

Sometime when I type into the search bar or address bar firefox takes me to the search options page (have it set the way I want it) and then I have to reenter my search to continue. I would like firefox to just let me search without second guessing my search options.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 30.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:62.0) Gecko/20100101 Firefox/62.0

More Information

jscher2000
  • Top 10 Contributor
8952 solutions 73370 answers

There used to be a problem where you were typing in the search bar and you nudged the mouse over the Change Search Settings part of the drop-down and Firefox understood that to mean when you pressed Enter in the box, you want to activate that "button" and open the Options page. Could that be what's happening? (I thought that got fixed!)

If that's not it, is there some other pattern that you can discern?

By the way, if you don't use the one-click icon section at the bottom of the address bar drop-down, you could hide it:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste URLB and pause while the list is filtered

(3) Double-click the browser.urlbar.oneOffSearches preference to switch the value from true to false

There used to be a problem where you were typing in the search bar and you nudged the mouse over the Change Search Settings part of the drop-down and Firefox understood that to mean when you pressed Enter in the box, you want to activate that "button" and open the Options page. Could that be what's happening? (I thought that got fixed!) If that's not it, is there some other pattern that you can discern? By the way, if you don't use the one-click icon section at the bottom of the address bar drop-down, you could hide it: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste '''URLB''' and pause while the list is filtered (3) Double-click the '''browser.urlbar.oneOffSearches''' preference to switch the value from true to false

Modified by jscher2000