Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

This thread was closed and archived. Please ask a new question if you need help.

Stop firefox from redirecting

  • 6 replies
  • 1 has this problem
  • 18 views
  • Last reply by cor-el

more options

I want to go here: https://signup.leagueoflegends.com/en/signup/redownload

But because of the japanese proxy I have Im redirected to here: https://signup.jp.leagueoflegends.com/ja/signup/index

Apparently I need to be a rocket scientist these days to make my browser do AS I WANT. WHERE IS THE DONT FOLLOW REDIRECTS BUTTON FROM A MILLION VERSIONS AGO?? TELL ME WHERE IS IT??? ITS CALLED A OPTION FOR A REASON; BECAUSE ITS AN OPTION; YOU CAN CHOOSE WETHER YOU WANT TO OR NOT ITS UP TO YOU! IF YOU DONT LIKE IT STAY AWAY FROM IT THATS ALL YOU NEED TO ; YOU DONT NEED TO REMOVE ONE FUCNTION AFTER ANOTHER. Now tell me how to make your BROWSER (cause thats what it is at this point when you keep doing EXACTLY THE SAME AS THE CORPORATE DO WITH THEIR BROWSERS). Let me repeat that, now tell me where I stop your browser from listening to all you OUT THERE and start listening to me. WAS THAT A GOOD QUESTION? DID I POST THAT CORRECTLY? I remember when firefox used to be at the frontier...

[Profanity removed by moderator. Please read Mozilla Support rules and guidelines, thanks.]

Modified by Chris Ilias

All Replies (6)

more options

Please edit your Question, not appropriate.

more options

Hi,

Here is something you could try:

  1. In the Location bar, type about:config and press Enter. The about:config "This might void your warranty!" warning page may appear.
  2. Click I'll be careful, I promise!, to continue to the about:config page.
  3. Search for the preference accessibility.blockautorefresh.
  4. Double-click on accessibility.blockautorefresh, which should set the value to True.

From your wording, I get the impression that you think you are directly contacting developers or Mozilla employees. You are not. This is a community support forum. The people that answer questions here are users just like you, volunteering their time.

I hope that fixed the issue for you. :)

more options

If you use a proxy that locates you in Japan then it is quite possible that some websites present you pages in Japanese. You would either have to check if there is a link or menu to get an international (English) page or try to replace "/ja/" in the link to "/en/" or /en-us/ to see if that prevents the website from redirecting. It is not Firefox doing this, but websites that do a reverse DNS lookup or otherwise do a geolocation check.

more options

Chris Ilias said

Hi, Here is something you could try:
  1. In the Location bar, type about:config and press Enter. The about:config "This might void your warranty!" warning page may appear.
  2. Click I'll be careful, I promise!, to continue to the about:config page.
  3. Search for the preference accessibility.blockautorefresh.
  4. Double-click on accessibility.blockautorefresh, which should set the value to True.
From your wording, I get the impression that you think you are directly contacting developers or Mozilla employees. You are not. This is a community support forum. The people that answer questions here are users just like you, volunteering their time. I hope that fixed the issue for you. :)

I thought I was, I wish I was, I dont care that Ive cooled off, they deserve every word of it.. ITS WORKING STOP "FIXING" IT. Secrurity flaws etc, ofc fine, but this is just ridiculous. And no it didnt help that "solution" is the first that pops up googling. I didnt come here right off the bat... Im tired of it, how hard is it to get a browser that simply follows my commands??? If I say go to xxx site then go to THAT SITE and stop. I didnt ask you to listen to who coded it saying "nono youre wrong THIS is where you should be going", I asked you one simple thing , GO TO THAT SITE AND THATS IT IF I WANT THAT TO TAKE ME ELSEWHERE AND YOURE SO HORNY FOR IT YOU CAN ASK ME, not just switch the address I told you to go to to another... WELCOME TO TWO THOUSAND AND EIGHTTEEN, EVERYONES AT 15IQ AND THE ONLY THING WE APPRECIATE IS WHEN SOMETHING IS SIMPLIFIED EVEN BEYOND PRACTICAL REASON OR SENSE.... WEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEE. Apparently I didnt cool off, this is nagging me for months if not a year Mr "Chris"...

[Profanity removed by moderator. Please read Mozilla Support rules and guidelines, thanks.]

Modified by Chris Ilias

more options

cor-el said

If you use a proxy that locates you in Japan then it is quite possible that some websites present you pages in Japanese. You would either have to check if there is a link or menu to get an international (English) page or try to replace "/ja/" in the link to "/en/" or /en-us/ to see if that prevents the website from redirecting. It is not Firefox doing this, but websites that do a reverse DNS lookup or otherwise do a geolocation check.

So maybe the devs can focus on making a function where firefox doesnt follow the commands given from the coorporate ? That is if they can find time off from removing useful functions that has been around since the dawn of inet time... Its simple my friend, whatever I type into the address bar, make DAMN SURE that thats the ONLY THING YOU TRY TO VISIT. If it doesnt work tell me it doesnt work, I have 3 billion years of evolution, Im sure I can correct the spelling error myself rather than you just taking me where you think its best... Is there really no function that tells firefox more or less "I dont care what they say, you only follow my commands"?

[Profanity removed by moderator. Please read Mozilla Support rules and guidelines, thanks.]

Modified by Chris Ilias

more options

(I see that Chris has the same idea and has locked the thread)

I will lock the thread because you do not seem to understand that your use of strong language is unacceptable.

If you think that you can do without it then you can try again in a new thread.

Accept that websites are doing this redirecting and Firefox can't do anything about this.

Modified by cor-el