Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Facebook/Other videos error message: No compatible source was found for this media

  • 16 replies
  • 1 has this problem
  • 250 views
  • Last reply by Zwirni

more options

Hello everyone,

Problem: Error message: No compatible source was found for this media. Whenever I want to watch a video on Facebook or some other sites. Youtube/Twitch work without problems.

Setup: Windows 10 firefox (60.0.1 x64), no addons and as plugins: OpenH264 and Shockwave Flash (29.0 r0)

All Replies (16)

more options

Things I already tried: Reinstalling Firefox Reinstalling Flash

more options
more options

Pretty much every Website other than Twtich and Youtube. For example I can't watch Amazon Prime Video as well since I updated from Windows 7 to Windows 10. I get a weird message about the DRM Plugin not working.

Again: The only thing changed is that I updated from Windows 7 to Windows 10. Everything works as before on Google chrome but Firefox is on a wild rampage since the update. I tried the https://www.microsoft.com/en-us/software-download/mediafeaturepack but it can't be installed on my system.

more options

So I deleted every single file and registry entry regarding Firefox and did another completely fresh install. I still have the same problems i.e. Amazon Prime Video not working (WCD Module is set to always active but doesn't work) and the "No compatible source was found for this media." message on every site other than twitch and youtube.

I hope someone has a clue about what is going on with Firefox and my system :).

P.S.: Everything works in google chrome so it shouldn't be system related.

more options

When you updated Windows to 10, did you also update all 3rd party programs?

more options

First, can you confirm that Firefox is able to use the Media Foundation files for H.264 / MP4 video? Some test pages:

Second, once that is confirmed to work, for DRM video (Amazon/Netflix), you will need Google's Widevine plugin. See:

Watch DRM content on Firefox

more options

jscher2000 said

First, can you confirm that Firefox is able to use the Media Foundation files for H.264 / MP4 video? Some test pages: Second, once that is confirmed to work, for DRM video (Amazon/Netflix), you will need Google's Widevine plugin. See: Watch DRM content on Firefox

On the Youtube-page H.264 and MSE & H.264 have a red Exclamation mark next to them. Same on quirksmode, H.264/MP4 is being grey.

Widevine plugin is installed and marked as "always active"

more options
more options

cor-el said

Did you check this?

Yes I tried downloading the 1803 version and started it. It tells me that my system doesn't have the correct version. But my version is (according to winver): Version 1803 (Build 17134.81)

more options

So, I guess this is one of these "format c" issues?

more options

Zwirni said

On the Youtube-page H.264 and MSE & H.264 have a red Exclamation mark next to them.

Could you check the settings:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste wmf and pause while the list is filtered

Are there any modified preferences in this set? You could try resetting them using right-click > Reset.

(3) In the search box above the list, type or paste mp4 and pause while the list is filtered

Are there any modified preferences in this set? You could try resetting them using right-click > Reset.

more options

under wmf the following entry was "changed": media.decoder-doctor.MediaWidevineNoWMF.formats

under mp4 nothing was "changed"

I did what you said and reset the entry but nothing has unfortunately changed regarding my problems. Although I do believe it has something to do with the mediasource package. I guess I have to reinstall Windows 10 and see whether I can install it then.

more options

Zwirni said

I tried the https://www.microsoft.com/en-us/software-download/mediafeaturepack but it can't be installed on my system.

This could be the basic issue, as you should probably download a Media Feature pack after the OS upgrade according to the Fix video and audio playback problems on Firefox for Windows support article.

Be sure to check your Windows edition and try downloading the version that matches your build. Does it match any of the versions listed on this page ?

more options

Tonnes said

Zwirni said
I tried the https://www.microsoft.com/en-us/software-download/mediafeaturepack but it can't be installed on my system.

This could be the basic issue, as you should probably download a Media Feature pack after the OS upgrade according to the Fix video and audio playback problems on Firefox for Windows support article.

Be sure to check your Windows edition and try downloading the version that matches your build. Does it match any of the versions listed on this page ?

I was able to install: KB3099229_x64 All the others (including 1803) didn't work. Unfortunately it didn't change anything. And my build is, according to winver, Version 1803 (Build 17134.81)

I guess it is time to accept, that i need to format C because Upgrading from Win7 to Win10 horribly crashed the registry or something like that.

more options

Are the results on both test pages exactly similar as before?

You may be able to fix this by installing K-Lite Codec Pack Standard as referred to in this article. I do think there should be an official answer and way to fix it though, but haven’t found that (yet).

more options

Tonnes said

Are the results on both test pages exactly similar as before? You may be able to fix this by installing K-Lite Codec Pack Standard as referred to in this article. I do think there should be an official answer and way to fix it though, but haven’t found that (yet).

I installed this pack but unfortunately it didn't change anything :/.

Thank you all for your effort but I guess it is time to format C and reinstall.