X
Tap here to go to the mobile version of the site.

Support Forum

When did Firefox stop giving a dialog when saving a bookmark?

Posted

I'm on Firefox 54.0.1 on Yosemite (Mac), and when I "Bookmark this page" I'm no longer given a dialog box that allows me to navigate to where I want if saved. Instead, it's saved in the Bookmarks Menu. [not Other Bookmarks, as advertised]. When was this change made?

I'm on Firefox 54.0.1 on Yosemite (Mac), and when I "Bookmark this page" I'm no longer given a dialog box that allows me to navigate to where I want if saved. Instead, it's saved in the Bookmarks Menu. [not Other Bookmarks, as advertised]. When was this change made?

Modified by DICKGUERTIN

Chosen solution

Do you want to try the "Restore Defaults" button on the bottom of the Customize tab? That should restore the default set of toolbar icons, subject to changes made by extensions.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Shockwave Flash 25.0 r0

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:54.0) Gecko/20100101 Firefox/54.0

More Information

jscher2000
  • Top 10 Contributor
8638 solutions 70669 answers

How are you adding the bookmark? These are the methods I know about:

  • Command+d (Windows: Ctrl+d)
  • right-click (or on Mac Ctrl+click) a blank area of the page > click star icon on the context menu
  • (classic menu bar) Bookmarks > Bookmark This Page
  • click the star icon on the toolbar (the only one that defaults to the "Other Bookmarks" category)

Regardless of your choice, the star button on the toolbar should turn blue and a panel should drop from the button indicating "Page Bookmarked". If you click the star after it turns blue, a panel should drop indicating "Edit This Bookmark".

In the early days of this panel, some users reported it would display briefly and then close itself before the 4 seconds or so that it is supposed to remain open if you don't interact with it, or even after they started interacting with it. I'm not sure if we identified the reason for that, but it sounds as though you might have a different issue.

How are you adding the bookmark? These are the methods I know about: * Command+d (Windows: Ctrl+d) * right-click (or on Mac Ctrl+click) a blank area of the page > click star icon on the context menu * (classic menu bar) Bookmarks > Bookmark This Page * click the star icon on the toolbar (the only one that defaults to the "Other Bookmarks" category) Regardless of your choice, the star button on the toolbar should turn blue and a panel should drop from the button indicating "Page Bookmarked". If you click the star after it turns blue, a panel should drop indicating "Edit This Bookmark". In the early days of this panel, some users reported it would display briefly and then close itself before the 4 seconds or so that it is supposed to remain open if you don't interact with it, or even after they started interacting with it. I'm not sure if we identified the reason for that, but it sounds as though you might have a different issue.
cor-el
  • Top 10 Contributor
  • Moderator
17421 solutions 157403 answers

Does the star get highlighted and can you open the dialog when you click the highlighted star?

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
Does the star get highlighted and can you open the dialog when you click the highlighted star? Start Firefox in <u>Safe Mode</u> to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem. *switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance *do NOT click the "Refresh Firefox" button on the Safe Mode start window *https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems

Question owner

There is no "star" All I see is the down-arrow for downloads, and the icons for two add-ons, followed by the 3-bar icon that opens the "Menu". I'm using the classic method of "Bookmark this page" from the Bookmarks drop-down on my Mac's bar. (Apple, Firefox, File, Edit, etc.)

There is no "star" All I see is the down-arrow for downloads, and the icons for two add-ons, followed by the 3-bar icon that opens the "Menu". I'm using the classic method of "Bookmark this page" from the Bookmarks drop-down on my Mac's bar. (Apple, Firefox, File, Edit, etc.)
jscher2000
  • Top 10 Contributor
8638 solutions 70669 answers

I think you need to add the combined star-menu icon back to the toolbar. It may be in the Customize panel among the unused icons, or possibly on the graphical application menu (the one you access with the 3-bar button): Customize Firefox controls, buttons and toolbars.

I think you need to add the combined star-menu icon back to the toolbar. It may be in the Customize panel among the unused icons, or possibly on the graphical application menu (the one you access with the 3-bar button): [[Customize Firefox controls, buttons and toolbars]].

Question owner

Sorry, it's not there. See my 2nd screen shot.

Sorry, it's not there. See my 2nd screen shot.

Question owner

It's aslo not in this group of icons ...(see 3rd screen-shot)

It's aslo not in this group of icons ...(see 3rd screen-shot)
jscher2000
  • Top 10 Contributor
8638 solutions 70669 answers

Chosen Solution

Do you want to try the "Restore Defaults" button on the bottom of the Customize tab? That should restore the default set of toolbar icons, subject to changes made by extensions.

Do you want to try the "Restore Defaults" button on the bottom of the Customize tab? That should restore the default set of toolbar icons, subject to changes made by extensions.

Question owner

OK, I did the restore and basically, very litltle changed. See my 4th screen shot.

OK, I did the restore and basically, very litltle changed. See my 4th screen shot.

Question owner

HOWEVER, the "star" is now on the URL-SEARCH bar. AND I get the dialog for about 2 seconds. If I click it, I can navigate it.

HOWEVER, the "star" is now on the URL-SEARCH bar. AND I get the dialog for about 2 seconds. If I click it, I can navigate it.

Modified by DICKGUERTIN

jscher2000
  • Top 10 Contributor
8638 solutions 70669 answers

DICKGUERTIN said

HOWEVER, the "star" is now on the URL-SEARCH bar. AND I get the dialog for about 2 seconds. If I click it, I can navigate it.

Yes, that's the default location. The panel normally has a short timeout, maybe 4 seconds. After it closes, you have to click the blue star to modify the location. I'm not aware of any way to extend the initial time.

''DICKGUERTIN [[#answer-990474|said]]'' <blockquote> HOWEVER, the "star" is now on the URL-SEARCH bar. AND I get the dialog for about 2 seconds. If I click it, I can navigate it. </blockquote> Yes, that's the default location. The panel normally has a short timeout, maybe 4 seconds. After it closes, you have to click the blue star to modify the location. I'm not aware of any way to extend the initial time.

Question owner

There was another side-effect ... I lost my Bookmarks Toolbar. Fortunately, I knew how to restore it, and didn't loose anything else.

There was another side-effect ... I lost my Bookmarks Toolbar. Fortunately, I knew how to restore it, and didn't loose anything else.
jscher2000
  • Top 10 Contributor
8638 solutions 70669 answers

DICKGUERTIN said

There was another side-effect ... I lost my Bookmarks Toolbar. Fortunately, I knew how to restore it, and didn't loose anything else.

For anyone else reading who might not know:

To turn different bars on and off, you can use one of these methods to show the toolbar list and select the desired bars there:

To turn on the Bookmarks Toolbar, Menu Bar, or other bars, click it on the list.

''DICKGUERTIN [[#answer-990505|said]]'' <blockquote> There was another side-effect ... I lost my Bookmarks Toolbar. Fortunately, I knew how to restore it, and didn't loose anything else. </blockquote> For anyone else reading who might not know: To turn different bars on and off, you can use one of these methods to show the toolbar list and select the desired bars there: * right-click a blank spot on the tab bar (or the "+" button) * (menu bar) View > Toolbars * in Customize mode > Show/Hide Toolbars (see: [[Customize Firefox controls, buttons and toolbars]]) To turn on the Bookmarks Toolbar, Menu Bar, or other bars, click it on the list.