X
Tap here to go to the mobile version of the site.

Support Forum

How to disable auto-page redirection block

Posted

frequently, when I select, paricular buttons on the page I'm currently on, which requires the display of relevant data, located, on another, site related, page , , , Firefox inserts, a blank page, containing a printed notice: "firefox has blocked this page from redirecting to another page". . . Firefox/mozilla has NO JUSTIFICATION,TO CENSOR MY online viewing, at ANY TIME! ! ! HOW may I PERMANENTLY, DISABLE, this OBSCENE, unsolicited, FIREFOX, action????

frequently, when I select, paricular buttons on the page I'm currently on, which requires the display of relevant data, located, on another, site related, page , , , Firefox inserts, a blank page, containing a printed notice: "firefox has blocked this page from redirecting to another page". . . Firefox/mozilla has NO JUSTIFICATION,TO CENSOR MY online viewing, at ANY TIME! ! ! HOW may I PERMANENTLY, DISABLE, this OBSCENE, unsolicited, FIREFOX, action????

Additional System Details

Installed Plug-ins

  • Shockwave Flash 25.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:53.0) Gecko/20100101 Firefox/53.0

More Information

jscher2000
  • Top 10 Contributor
8692 solutions 71046 answers

Maybe one of Firefox's accessibility options got turned on somehow. You can check here:

  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences

In the left column, click Advanced. Then on the right side, with the "General" mini-tab active, make sure the following is not selected (box is not checked): "Warn me when websites try to redirect or reload the page"

Was that it?

Maybe one of Firefox's accessibility options got turned on somehow. You can check here: * Windows: "3-bar" menu button (or Tools menu) > Options * Mac: "3-bar" menu button (or Firefox menu) > Preferences * Linux: "3-bar" menu button (or Edit menu) > Preferences In the left column, click Advanced. Then on the right side, with the "General" mini-tab active, make sure the following is not selected (box is not checked): "Warn me when websites try to redirect or reload the page" Was that it?

Question owner

Thank you, Jscher, I've implemented your suggestion, I deduce, I checked, that option, out of ignorance, of 'th consequence! I'm still, quite 'th 'nubie' at this, modern digital device, operation, stuff . . .Its been almost 5 decades, since I took BASIC PROGRAMMING, in college!! And I've only recently, noted the incentive, to engage with 'th current stuff!

Thank you, Jscher, I've implemented your suggestion, I deduce, I checked, that option, out of ignorance, of 'th consequence! I'm still, quite 'th 'nubie' at this, modern digital device, operation, stuff . . .Its been almost 5 decades, since I took BASIC PROGRAMMING, in college!! And I've only recently, noted the incentive, to engage with 'th current stuff!
knotian 0 solutions 2 answers

Helpful Reply

With 56 these options no longer appear - problem is still there The redirect stops me from using google news. How to fix? Looks like only option I have is to drop Firefox.

With 56 these options no longer appear - problem is still there The redirect stops me from using google news. How to fix? Looks like only option I have is to drop Firefox.

Modified by knotian

cor-el
  • Top 10 Contributor
  • Moderator
17472 solutions 157915 answers

The warning about reloading or redirecting is meant as an accessibility feature so people with disabilities or people who use screen readers do not get confused and isn't meant as a safety protection to stop redirecting.

In Firefox 56+ the "Warn me when web sites try to redirect or reload the page" setting can no longer be found in Options/Preferences.

You have to modify this pref on the about:config page to enable or disable this feature.

The warning about reloading or redirecting is meant as an accessibility feature so people with disabilities or people who use screen readers do not get confused and isn't meant as a safety protection to stop redirecting. *http://kb.mozillazine.org/Accessibility_features_of_Firefox In Firefox 56+ the "Warn me when web sites try to redirect or reload the page" setting can no longer be found in Options/Preferences. You have to modify this pref on the <b>about:config</b> page to enable or disable this feature. *http://kb.mozillazine.org/accessibility.blockautorefresh
jscher2000
  • Top 10 Contributor
8692 solutions 71046 answers

Helpful Reply

knotian said

Looks like only option I have is to drop Firefox.

If you give up that easily, pretty soon there won't be any technology you can use. ;-)

But seriously, please see cor-el's last reply. If you prefer it "step by step":

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

I suggest bookmarking this page for future ease of access.

(2) In the search box above the list, type or paste access and pause while the list is filtered

(3a) TO TURN OFF: If the accessibility.blockautorefresh preference is bolded and "modified" or "user set" to true, double-click it to restore the default value of false

(3b) TO TURN ON: Double-click the accessibility.blockautorefresh preference to switch it from false to true

Success?

''knotian [[#answer-1016429|said]]'' <blockquote>Looks like only option I have is to drop Firefox. </blockquote> If you give up that easily, pretty soon there won't be any technology you can use. ;-) But seriously, please see cor-el's last reply. If you prefer it "step by step": (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button accepting the risk. ''I suggest bookmarking this page for future ease of access.'' (2) In the search box above the list, type or paste '''access''' and pause while the list is filtered (3a) TO TURN OFF: If the '''accessibility.blockautorefresh''' preference is bolded and "modified" or "user set" to true, double-click it to restore the default value of false (3b) TO TURN ON: Double-click the '''accessibility.blockautorefresh''' preference to switch it from false to true Success?
knotian 0 solutions 2 answers

Thank you very much. I have been searching and all I found were complaints about the problem. It was a very easy fix and worked very well. I can now use Google News. The comment about 'won't be any tech.." was well deserved. It was just that I was really fed up with not finding an answer. All the references were to 55 and earlier and of course they would not work any more. Thanks again.

Thank you very much. I have been searching and all I found were complaints about the problem. It was a very easy fix and worked very well. I can now use Google News. The comment about 'won't be any tech.." was well deserved. It was just that I was really fed up with not finding an answer. All the references were to 55 and earlier and of course they would not work any more. Thanks again.
jscher2000
  • Top 10 Contributor
8692 solutions 71046 answers

Hi knotian, I have to apologize that the previous threads suggested as solutions when you're searching on this site (and probably also in Google) tend to be the ones that have stood the test of time even if they are obsolete. The algorithms definitely need tuning!

Hi knotian, I have to apologize that the previous threads suggested as solutions when you're searching on this site (and probably also in Google) tend to be the ones that have stood the test of time even if they are obsolete. The algorithms definitely need tuning!