Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Google Maps does not work poperly on Firefox 50.1 - the background becomes black

  • 3 replies
  • 6 have this problem
  • 7601 views
  • Last reply by zagreb

more options

After starting google maps screen becomes black (or purple in upper part). when switch to other tab, firefox becomes very slow... This started before one month, after update firefox to new version...

Chosen solution

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance
  • Do NOT click the "Refresh Firefox" button on the Safe Mode start window
Read this answer in context 👍 0

All Replies (3)

more options

Chosen Solution

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance
  • Do NOT click the "Refresh Firefox" button on the Safe Mode start window
more options
more options

zagreb said

After starting google maps screen becomes black (or purple in upper part). when switch to other tab, firefox becomes very slow... This started before one month, after update firefox to new version...

zagreb said

After starting google maps screen becomes black (or purple in upper part). when switch to other tab, firefox becomes very slow... This started before one month, after update firefox to new version...

after turning off hardware acc. - no problem any more