X
Tap here to go to the mobile version of the site.

Support Forum

How to fix ghosting scroll cursors that won't go away?

Posted

After using firefox for a while (usually longer than an hour consecutively) I will occasionally scroll on a webpage, only to have the scroll icon which appears not disappear after I have stopped scrolling. Interestingly, the scroll bars do not disappear even upon closing firefox; currently, the only way I have found to get rid of them is to restart my pc. I have attached some screenshots to better convey this issue, and if there is anything else I can do or provide let me know!

Thanks

After using firefox for a while (usually longer than an hour consecutively) I will occasionally scroll on a webpage, only to have the scroll icon which appears not disappear after I have stopped scrolling. Interestingly, the scroll bars do not disappear even upon closing firefox; currently, the only way I have found to get rid of them is to restart my pc. I have attached some screenshots to better convey this issue, and if there is anything else I can do or provide let me know! Thanks

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 15.20.20039
  • Foxit PhantomPDF Plug-In For Firefox and Netscape
  • Google Update
  • Intel web components updater - Installs and updates the Intel web components
  • Intel web components for Intel® Identity Protection Technology
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.111.2 for Mozilla browsers
  • 5.1.50901.0

Application

  • Firefox 49.0.2
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:49.0) Gecko/20100101 Firefox/49.0
  • Support URL: https://support.mozilla.org/1/firefox/49.0.2/WINNT/en-US/

Extensions

  • Adblock Plus 2.8.1 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Asynchronous Plugin Rendering 2.0 (asyncrendering@mozilla.org)
  • GDrive Panel 1.0.2.1-signed.1-signed (gdrivepanel@alejandrobrizuela.com.ar)
  • Google Keep Notes 49.0 ({a94d60a0-8408-4c53-8eec-cb349eb958b8})
  • Multi-process staged rollout 1.3 (e10srollout@mozilla.org)
  • Pocket 1.0.4 (firefox@getpocket.com)
  • Reddit Enhancement Suite 5.0.3 (jid1-xUfzOsOFlzSOXg@jetpack)
  • Web Compat 1.0 (webcompat@mozilla.org)
  • Avast Online Security 12.0.88 (wrc@avast.com) (Inactive)
  • Avast SafePrice 10.3.5.39 (sp@avast.com) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics 520
  • adapterDescription2:
  • adapterDeviceID: 0x1916
  • adapterDeviceID2:
  • adapterDrivers: igdumdim64 igd10iumd64 igd10iumd64 igdumdim32 igd10iumd32 igd10iumd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterSubsysID: 00000000
  • adapterSubsysID2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • crashGuards: []
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.21976
  • driverDate: 7-1-2016
  • driverDate2:
  • driverVersion: 20.19.15.4483
  • driverVersion2:
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'available', u'description': u'Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'HW_COMPOSITING'}, {u'status': u'available', u'description': u'Direct3D11 Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'D3D11_COMPOSITING'}, {u'status': u'disabled', u'description': u'Direct3D9 Compositing', u'log': [{u'status': u'disabled', u'message': u'Disabled by default', u'type': u'default'}], u'name': u'D3D9_COMPOSITING'}, {u'status': u'available', u'description': u'Direct2D', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'DIRECT2D'}, {u'status': u'available', u'description': u'Direct3D11 hardware ANGLE', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'D3D11_HW_ANGLE'}]}
  • info: {u'AzureCanvasAccelerated': 0, u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d 1.1'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • supportsHardwareH264: Yes; Using D3D9 API
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics 520 Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No

Question owner

Pictures didn't attach for some reason, here they are:

Pictures didn't attach for some reason, here they are:
FredMcD
  • Top 10 Contributor
4246 solutions 59400 answers

Helpful Reply

Is this only when Firefox is running? Next time it happens, close Firefox. Is the problem still there?

Is this only when Firefox is running? Next time it happens, close Firefox. Is the problem still there?

Question owner

FredMcD said

Is this only when Firefox is running? Next time it happens, close Firefox. Is the problem still there?

Only when firefox is running If I close firefox, the problem persists. Even if I open another application the ghosted scroll cursors are still there. The only way to get rid of them I've found is a restart.

''FredMcD [[#answer-935511|said]]'' <blockquote> Is this only when Firefox is running? Next time it happens, close Firefox. Is the problem still there? </blockquote> Only when firefox is running If I close firefox, the problem persists. Even if I open another application the ghosted scroll cursors are still there. The only way to get rid of them I've found is a restart.
FredMcD
  • Top 10 Contributor
4246 solutions 59400 answers

If the problem is still there after Firefox closes, then another program may be at fault. Does this start only when Firefox is running? What are you doing when it comes up? Have you noticed how long it takes before those bars show up?

If the problem is still there after Firefox closes, then another program may be at fault. Does this start only when Firefox is running? What are you doing when it comes up? Have you noticed how long it takes before those bars show up?

Question owner

FredMcD said

If the problem is still there after Firefox closes, then another program may be at fault. Does this start only when Firefox is running? What are you doing when it comes up? Have you noticed how long it takes before those bars show up?

So far, Firefox is the only program I've encountered this problem with. Often, I find it happens after Firefox has been open for a while - usually over an hour or two. I do think I've noticed a correlation between scrolling through large image or gif heavy pages and the scroll bar not disappearing.

''FredMcD [[#answer-935689|said]]'' <blockquote> If the problem is still there after Firefox closes, then another program may be at fault. Does this start only when Firefox is running? What are you doing when it comes up? Have you noticed how long it takes before those bars show up? </blockquote> So far, Firefox is the only program I've encountered this problem with. Often, I find it happens after Firefox has been open for a while - usually over an hour or two. I do think I've noticed a correlation between scrolling through large image or gif heavy pages and the scroll bar not disappearing.

Question owner

Something else I've noticed is that, even after Firefox has closed, if I mouse over the scroll bar my cursor changes to the Windows spinning blue circle, like this: https://social.msdn.microsoft.com/Forums/getfile/573905

Something else I've noticed is that, even after Firefox has closed, if I mouse over the scroll bar my cursor changes to the Windows spinning blue circle, like this: https://social.msdn.microsoft.com/Forums/getfile/573905
FredMcD
  • Top 10 Contributor
4246 solutions 59400 answers

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac=Options)
key, and then starting Firefox. A small dialog should appear. Click Start In Safe Mode (not Refresh).

Is the problem still there?

Start '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Firefox in Safe Mode]''' {web Link} by holding down the '''<Shift><br> ''(Mac=Options)'' ''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there?

Question owner

FredMcD said

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac=Options)
key, and then starting Firefox. A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

So far this has fixed the problem, which means that it probably has something to do with my addons, correct?

''FredMcD [[#answer-935746|said]]'' <blockquote> Start '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Firefox in Safe Mode]''' {web Link} by holding down the '''<Shift><br> ''(Mac=Options)'' ''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there? </blockquote> So far this has fixed the problem, which means that it probably has something to do with my addons, correct?
FredMcD
  • Top 10 Contributor
4246 solutions 59400 answers

It could be the work of one of your add-ons. Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control>(Mac=<Command>)<Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.

It could be the work of one of your add-ons. Type '''about:addons'''<enter> in the address bar to open your Add-ons Manager. Hot key; '''<Control>''(Mac=<Command>)''<Shift> A)''' In the Add-ons Manager, on the left, select '''Extensions.''' Disable a few add-ons, then '''Restart Firefox.''' Some added toolbar and anti-virus add-ons are known to cause Firefox issues. '''Disable All of them.''' If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group '''ONE AT A TIME''' (restarting FF) until the problem returns. Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.

Question owner

FredMcD said

It could be the work of one of your add-ons. Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control>(Mac=<Command>)<Shift> A) In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox. Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All of them. If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns. Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.

Bumping this because I've been unable to fix this problem. Even with all add-ons disabled, the issue persists. I've also tried using both x32 and x64 bit firefox, changing permissions, re-installing etc.

''FredMcD [[#answer-936076|said]]'' <blockquote> It could be the work of one of your add-ons. Type '''about:addons'''<enter> in the address bar to open your Add-ons Manager. Hot key; '''<Control>''(Mac=<Command>)''<Shift> A)''' In the Add-ons Manager, on the left, select '''Extensions.''' Disable a few add-ons, then '''Restart Firefox.''' Some added toolbar and anti-virus add-ons are known to cause Firefox issues. '''Disable All of them.''' If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group '''ONE AT A TIME''' (restarting FF) until the problem returns. Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective. </blockquote> Bumping this because I've been unable to fix this problem. Even with all add-ons disabled, the issue persists. I've also tried using both x32 and x64 bit firefox, changing permissions, re-installing etc.
FredMcD
  • Top 10 Contributor
4246 solutions 59400 answers

Helpful Reply

Type about:preferences#advanced<Enter> in the address bar. Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Type about:addons<enter> in the address bar to open the Add-ons Manager. Hot key; <Control>(Mac=<Command>) <Shift> A)

On the left side of the page, select Appearance. Then select Default.

Now restart Firefox.


Start your Computer in safe mode with networking. Then start Firefox. Try Safe websites. Is the problem still there?

Starting The Computer In Safe Mode;
Free Online Encyclopedia

Type '''about:preferences#advanced'''<Enter> in the address bar. Under '''Advanced,''' Select '''General.''' Look for and turn off '''Use Hardware Acceleration'''. Type '''about:addons'''<enter> in the address bar to open the '''Add-ons Manager.''' Hot key; '''<Control>''(Mac=<Command>)'' <Shift> A)''' On the left side of the page, select '''Appearance.''' Then select '''Default.''' Now restart Firefox. ---------------- Start your '''Computer''' in safe mode with networking. Then start Firefox. Try '''Safe''' websites. Is the problem still there? '''[http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting The Computer In Safe Mode;<br>Free Online Encyclopedia]'''

Question owner

FredMcD said

Type about:preferences#advanced<Enter> in the address bar. Under Advanced, Select General. Look for and turn off Use Hardware Acceleration. Type about:addons<enter> in the address bar to open the Add-ons Manager. Hot key; <Control>(Mac=<Command>) <Shift> A) On the left side of the page, select Appearance. Then select Default. Now restart Firefox.

Start your Computer in safe mode with networking. Then start Firefox. Try Safe websites. Is the problem still there?

Starting The Computer In Safe Mode;
Free Online Encyclopedia

It appears that turning off hardware acceleration fixes the problem, thanks for all your help!

''FredMcD [[#answer-940461|said]]'' <blockquote> Type '''about:preferences#advanced'''<Enter> in the address bar. Under '''Advanced,''' Select '''General.''' Look for and turn off '''Use Hardware Acceleration'''. Type '''about:addons'''<enter> in the address bar to open the '''Add-ons Manager.''' Hot key; '''<Control>''(Mac=<Command>)'' <Shift> A)''' On the left side of the page, select '''Appearance.''' Then select '''Default.''' Now restart Firefox. ---------------- Start your '''Computer''' in safe mode with networking. Then start Firefox. Try '''Safe''' websites. Is the problem still there? '''[http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting The Computer In Safe Mode;<br>Free Online Encyclopedia]''' </blockquote> It appears that turning off hardware acceleration fixes the problem, thanks for all your help!
FredMcD
  • Top 10 Contributor
4246 solutions 59400 answers

Glad to help. Safe Surfing.

Glad to help. Safe Surfing.

Question owner

FredMcD said

Glad to help. Safe Surfing.

For whatever reason, after a couple days the problem resumed even with hardware acceleration off. Currently, I've switched to the dev version of firefox, and that seems to have solved the problem. Just posting this on the off chance anyone else has this problem!

''FredMcD [[#answer-941125|said]]'' <blockquote> Glad to help. Safe Surfing. </blockquote> For whatever reason, after a couple days the problem resumed even with hardware acceleration off. Currently, I've switched to the dev version of firefox, and that seems to have solved the problem. Just posting this on the off chance anyone else has this problem!
FredMcD
  • Top 10 Contributor
4246 solutions 59400 answers

A post was flagged as Solved Problem. Please remove that flag. If you don’t, others that can help may not read this post.

Go to that message, and use the Undo link to its right.

A post was flagged as '''Solved Problem.''' Please remove that flag. If you don’t, others that can help may not read this post. Go to that message, and use the '''Undo''' link to its right.

Question owner

FredMcD said

A post was flagged as Solved Problem. Please remove that flag. If you don’t, others that can help may not read this post. Go to that message, and use the Undo link to its right.

And the mystery deepens.. the problem has again resumed on the dev version of firefox. I've made a little bit of progress, and have linked the issue to a process called SynTPEnh.exe, which appears to be related to the synaptics touchpad. When I force quit this process, the ghosted scroll bars disappear; however, I also lose my ability to scroll using the touchpad. This makes me think the problem may not be entirely on firefox's end. However, I've so far only encountered the problem when firefox is open.

''FredMcD [[#answer-942888|said]]'' <blockquote> A post was flagged as '''Solved Problem.''' Please remove that flag. If you don’t, others that can help may not read this post. Go to that message, and use the '''Undo''' link to its right. </blockquote> And the mystery deepens.. the problem has again resumed on the dev version of firefox. I've made a little bit of progress, and have linked the issue to a process called SynTPEnh.exe, which appears to be related to the synaptics touchpad. When I force quit this process, the ghosted scroll bars disappear; however, I also lose my ability to scroll using the touchpad. This makes me think the problem may not be entirely on firefox's end. However, I've so far only encountered the problem when firefox is open.
FredMcD
  • Top 10 Contributor
4246 solutions 59400 answers

See if there are any updates for that program. Also contact its support.

See if there are any updates for that program. Also contact its support.