X
Tap here to go to the mobile version of the site.
Scheduled maintenance: Monday, March 30, between 3:30pm and 5:30pm UTC. This site will have limited functionality while we undergo maintenance to improve your experience. If an article doesn’t solve your issue and you want to ask a question, we have our support community waiting to help you at @firefox on Twitter

Support Forum

Trying to open Outlook mail item with a .docx extension. Says can't open in pictureviewer. Apparently Word 2007 which I have would do it but how to tell ff?

Posted

All in the question.

IIUC .docx is a common filetype.

Outlook is a common mail program

So why can't Firefox read it?

All in the question. IIUC .docx is a common filetype. Outlook is a common mail program So why can't Firefox read it?

Chosen solution

I've solved my problem.

I saved the file from the email onto my PC then "Open with" with Word and it gave me a default option for that file type.

Presumably I could instead have just gone into Control Panel / Default Programmes.

I had assumed Firefox was already accessing that but apparently not.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 15.16.20045
  • Google Update
  • Shockwave Flash 21.0 r0
  • Shockwave Flash 22.0 r0
  • Windows Activation Technologies Plugin for Mozilla

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:47.0) Gecko/20100101 Firefox/47.0

More Information

Chosen Solution

I've solved my problem.

I saved the file from the email onto my PC then "Open with" with Word and it gave me a default option for that file type.

Presumably I could instead have just gone into Control Panel / Default Programmes.

I had assumed Firefox was already accessing that but apparently not.

I've solved my problem. I saved the file from the email onto my PC then "Open with" with Word and it gave me a default option for that file type. Presumably I could instead have just gone into Control Panel / Default Programmes. I had assumed Firefox was already accessing that but apparently not.