X
Tap here to go to the mobile version of the site.

Support Forum

Uneven/inconsistent scrolling with mouse wheel

Posted

When I scroll using the mouse wheel in Firefox the pages don't move a persistent distance with each notch of the wheel - sometimes it's a few lines, then it's the entire length of the window, then a few lines, and then now and then the page will move in the opposite direction I'm scrolling. I tried disabling smooth scrolling which makes the pages bounce less, but it's still unpredictable whether it'll scroll a few lines or several paragraphs. The mouse is set to scroll 3 lines per notch and it works in every other program, just not in Firefox. I also still find that it tries to smooth scroll on some pages despite it being turned off. If I disable the notches in the wheel I can somewhat control the distance the page moves, but it's still bouncing. If I click the middle mouse button - which locks the mouse movement to the scroll bar, the page scrolls just like if I dragged the scroll bar elevator - smooth and exactly how much you'd expect (but a pita to use, not very accurate, and really bad for the wrist). Incidentally text boxes usually scroll correctly. It's just the web pages themselves that have issues.

This issue pops up every few versions of Firefox and then goes away with a later version, and I've yet to find a way to fix it myself - it just seems to go away eventually on its own - and it doesn't matter what I'm doing. It's even buggered in About:Config.

This time it came either with the Firefox 46 update or when I updated the video driver the other day. But it doesn't happen in any other program. Scrolling works perfectly normal in Thunderbird, Word, Windows Explorer, and anything else I've tried. Only Firefox is having issues.

I tried updating all the mouse related drivers, disabled smooth scrolling in the mouse driver, etc, but Firefox still acts weird. Also tried changing some suggested settings in about:config, but also makes no difference.

Mouse: Logitech Performance MX

Firefox 46.0.1 Logitech Setpoint 6.67.83 Logitech driver 5.90.41 Setpoint 2.50 Windows 7 x64 SP1

When I scroll using the mouse wheel in Firefox the pages don't move a persistent distance with each notch of the wheel - sometimes it's a few lines, then it's the entire length of the window, then a few lines, and then now and then the page will move in the opposite direction I'm scrolling. I tried disabling smooth scrolling which makes the pages bounce less, but it's still unpredictable whether it'll scroll a few lines or several paragraphs. The mouse is set to scroll 3 lines per notch and it works in every other program, just not in Firefox. I also still find that it tries to smooth scroll on some pages despite it being turned off. If I disable the notches in the wheel I can somewhat control the distance the page moves, but it's still bouncing. If I click the middle mouse button - which locks the mouse movement to the scroll bar, the page scrolls just like if I dragged the scroll bar elevator - smooth and exactly how much you'd expect (but a pita to use, not very accurate, and really bad for the wrist). Incidentally text boxes usually scroll correctly. It's just the web pages themselves that have issues. This issue pops up every few versions of Firefox and then goes away with a later version, and I've yet to find a way to fix it myself - it just seems to go away eventually on its own - and it doesn't matter what I'm doing. It's even buggered in About:Config. This time it came either with the Firefox 46 update or when I updated the video driver the other day. But it doesn't happen in any other program. Scrolling works perfectly normal in Thunderbird, Word, Windows Explorer, and anything else I've tried. Only Firefox is having issues. I tried updating all the mouse related drivers, disabled smooth scrolling in the mouse driver, etc, but Firefox still acts weird. Also tried changing some suggested settings in about:config, but also makes no difference. Mouse: Logitech Performance MX Firefox 46.0.1 Logitech Setpoint 6.67.83 Logitech driver 5.90.41 Setpoint 2.50 Windows 7 x64 SP1

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 15.16.20039
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.91.2 for Mozilla browsers
  • Office Authorization plug-in for NPAPI browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 21.0 r0

Application

  • Firefox 46.0.1
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:46.0) Gecko/20100101 Firefox/46.0
  • Support URL: https://support.mozilla.org/1/firefox/46.0.1/WINNT/en-GB/

Extensions

  • Firefox Hello 1.2.6 (loop@mozilla.org)
  • FireFTP 2.0.26 ({a7c6cf7f-112c-4500-a7ea-39801a327e5f})
  • Greasemonkey 3.8 ({e4a8a97b-f2ed-450b-b12d-ee082ba24781})
  • Multi-process staged rollout 1.0 (e10srollout@mozilla.org)
  • Pocket 1.0 (firefox@getpocket.com)
  • Logitech SetPoint 6.5 ({F003DA68-8256-4b37-A6C4-350FA04494DF}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA GeForce GTX 960
  • adapterDescription2:
  • adapterDeviceID: 0x1401
  • adapterDeviceID2:
  • adapterDrivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
  • adapterDrivers2:
  • adapterRAM: 2048
  • adapterRAM2:
  • adapterSubsysID: 00000000
  • adapterSubsysID2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.17568
  • driverDate: 5-9-2016
  • driverDate2:
  • driverVersion: 10.18.13.6519
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d 1.1', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 2
  • numTotalWindows: 2
  • supportsHardwareH264: Yes
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce GTX 960 Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
FredMcD
  • Top 10 Contributor
4246 solutions 59390 answers

Use another mouse. Is the problem still there?

If you press the middle mouse button, you change the mouse into a scroll controller.

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac=Options)
key, and then starting Firefox. A small dialog should appear. Click Start In Safe Mode (not Refresh).

Is the problem still there?

Use another mouse. Is the problem still there? If you press the middle mouse button, you change the mouse into a scroll controller. Start '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Firefox in Safe Mode]''' {web Link} by holding down the '''<Shift><br> ''(Mac=Options)'' ''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there?

Question owner

I don't have a bunch of other mice lying around, so can't really test that. Or I would have already. The only other mouse I have requires a driver that's incompatible with a bunch of the drivers on my computer (it's crap, basically), so it's a pita to get working (and without the driver the wheel doesn't work).

Safe Mode or Normal Mode makes no difference. But here's the odd part: The scrolling issue isn't as noticeable today. It's almost normal in fact. Scrolling's always been dodgy with Logitech mice because of how they make the wheel, but running the mouse in notch mode it's still uneven, but workable. As before, disabling, the notches (switching to high speed scrolling) makes the scrolling smooth, but very hard to control.

The thing is, though: It works properly in other programs. It's just Firefox that's being weird. I think it's a conflict between how Firefox wants to assist the mouse and not having to with SetPoint doing the same thing, but I'm not sure what to change to fix it. It's always very noticeable that the issues gets worse on pages with a lot of active scripts and images, and as always Flash ads makes Firefox lag (I have an AMD FX-8350, so it should take a lot more to a problem with processing power).

Interesting part: Updated Thunderbird to 45.1 this morning, and now it has the same issue with some emails that have HTML formatting, like the ones from Mozilla support, while others scroll perfectly normal.

But if it works properly in Thunderbird, it should work properly in Firefox, right? Since they use almost the same render engine.

I don't have a bunch of other mice lying around, so can't really test that. Or I would have already. The only other mouse I have requires a driver that's incompatible with a bunch of the drivers on my computer (it's crap, basically), so it's a pita to get working (and without the driver the wheel doesn't work). Safe Mode or Normal Mode makes no difference. But here's the odd part: The scrolling issue isn't as noticeable today. It's almost normal in fact. Scrolling's always been dodgy with Logitech mice because of how they make the wheel, but running the mouse in notch mode it's still uneven, but workable. As before, disabling, the notches (switching to high speed scrolling) makes the scrolling smooth, but very hard to control. The thing is, though: It works properly in other programs. It's just Firefox that's being weird. I think it's a conflict between how Firefox wants to assist the mouse and not having to with SetPoint doing the same thing, but I'm not sure what to change to fix it. It's always very noticeable that the issues gets worse on pages with a lot of active scripts and images, and as always Flash ads makes Firefox lag (I have an AMD FX-8350, so it should take a lot more to a problem with processing power). Interesting part: Updated Thunderbird to 45.1 this morning, and now it has the same issue with some emails that have HTML formatting, like the ones from Mozilla support, while others scroll perfectly normal. But if it works properly in Thunderbird, it should work properly in Firefox, right? Since they use almost the same render engine.
FredMcD
  • Top 10 Contributor
4246 solutions 59390 answers

It could be a driver problem. Can you update the driver? I've called the big guys to help you. Good luck.

It could be a driver problem. Can you update the driver? I've called the big guys to help you. Good luck.

Question owner

I updated the drivers before making the first post hoping it'd fix it. So it's the latest drivers I could find.

Just turned on the computer, fired up Firefox to check for responses, and now the scrolling seems to be working like it should. It's still not as smooth and precise as in other programs, but it's still working. One thing is however that Firefox likes to scroll 10 lines instead of the 3 the mouse is set to, but the mouse and scrolling settings in config are beyond my comprehension, so I can't tell why.

I don't understand why it works better now since I haven't changed anything and the only things that auto-updates is Avast, Firefox, and Thunderbird (and it's still the same Firefox), but it clearly works close to normal.

There is still some bouncing when I let go of the wheel, but I think that's the wheel falling into a notch.

So: Possibly solved? I don't know yet.

EDIT: Watching a video on YouTube while reading in the other Firefox window makes the scrolling go all stupid again. Had to switch to scroll with the arrow keys. None of the CPU cores are working harder than 10%, but it looks like Firefox simply isn't multitasking properly.

I updated the drivers before making the first post hoping it'd fix it. So it's the latest drivers I could find. Just turned on the computer, fired up Firefox to check for responses, and now the scrolling seems to be working like it should. It's still not as smooth and precise as in other programs, but it's still working. One thing is however that Firefox likes to scroll 10 lines instead of the 3 the mouse is set to, but the mouse and scrolling settings in config are beyond my comprehension, so I can't tell why. I don't understand why it works better now since I haven't changed anything and the only things that auto-updates is Avast, Firefox, and Thunderbird (and it's still the same Firefox), but it clearly works close to normal. There is still some bouncing when I let go of the wheel, but I think that's the wheel falling into a notch. So: Possibly solved? I don't know yet. EDIT: Watching a video on YouTube while reading in the other Firefox window makes the scrolling go all stupid again. Had to switch to scroll with the arrow keys. None of the CPU cores are working harder than 10%, but it looks like Firefox simply isn't multitasking properly.

Modified by SteelRodent

FredMcD
  • Top 10 Contributor
4246 solutions 59390 answers

FredMcD said

If you press the middle mouse button, you change the mouse into a scroll controller.
''FredMcD [[#answer-879585|said]]'' <blockquote> If you press the middle mouse button, you change the mouse into a scroll controller. </blockquote>