X
Tap here to go to the mobile version of the site.

Support Forum

flash keeps crashing

Posted

Hi, I have been using firefox for a while now, and for some reason, during the past few months flash has kept crashing. As a result of this I had to uninstall flash completely. Of course, i tried to reinstall it and see if that worked, however it did not. I am glad that I am still able to watch Youtube, as they have converted into HTML5, however some other websites still use flash. I have tried all possible solutions given to other posts, such as updating drivers, however i cannot disable hardware acceleration, since it requires for me to have flash in order to disable it.

Thanks, frustrating problem

Hi, I have been using firefox for a while now, and for some reason, during the past few months flash has kept crashing. As a result of this I had to uninstall flash completely. Of course, i tried to reinstall it and see if that worked, however it did not. I am glad that I am still able to watch Youtube, as they have converted into HTML5, however some other websites still use flash. I have tried all possible solutions given to other posts, such as updating drivers, however i cannot disable hardware acceleration, since it requires for me to have flash in order to disable it. Thanks, frustrating problem

Chosen solution

Hi, Microsoft released a windows 10 update regarding flash security issue, which seemed to fix my issues for now. I hope other members experiencing the same problem, have also gotten their flash fixed by this new update. Thanks

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Google Update
  • Intel web components updater - Installs and updates the Intel web components
  • Intel web components for Intel® Identity Protection Technology
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.91.2 for Mozilla browsers
  • The plugin allows you to have a better experience with Microsoft Lync
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • Nitro PDF plugin for Firefox and Chrome
  • 5.1.41212.0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:46.0) Gecko/20100101 Firefox/46.0

More Information

FredMcD
  • Top 10 Contributor
4267 solutions 59835 answers

If you have problems with current Shockwave Flash plugin versions then check this:

  • see if there are updates for your graphics drivers

https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration

  • disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later)

https://forums.adobe.com/message/4468493#TemporaryWorkaround

  • disable hardware acceleration in the Flash plugin

https://forums.adobe.com/thread/891337 See also:


This is not a cure, but should let the web page load without crashing.

Flash block {web link} Never be annoyed by a Flash animation again! Blocks Flash so it won't get in your way, but if you want to see it, just click on it

If you have problems with current Shockwave Flash plugin versions then check this: * see if there are updates for your graphics drivers '''https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration''' * disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later) '''https://forums.adobe.com/message/4468493#TemporaryWorkaround''' * disable hardware acceleration in the Flash plugin '''https://forums.adobe.com/thread/891337''' See also: * '''http://kb.mozillazine.org/Flash#Troubleshooting''' ------------ This is not a cure, but should let the web page load without crashing. '''[https://addons.mozilla.org/en-US/firefox/addon/flashblock/ Flash block]''' {web link} Never be annoyed by a Flash animation again! Blocks Flash so it won't get in your way, but if you want to see it, just click on it

Question owner

As mentioned before, graphics card has nothing related to flash, as HTML works fine. I have also disabled protected mode, and no difference is made. It is impossible for me to disable hardware acceleration, since it requires for flash to work.

You have simply ignored what I mentioned in the message, and feel disappointed by the mozilla forums

As mentioned before, graphics card has nothing related to flash, as HTML works fine. I have also disabled protected mode, and no difference is made. It is impossible for me to disable hardware acceleration, since it requires for flash to '''work'''. You have simply ignored what I mentioned in the message, and feel disappointed by the mozilla forums
FredMcD
  • Top 10 Contributor
4267 solutions 59835 answers

Hello,

Try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches.

You will need to restart Firefox for this to take effect so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

Then perform these steps:

  1. Click the menu button New Fx Menu and select Options on Windows or Preferences on Mac or Linux.
  2. Select the Advanced panel and then the General tab.
  3. Uncheck Use hardware acceleration when available.
  4. Restart Firefox and see if the problems persist.

Did this fix your problems? Please report back to us!

If the problem is resolved, you should check for updates for your graphics driver by following the steps mentioned in these Knowledge base articles:

Thank you.

Hello, Try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches. You will need to restart Firefox for this to take effect so save all work first (e.g., mail you are composing, online documents you're editing, etc.). Then perform these steps: #Click the menu button [[Image:New Fx Menu]] and select ''Options'' on Windows or ''Preferences'' on Mac or Linux. #Select the ''Advanced'' panel and then the ''General'' tab. #Uncheck '''Use hardware acceleration when available'''. #Restart Firefox and see if the problems persist. Did this fix your problems? Please report back to us! If the problem is resolved, you should check for updates for your graphics driver by following the steps mentioned in these Knowledge base articles: * [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems#w_turn-off-hardware-acceleration]] * [[Upgrade your graphics drivers to use hardware acceleration and WebGL]] Thank you.

Chosen Solution

Hi, Microsoft released a windows 10 update regarding flash security issue, which seemed to fix my issues for now. I hope other members experiencing the same problem, have also gotten their flash fixed by this new update. Thanks

Hi, Microsoft released a windows 10 update regarding flash security issue, which seemed to fix my issues for now. I hope other members experiencing the same problem, have also gotten their flash fixed by this new update. Thanks
FredMcD
  • Top 10 Contributor
4267 solutions 59835 answers

That was very good work. Well Done.

That was very good work. Well Done.