Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Facebook icons not displaying, Windows 10, Firefox 40

  • 1 reply
  • 19 have this problem
  • 7 views
  • Last reply by jsljustin

more options

Asked elsewhere, answers are not applicable.

Basically, running firefox 40 under Windows 10, the facebook icons do not display. It is particularly difficult when icons such as the notification ones, and even the main facebook menu does not appear, precluding the easy ability to log out etc.

As stated, this question has been asked and answered elsewhere, but the supposed answers are not applicable here, i.e I have no images blocked for facebook (under Tools >> Page Info >> Media (tab)), yet these icons and most if not all others do not display. A refresh of the page repeatedly can sometimes cause the icons to reappear, but then they disappear again upon browsing facebook.

Chosen solution

I found the source of my problem! I hope this may be of help to anyone else reading this.

Basically, my anti-virus solution (avast free) was blocking a lot of content, but only on https protocols, which facebook and may other sites use. Avast was scanning https and blocking or otherwise interfering with the websites, causing many issues with https.

In the end I first disabled the https scanner on avast, which isn't good anyway, as you don't want a middle-man (avast in this case) scanning https communication, as it is designed to be private.. but then I noticed that the avast web protection modules were causing so many other browser slowdowns and general web issues, that I uninstalled avast completely, and went with another AV product.

In short, if you have issues with facebook or any other website, with icons and images / buttons etc not displaying, AND you are using avast anti-virus, then it is likely that avast is causing this problem. You can either disable https scanning (in avast settings) or go with another anti-virus.

Hope this helps.

Read this answer in context 👍 9

All Replies (1)

more options

Chosen Solution

I found the source of my problem! I hope this may be of help to anyone else reading this.

Basically, my anti-virus solution (avast free) was blocking a lot of content, but only on https protocols, which facebook and may other sites use. Avast was scanning https and blocking or otherwise interfering with the websites, causing many issues with https.

In the end I first disabled the https scanner on avast, which isn't good anyway, as you don't want a middle-man (avast in this case) scanning https communication, as it is designed to be private.. but then I noticed that the avast web protection modules were causing so many other browser slowdowns and general web issues, that I uninstalled avast completely, and went with another AV product.

In short, if you have issues with facebook or any other website, with icons and images / buttons etc not displaying, AND you are using avast anti-virus, then it is likely that avast is causing this problem. You can either disable https scanning (in avast settings) or go with another anti-virus.

Hope this helps.