Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

This just started showing up: "Could not load plugins: File not found".

  • 16 replies
  • 3 have this problem
  • 147 views
  • Last reply by cor-el

more options

All my plugins for video are always active and everything is up to date. Please help!

All Replies (16)

more options

Did it say what plugins? Your System Details shows many plugins.

Start Firefox in Safe Mode {web link} While you are in safe mode;

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration. Then check ALL of your settings; Browser and add-ons.

Poke around safe web sites. Are there any problems?. Then restart.

more options

Do a clean reinstall and delete the Firefox program folder before (re)installing a fresh copy of the current Firefox release.

If possible uninstall your current Firefox version to cleanup the Windows registry and settings in security software.

  • Do NOT remove "personal data" when you uninstall your current Firefox version, because this will remove all profile folders and you lose personal data like bookmarks and passwords including data in profiles created by other Firefox versions.

Remove the Firefox program folder before installing that newly downloaded copy of the Firefox installer.

  • (32 bit Windows) "C:\Program Files\Mozilla Firefox\"
  • (64 bit Windows) "C:\Program Files (x86)\Mozilla Firefox\"

Your bookmarks and other personal data are stored in the Firefox profile folder and won't be affected by an uninstall and (re)install, but make sure NOT to remove personal data when you uninstall Firefox as that will remove all Firefox profile folders and you lose your personal data.

If you keep having problems then also create a new profile.


more options

Followed your uninstall/reinstall instructions. Get the same message. Video wont stream on most (not all) sites that I was streaming on a week or two ago (depends on the site).

Mozilla recently released a new version if I recall. Is this a problem on Mozillas side?

more options

Here are two instructions;


  • 1 Thru the Add-ons Manager, set all plugins to Ask.

Type about:addons<Enter> in the address bar to open your Add-ons Manager. Hot key; <Control>(Mac:<Command>)<Shift> A)

On the left side of the page, select Plugins.

BTW; At the top right is a link to check your plugins.


  • 2

Go to the web page. Once the page is loading, mouse to the address bar and Left click the icon. A window for displaying site information should come up. Select More Information. Now select Permissions. In the menu, find and check the plugins, make sure they are set properly.

more options

Thank you for offering suggestions but none of this is helping. I done all that has been suggested and I am still getting the same message. Any ideas about what the problem is, i.e., is it more than a Mozilla issue?

more options

Can you give an address of a page where you get this error?

If you click the plugin notification icon in the address bar (looks like a small Lego block) on that page, does it show anything unusual?

more options

A Google search suggest that this is a problem with the JWplayer.

You can try to reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • Hold down the Shift key and left-click the Reload button
  • Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • Press "Command + Shift + R" (Mac)
more options

Thanks for your reply. I have seen the JW player issue mentioned elsewhere. Your suggestion does not work. I am currently living in a country where Google is not accessible (where I live is not the issue--things were fine until a couple of weeks ago).

This is still a problem. Any other ideas?

more options
more options

I appreciate the help but none of this is working.

All the plugins are up to date and set to active. I have been through them and set the to ask to activate and back to always activate.

The only one I cannot get to update its plugin is VLC player. I uninstalled and reinstalled the new version but still the new plugin does not appear (my browser says it is 2.1.3 and to update to 2.1.5. -- I have done that but still no new plugin).

more options

"Can you give an address of a page where you get this error?

If you click the plugin notification icon in the address bar (looks like a small Lego block) on that page, does it show anything unusual?"

Thanks for the help.

It happens on several websites where I am a paying member though I have noticed that sometimes it happens on news websites (not always)

I clicked on that notification icon. There is nothing unusual. I just asks if I want to continue allowing the plugin to run.

more options

Hi psgray, you didn't mention the results of trying the site in Firefox's Safe Mode. This would rule out your extensions as potential culprits.

For example, if you use Adblock Plus, please see this thread on the unofficial Mozillazine forums regarding making a site-specific exception: [SOLVED] What plugin to watch the live stream at RT.com?

To test in Firefox's Safe Mode:

You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

Not all add-ons are disabled: Flash and other plugins still run

After Firefox shuts down, a small dialog should appear. Click "Start in Safe Mode" (not Reset).

Any difference with with your Flash players?

Modified by jscher2000

more options

Do you see any errors related to this issue in the Web Console (Firefox/Tools > Web Developer)?

more options

cor-el:

Thanks for this.

I see this Java error: "Use of getPreventDefault() is deprecated. Use defaultPrevented instead." there are a number of CSS errors but nothing related to video.

I don't know if its relevant.

Please be patient. I know enough about IT to know that I do not know what the problem is here. I do not think it is a problem than can be fixed by adjusting the plugins and add-ons. It is something else.

Thanks for your help.

more options

Hi jscher2000:

Thanks for your help.

Yes, I tried the safe mode and still the same issue.

As for the RT.com link, I have Prvacy Badger and HTTPS Everywhere installed. HTTS Everywhere is disable because too many websites make using it a chore. I tried resetting privacy badger for the sites/pages but that changed nothing. I should say that I used both of those with these sites for months here without any problem.

The only change I can think of is I installed the "forget" app from Mozilla sometime before this happened. I think these sites had no problem with that so maybe its not relevant.

more options

Can you confirm that a plugin is used and not the HTML5 media player?

If a plugin is active then you will have a Lego block icon the the at the left end of the location/address bar.

Create a new profile as a test to check if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

You can check for issues caused by plugins and set all plugins to "Ask to Activate" on the "Firefox/Tools > Add-ons > Plugins" page (plugins are not affected by Firefox Safe Mode)