Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Firefox 4 Back, forward, refresh buttons not working

  • 5 απαντήσεις
  • 318 έχουν αυτό το πρόβλημα
  • 236 προβολές
  • Τελευταία απάντηση από TZANETTI

more options

Upgraded to Firefox 4 yesterday. Had problems navigating as the back, forward, and refresh buttons would not work. URLs would also not show up at times. Reverted back to 3.6 and now no issues. Anyone else having this problem?

All Replies (5)

more options

I solved this problem by deleting the preferences file and letting Firefox create a new one. I lost all my preferences, however, which was a bother but not a huge one.

To try this, close Firefox 4 and open the profile folder for Firefox. If you need help finding where your profile is located, see this link:

http://kb.mozillazine.org/Profile_folder

In that folder, send the file called prefs.js to your recycle or trash bin. Then restart Firefox. The buttons should work correctly -- at least they did for me.

If you find it is too troublesome to lose the preferences, you can restore the file from your computer's recycle or trash bin. Be sure and do this when Firefox is NOT loaded as it overwrites the pref.js file when it closes.

I keep a list of changes that I make to the preferences file for all our systems, so resetting these was not a great burden. I found it rather worse not to be able to use the BACK button.

I noticed that my preferences file was loaded with obsolete settings from uninstalled extensions that did not clean house when leaving. Perhaps it is better to fumigate the preferences to keep this from happening again.

Before discovering this, I messed around trying to change obvious settings, such as those associated with history, to no avail. I also uninstalled all the existing extensions, also to no avail. This solution got it working again. Oddly, I only had this problem on one of our six systems.

Cheers

Τροποποιήθηκε στις από το χρήστη HankSnow

more options

I had this problem too and I solved it deleting line "user_pref("browser.sessionhistory.max_entries", 0);" in my prefs.js

more options

I had to back up my bookmarks and remove pretty much everything under C:\Users\<Windows login/user name>\AppData\Roaming\Mozilla\Firefox\Profiles\

It solved the problem. Now Firefox 4 runs great!

more options

I tried the solutions that dealt with prefs.js, and they did not work for me; however, I found a solution on a different web site that did work. I had installed McAfee SiteAdvisor (as I always do) after installing Firefox 4, and that was causing the problem. Disabling SiteAdvisor fixed the problem on my installation of Firefox 4.

more options

Create a new profile

Τροποποιήθηκε στις από το χρήστη TZANETTI