Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Pinterest doesn't work on firefox

  • 5 απαντήσεις
  • 3 έχουν αυτό το πρόβλημα
  • 28 προβολές
  • Τελευταία απάντηση από jscher2000

more options

I am an artist and use illustrator to make moodboards for clients.

It works fine in microsoft edge, but on firefox, the option to pin images on images on the website doesn't even show up, and it doesn't open certain pages on pinterest including my profile with all of my boards on it.

this renders pinterest unusable.

I have the default privacy settings on, and i turned off my popup blocker, adblocker, and uninstalled my pinterest button add on and facebook privacy add on.

All Replies (5)

more options

Hi lex, can you give an example of where the "Pin" buttons/links aren't working or aren't appearing?

Meanwhile, you might also check Firefox's Tracking Protection feature. If the little shield icon at the left end of the address bar has changed from gray to purple, something is being blocked in the page. Click that and see whether making an exception for the site helps with their Pin buttons.

Helpful?

more options

@jscher2000 Hey! i uninstalled and reinstalled firefox, and i am now able to look at my account and pinterest boards. the shield icon was not purple, but i disabled it anyway, as you can see in my screenshots. in my screenshots, i circled where the "save" button should be with red and included a crude recreaation of the mouse hovering over the image i also have screenshots from the page on microsoft edge, where it works.

thank you so much for your help

Helpful?

more options

Hmm, I see those overlays appear on images when I hover over them. It seems a script adds them when you mouse over an image and them removes them when you mouse out. This makes it a little difficult to investigate.

Do you have any add-ons that might mistake the overlays for ads? If you use any ad blockers, try making an exception for Pinterest, or you could test in Firefox's Safe Mode. In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, any userChrome.css/userContent.css files, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.)

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help button > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

Helpful?

more options

So it worked in safe mode, but even when i fully disabled my vpn, adblocker, and popup blocker it still wouldn't work.

Helpful?

more options

Hmm, what if you disable the popup blocker AND do a regular exit/restart of Firefox just to make sure it's not active?

Helpful?

Κάντε μια ερώτηση

Πρέπει να συνδεθείτε στο λογαριασμό σας για να απαντήσετε στις δημοσιεύσεις. Παρακαλούμε ξεκινήστε μια νέα ερώτηση, αν δεν έχετε ήδη λογαριασμό.