Pomoc pśepytaś

Glědajśo se wobšudy pomocy. Njenapominajomy was nigda, telefonowy numer zawołaś, SMS pósłaś abo wósobinske informacije pśeraźiś. Pšosym dajśo suspektnu aktiwitu z pomocu nastajenja „Znjewužywanje k wěsći daś“ k wěsći.

Learn More

Library bookmarks will not open in FF 22 private browsing window.

  • 2 wótegronje
  • 2 matej toś ten problem
  • 9 naglědow
  • Slědne wótegrono wót cor-el

more options

In the past couple of weeks (perhaps since an upgrade to FF 22?), my bookmark links will no longer open in the private browsing window. Instead, they revert to the "normal" window. Since FF switched to force private browsing into a new window instead of a new tab, it has been my practice once the private browsing window opens, to go to my "Library" screen and click on "Open In a New Tab" for whatever URL I want opened in private browsing mode.

This no longer works! No matter what Library link I click on, it opens in the normal window, not the private browsing window. The only way I've found to actually open a page in private browsing is to type by hand or copy-and-paste a URL into the location bar of the private browsing window. Very primitive.

P.S. I make sure that the private browsing screen is the last one viewed before going to the Library to click on a link.

In the past couple of weeks (perhaps since an upgrade to FF 22?), my bookmark links will no longer open in the private browsing window. Instead, they revert to the "normal" window. Since FF switched to force private browsing into a new window instead of a new tab, it has been my practice once the private browsing window opens, to go to my "Library" screen and click on "Open In a New Tab" for whatever URL I want opened in private browsing mode. This no longer works! No matter what Library link I click on, it opens in the normal window, not the private browsing window. The only way I've found to actually open a page in private browsing is to type by hand or copy-and-paste a URL into the location bar of the private browsing window. Very primitive. P.S. I make sure that the private browsing screen is the last one viewed before going to the Library to click on a link.

Wšykne wótegrona (2)

more options

Check the latest on the subject in the Private Browsing article

To keep private and public, it could make sense to keep two profiles, and set the "private" profile in such a way, that Firefox starts right away in the private mode. See

Security and passwords settings

However, I do not know if starting off in safe mode right away makes it keep the URLs.

Wót smo změnjony

more options

Yes, that is how it works.

You can use the Private Tabs extension to make such a tab a private mode tab.

Future Firefox versions will support Private Browsing per tab, this is already available as an extension.

The Firefox menu button gets a purple background or you get a purple PB mask on the menu bar or tab bar (Linux) when you are in a PB tab and all Private Browsing mode tabs get a dashed underlining unless you are in permanent PB mode.