Pomoc pśepytaś

Glědajśo se wobšudy pomocy. Njenapominajomy was nigda, telefonowy numer zawołaś, SMS pósłaś abo wósobinske informacije pśeraźiś. Pšosym dajśo suspektnu aktiwitu z pomocu nastajenja „Znjewužywanje k wěsći daś“ k wěsći.

Learn More

Hotkeys not working on Firefox.

  • 1 wótegrono
  • 0 ma toś ten problem
  • 83 naglědow
  • Slědne wótegrono wót Balázs Meskó

more options

I use a public computer often, and I would like to use certain customizations while remaining anonymous. Rather than going through and clicking a bunch of checkboxes, I decided to have a hot key combination to enter in order to obtain my desired options. For example, I want to allow new windows to open normally, I want to choose where files are saved, and I want to turn off Firefox's recommendations. The underlined hotkeys are, respectively, ALT+W, ALT+A, and ALT+R ALT+F. So rather than a bunch of scrolling and clicking, I could just type ALT+WARF, and get the options I want quickly.

However, pressing the hotkeys while in the settings does not seem to do anything. In particular, pressing ALT+WARF only succeeds in pressing the ALT+F, which opens the File menu. Pressing these keys without an ALT key sends them automatically to the search bar -- which is also not what I want. Pressing ALT+SHIFT focuses in on the checkbox -- but does not press it. For example, ALT+SHIFT+W focuses on the checkbox, but I still have to click SPACE after it to press it.

Is this a bug? If not, how can I make the underlined keys press the respective checkboxes?

I use a public computer often, and I would like to use certain customizations while remaining anonymous. Rather than going through and clicking a bunch of checkboxes, I decided to have a hot key combination to enter in order to obtain my desired options. For example, I want to allow new windows to open normally, I want to choose where files are saved, and I want to turn off Firefox's recommendations. The underlined hotkeys are, respectively, ALT+W, ALT+A, and ALT+R ALT+F. So rather than a bunch of scrolling and clicking, I could just type ALT+WARF, and get the options I want quickly. However, pressing the hotkeys while in the settings does not seem to do anything. In particular, pressing ALT+WARF only succeeds in pressing the ALT+F, which opens the File menu. Pressing these keys without an ALT key sends them automatically to the search bar -- which is also not what I want. Pressing ALT+SHIFT focuses in on the checkbox -- but does not press it. For example, ALT+SHIFT+W focuses on the checkbox, but I still have to click SPACE after it to press it. Is this a bug? If not, how can I make the underlined keys press the respective checkboxes?

Wšykne wótegrona (1)

more options

There is no bug here. Alt activates the main menu using the accelerator keys, as it does in any application. The Settings page has some special logic to allow Alt+Shift to search on it, and it works similarly to accelerator keys, namely:

  • if there is only a single match, then it activates it at once
  • if there are multiple matches, then it selects the next one (first, second, etc.), but does not activate it

So in short, it does not activate them because there is a key collision.

Wužytny?

Stajśo pšašanje

Musyśo se pla swójogo konta pśizjawiś, aby na pśinoski wótegronił. Pšosym stajśo pšašanje, jolic hyšći njamaśo wužywaŕske konto.