Pomoc pśepytaś

Glědajśo se wobšudy pomocy. Njenapominajomy was nigda, telefonowy numer zawołaś, SMS pósłaś abo wósobinske informacije pśeraźiś. Pšosym dajśo suspektnu aktiwitu z pomocu nastajenja „Znjewužywanje k wěsći daś“ k wěsći.

Learn More

Theme Changes Some Components to Dark-mode Despite Override

  • 7 wótegrona
  • 0 ma toś ten problem
  • 51 naglědow
  • Slědne wótegrono wót zeroknight

more options

Hiya,

I use a theme which some years ago (after a change in the way Firefox handles dark-mode preferences) changed all UI and websites to use dark-mode. I was able to keep using the theme, and mostly override this behavior by setting:

`layout.css.prefers-color-scheme.content-override = 1`

However, this didn't take for some components, such as the sidebar and bookmark editor window, which still continue to use dark-mode.

Is there any way to completely disable dark-mode everywhere, and still use my preferred theme?

Cheers, Afraz

Hiya, I use a theme which some years ago (after a change in the way Firefox handles dark-mode preferences) changed all UI and websites to use dark-mode. I was able to keep using the theme, and mostly override this behavior by setting: `layout.css.prefers-color-scheme.content-override = 1` However, this didn't take for some components, such as the sidebar and bookmark editor window, which still continue to use dark-mode. Is there any way to completely disable dark-mode everywhere, and still use my preferred theme? Cheers, Afraz

Wubrane rozwězanje

You can edit the theme manifest file and change "color_scheme" to "light" then either submit it as a new theme or install it on Developer Edition with signature enforcement disabled.

Toś to wótegrono w konteksće cytaś 👍 0

Wšykne wótegrona (7)

more options

Could be incompatible themes or userChrome.css. If these aren't Firefox defaults or Firefox themes site download then you might want to check the site your getting them from to verify it's compatible with latest version of Firefox.

more options

We can rule out `userChrome.css`, because I don't have one :)

It could well be an "incompatible" theme. I got it from the normal theme page for Firefox, and this started happening some time ago, when Firefox changed the way themes effect dark-mode.

I'd really like to keep using this theme though, so am willing to create the necessary entries in a `userChrome.css`. Trouble is, I have no idea what I need to set. Is there documentation somewhere I can look up for changing the appearance of all the extra UI windows like the history browser, bookmarks browser, etc.?

more options

Wubrane rozwězanje

You can edit the theme manifest file and change "color_scheme" to "light" then either submit it as a new theme or install it on Developer Edition with signature enforcement disabled.

more options

Marked @zeroknight's answer as correct, but it bears further explanation.

This is what needs to be added in the manifest:

``` ...

   "properties": {
     "color_scheme": "light"
   }

... ```

It seems that if a theme doesn't set `properites.color_scheme`, then Firefox defaults to "dark" (my OS is set to light), which is disappointing.

more options

Themes are meant to override the OS theme. The light/dark color scheme is decided by the theme's toolbar and text colors if one isn't specified.

more options

So given the following manifest, Firefox would use "dark"?

{

 "theme": {
   "images": {
     "theme_frame": "fox1_head.png"
   },
   "colors": {
     "frame": "#12455e",
     "tab_background_text": "#ffffff"
   },
 },
 "version": "2.0",
 "name": "Have a Light Fox Dream",
 "manifest_version": 2,
 "description": "Enjoy more!"

}

Wót afrazkhan změnjony

more options

afrazkhan said

"tab_background_text": "#ffffff"

Light text will make the color scheme dark.