Pomoc pśepytaś

Glědajśo se wobšudy pomocy. Njenapominajomy was nigda, telefonowy numer zawołaś, SMS pósłaś abo wósobinske informacije pśeraźiś. Pšosym dajśo suspektnu aktiwitu z pomocu nastajenja „Znjewužywanje k wěsći daś“ k wěsći.

Learn More

Private window not so private

  • 7 wótegrona
  • 3 maju toś ten problem
  • 64 naglědow
  • Slědne wótegrono wót DPro

more options

If I leave my current session open, then log in to gmail in a private window then close that private window the previous opened window that previously was not logged into gmail is now logged in. So the privacy of the new private window is not so private.

If I leave my current session open, then log in to gmail in a private window then close that private window the previous opened window that previously was not logged into gmail is now logged in. So the privacy of the new private window is not so private.

Wubrane rozwězanje

Do your private windows show the "mask" icon? I put an arrow pointing to it in the second image. If not, you may have Firefox set to automatic private browsing. In that mode, all windows are private and therefore all windows share a single cookie jar. You can check on the Options page here:

"3-bar" menu button (or Tools menu) > Options > Privacy

If the selector is set to "Firefox will: Never remember history" change it temporarily to "Firefox will: Use custom settings for history".

Is the box checked to "Always use private browsing mode"?

Toś to wótegrono w konteksće cytaś 👍 1

Wšykne wótegrona (7)

more options

Does this also happen if you open a new normal window?

Start Firefox in Safe Mode to check if one of the extensions (Firefox menu button/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox menu button/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
more options

Yes this happens with a new normal window as well. It also happens in safe mode. It appears that there is some connection between the private window and the normal window within Firefox that puts the log in information into both windows and leaves it there even after the private window is closed.

This isn't a huge deal to me its just an observation.

I tried somethin else. I opened a normal window then went to the gmail log in page. I did not enter any information there. I then opened a private window and logged into gmail. Then I went back to the normal window and clicked the next button without entering my email in the log in window. The window hesitated for a moment the line came up in red telling me to enter my email information then the screen changed and my gmail opened as if I had filled in the name and password. There was a hesitation as if firefox or google was searching out the info.

Wót DPro změnjony

more options

Regular windows and private windows should have two completely separate cookie jars. You should be able to log into two completely different Google accounts, one in regular windows and another in private windows. Logging out in one shouldn't affect the other. That session should never cross over.

But: form history and saved passwords can be used in any tab, regular or private. It may appear from a form history entry or saved login that Google crossed some data over, but with these features, you are just seeing the same Firefox behavior in different tabs.

more options

I have Firefox set to delite on exit and save nothing. I have no saved passwords. I would conclude that Firefox private window is flawed in some way. Try it youself and see what happens.

more options

DPro said

Try it youself and see what happens.

Here's what I did:

(1) Opened a regular window to the Gmail login screen (first screen shot)

(2) Opened a private window, logged into Gmail, viewed a message (second screen shot)

(3) Logged out of Gmail in the private window and closed the window

(4) Reloaded the Gmail login screen in the regular window to see whether it would pick up any trace of my private window login (third screen shot)

Behaved as expected. No change in the regular window, in particular, the user name does not show up as it would if you had logged in/out in a regular window.

more options

Wubrane rozwězanje

Do your private windows show the "mask" icon? I put an arrow pointing to it in the second image. If not, you may have Firefox set to automatic private browsing. In that mode, all windows are private and therefore all windows share a single cookie jar. You can check on the Options page here:

"3-bar" menu button (or Tools menu) > Options > Privacy

If the selector is set to "Firefox will: Never remember history" change it temporarily to "Firefox will: Use custom settings for history".

Is the box checked to "Always use private browsing mode"?

more options

Nice one! I reset to custom settings and all is as it should be. Thank you