X
Tippen Sie hierhin, um die Version dieser Website für Mobilgeräte aufzurufen.

Hilfeforum

How do I make firefox use http instead of https?

Veröffentlicht

In my company's internet it is problematic to use https. However firefox always defaults to https connections (e.g. when making a google search from the search toolbar, or when typing an address bar starting with "www"); therefore always bringing up an "This Connection is Untrusted" alert page and making me have to manually go to the address bar and changing the "https" to "http". In Google Chrome and Internet Explorer it is very easy to set the browser to use http instead of https. However, I can't seem to find this option in firefox. Any ideas?

In my company's internet it is problematic to use https. However firefox always defaults to https connections (e.g. when making a google search from the search toolbar, or when typing an address bar starting with "www"); therefore always bringing up an "This Connection is Untrusted" alert page and making me have to manually go to the address bar and changing the "https" to "http". In Google Chrome and Internet Explorer it is very easy to set the browser to use http instead of https. However, I can't seem to find this option in firefox. Any ideas?

Ausgewählte Lösung

There are two different settings involved:

Address Bar Autofill

If you have used HTTPS on a site before, Firefox's address bar autofill feature will prefer the HTTPS address. If you don't mind selecting from the drop-down instead, or simply typing the whole address, you can turn off the address bar autofill. Here's how:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the filter box, type or paste autofill and pause while the list is filtered

(3) Double-click browser.urlbar.autoFill to toggle it from true to false.

Address Bar Search

Regarding address bar search, you can change the URL used by the "keyword" service. Please see this thread for links: Unable to connect to proxy due to automatic https.

Does that solve it?

Diese Antwort im Kontext lesen 7

Mehr Details zum System

Installierte Plugins

  • Shockwave Flash 11.7 r700
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.03
  • Next Generation Java Plug-in 1.6.0_33 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • 5.1.20125.0
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Anwendung

  • User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:21.0) Gecko/20100101 Firefox/21.0

Weitere Informationen

jscher2000
  • Top 10 Contributor
7448 Lösungen 60790 Antworten
Veröffentlicht

Ausgewählte Lösung

There are two different settings involved:

Address Bar Autofill

If you have used HTTPS on a site before, Firefox's address bar autofill feature will prefer the HTTPS address. If you don't mind selecting from the drop-down instead, or simply typing the whole address, you can turn off the address bar autofill. Here's how:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the filter box, type or paste autofill and pause while the list is filtered

(3) Double-click browser.urlbar.autoFill to toggle it from true to false.

Address Bar Search

Regarding address bar search, you can change the URL used by the "keyword" service. Please see this thread for links: Unable to connect to proxy due to automatic https.

Does that solve it?

There are two different settings involved: '''Address Bar Autofill''' If you have used HTTPS on a site before, Firefox's address bar autofill feature will prefer the HTTPS address. If you don't mind selecting from the drop-down instead, or simply typing the whole address, you can turn off the address bar autofill. Here's how: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter. Click the button promising to be careful. (2) In the filter box, type or paste '''autofill''' and pause while the list is filtered (3) Double-click '''browser.urlbar.autoFill''' to toggle it from true to false. '''Address Bar Search''' Regarding address bar search, you can change the URL used by the "keyword" service. Please see this thread for links: [https://support.mozilla.org/en-US/questions/955363 Unable to connect to proxy due to automatic https]. Does that solve it?