X
Tippen Sie hierhin, um die Version dieser Website für Mobilgeräte aufzurufen.

Hilfeforum

SPDY enabled in FF 12.0 prevents Gmail loading

Veröffentlicht

If I enable SPDY in FF 12.0 I can not connect to Gmail. The connection tries but just stalls with the connection indicator on the tab turning slowly anticlockwise. I can connect to Gmail with Chrome, which I believe has SPDY enabled by default.

If I enable SPDY in FF 12.0 I can not connect to Gmail. The connection tries but just stalls with the connection indicator on the tab turning slowly anticlockwise. I can connect to Gmail with Chrome, which I believe has SPDY enabled by default.

Ausgewählte Lösung

I too thought the problem was with network.http.spdy.enabled, if I disabled it Gmail and Google would load. But further investigation lead me to this page and solution: http://forums.mydigitallife.info/threads/34380-firefox-13-google-com-SPYD-no-search . Apparently at some point I changed the setting on network.http.keepalive to false, it showed user set, once I change it to true and reset the other to true all worked well.

Diese Antwort im Kontext lesen 6

Mehr Details zum System

Installierte Plugins

Google Earth, Google Update, Java, PDF-Xchange, Shockwave Flash, Shockwave for Director, Windows Media Player, Windows Presentation Foundation.

Anwendung

  • User-Agent: Mozilla/5.0 (Windows NT 5.1; rv:12.0) Gecko/20100101 Firefox/12.0

Weitere Informationen

cor-el
  • Top 10 Contributor
  • Moderator
17574 Lösungen 158975 Antworten
Veröffentlicht

@Gene1940

Does it help if you reset all prefs?


Clear the cache and the cookies from sites that cause problems.

"Clear the Cache":

  • Tools > Options > Advanced > Network > Offline Storage (Cache): "Clear Now"

"Remove Cookies" from sites causing problems:

  • Tools > Options > Privacy > Cookies: "Show Cookies"

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance/Themes).

@Gene1940 Does it help if you reset all prefs? *http://kb.mozillazine.org/Resetting_preferences *https://support.mozilla.org/kb/Resetting+preferences ---- Clear the cache and the cookies from sites that cause problems. "Clear the Cache": *Tools > Options > Advanced > Network > Offline Storage (Cache): "Clear Now" "Remove Cookies" from sites causing problems: *Tools > Options > Privacy > Cookies: "Show Cookies" Start Firefox in <u>[[Safe Mode]]</u> to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance/Themes). *Don't make any changes on the Safe mode start window. *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes
Gene1940 4 Lösungen 57 Antworten
Veröffentlicht

I mentioned that before, but I'll give more detail.

Windows 7 64-bit SP1

It was a clean install on a new hard drive last fall. In other words, there are no old remnants of anything. :-)

I mentioned that before, but I'll give more detail. Windows 7 64-bit SP1 It was a clean install on a new hard drive last fall. In other words, there are no old remnants of anything. :-)

Geändert am von Gene1940

cor-el
  • Top 10 Contributor
  • Moderator
17574 Lösungen 158975 Antworten
Veröffentlicht

Create a new profile as a test to check if your current profile is causing the problems.

See "Basic Troubleshooting: Make a new profile":

There may be extensions and plugins installed by default in a new profile, so check that in "Tools > Add-ons > Extensions & Plugins" in case there are still problems.

If the new profile works then you can transfer some files from the old profile to that new profile, but be careful not to copy corrupted files.

See:

Create a new profile as a test to check if your current profile is causing the problems. See "Basic Troubleshooting: Make a new profile": *https://support.mozilla.org/kb/Basic+Troubleshooting#w_8-make-a-new-profile There may be extensions and plugins installed by default in a new profile, so check that in "Tools > Add-ons > Extensions & Plugins" in case there are still problems. If the new profile works then you can transfer some files from the old profile to that new profile, but be careful not to copy corrupted files. See: *http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox
Gene1940 4 Lösungen 57 Antworten
Veröffentlicht

This is definitely a little weird. I just changed SPDY back to true and was able to log into GMail several times, and even send mail, with no problems at all.

Last evening I switched between true and false several times. Setting SPDY to true always caused GMail to fail.

Maybe last night was a Google problem. Or maybe something magically fixed itself on my machine.

This is definitely a little weird. I just changed SPDY back to true and was able to log into GMail several times, and even send mail, with no problems at all. Last evening I switched between true and false several times. Setting SPDY to true always caused GMail to fail. Maybe last night was a Google problem. Or maybe something magically fixed itself on my machine.

Geändert am von Gene1940

Fragesteller

matt832, thanks, good work, that was my problem. I too had disabled both network.http.keep-alive and network.http.proxy.keep-alive. Enabled them and can now connect to gmail with SPDY enabled. I had tried most other solutions but never thought keep-alive could be an issue. Very strange.

matt832, thanks, good work, that was my problem. I too had disabled both network.http.keep-alive and network.http.proxy.keep-alive. Enabled them and can now connect to gmail with SPDY enabled. I had tried most other solutions but never thought keep-alive could be an issue. Very strange.

Fragesteller

A further thought on SPDY needing "network.http.keep-alive" to function. SPDY has a push component so Google and other adopters can send content, maybe ads, without a request using SPDY. I would have thought my router's firewall would prevent this so maybe they use a "keep-alive" request to get through firewalls. Perhaps I am being paranoid but I will disable SPDY until I know more about it.

A further thought on SPDY needing "network.http.keep-alive" to function. SPDY has a push component so Google and other adopters can send content, maybe ads, without a request using SPDY. I would have thought my router's firewall would prevent this so maybe they use a "keep-alive" request to get through firewalls. Perhaps I am being paranoid but I will disable SPDY until I know more about it.
neffer85 0 Lösungen 2 Antworten
Veröffentlicht

The SPDY fix doesn't work for me. I'm running Vista Service Pack 2 and have V. 13 of Firefox. I updated a few days ago and Gmail suddenly stopped working. Any other solutions or suggestions? I've tried uninstalling/reinstalling, making sure all of my add-ons are up to date, and clearing cache/cookies. It works in IE and Chrome.

The SPDY fix doesn't work for me. I'm running Vista Service Pack 2 and have V. 13 of Firefox. I updated a few days ago and Gmail suddenly stopped working. Any other solutions or suggestions? I've tried uninstalling/reinstalling, making sure all of my add-ons are up to date, and clearing cache/cookies. It works in IE and Chrome.

Fragesteller

neffer85, I have not found any other problem related to SPDY with Gmail. If you are sure you have enabled "network.http.keep-alive" and also possibly "network.http.proxy.keep-alive", then I suggest you disable SPDY in "about:config" to confirm that it is causing your problem. If you can then connect to Gmail, I suggest you leave SPDY disabled and wait for FF14 as I believe there are some changes related to this issue. You won't notice much if any difference without SPDY at present but remember to enable SPDY when you update to FF14 and try it again. BTW, there is a FF version 13.0.1 available.

neffer85, I have not found any other problem related to SPDY with Gmail. If you are sure you have enabled "network.http.keep-alive" and also possibly "network.http.proxy.keep-alive", then I suggest you disable SPDY in "about:config" to confirm that it is causing your problem. If you can then connect to Gmail, I suggest you leave SPDY disabled and wait for FF14 as I believe there are some changes related to this issue. You won't notice much if any difference without SPDY at present but remember to enable SPDY when you update to FF14 and try it again. BTW, there is a FF version 13.0.1 available.
Gene1940 4 Lösungen 57 Antworten
Veröffentlicht

This is just a shot in the dark, but you might try adjusting some GMail options also. The new version of GMail is not ready for prime time, with numerous bugs, and Google makes it painfully complicated to report problems.

This is just a shot in the dark, but you might try adjusting some GMail options also. The new version of GMail is not ready for prime time, with numerous bugs, and Google makes it painfully complicated to report problems.
ZZ Jet 0 Lösungen 2 Antworten
Veröffentlicht

Matt_G,

I posted detail what I did at this thread https://support.mozilla.org/en-US/questions/931517#answer-350281

Matt_G, I posted detail what I did at this thread https://support.mozilla.org/en-US/questions/931517#answer-350281