Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

How to set View Source to open in editor of choice?

  • 6 Antworten
  • 38 haben dieses Problem
  • 13269 Aufrufe
  • Letzte Antwort von picknb

more options

In IE you can set View Source to open in your editor of choice e.g. Notepad++? How do you do that in Firefox?

Ausgewählte Lösung

You can do this by changing 2 hidden preferences.

  1. Type about:config into the location bar and press enter
  2. Accept the warning message that appears, you will be taken to a list of preferences
  3. In the filter box type view_source
  4. Double-click on view_source.editor.external to change its value to true
  5. Double-click on view_source.editor.path and set it to C:\Program Files\Notepad++\notepad++.exe (if Notepad++ is stored elsewhere change that to where it is stored)

You can also do this by using the Dafizilla ViewSourceWith add-on.

Diese Antwort im Kontext lesen 👍 19

Alle Antworten (6)

more options

Ausgewählte Lösung

You can do this by changing 2 hidden preferences.

  1. Type about:config into the location bar and press enter
  2. Accept the warning message that appears, you will be taken to a list of preferences
  3. In the filter box type view_source
  4. Double-click on view_source.editor.external to change its value to true
  5. Double-click on view_source.editor.path and set it to C:\Program Files\Notepad++\notepad++.exe (if Notepad++ is stored elsewhere change that to where it is stored)

You can also do this by using the Dafizilla ViewSourceWith add-on.

more options

You have out-of-date plugins. It is important to keep them updated due to continuing security fixes and improvements in those plug-ins:

  1. Check your plugin versions: http://www.mozilla.com/en-US/plugincheck/
    • Note: plugin check page does not have information on all plugin versions
  2. Update Adobe Reader (PDF plugin):
    • From within your existing Adobe Reader (if you have it already installed):
      • Open the Adobe Reader program from your Programs list
      • Click Help > Check for Updates
      • Follow the prompts for updating
      • If this method works for you, skip the "Download complete installer" section below and proceed to "After the installation" below
    • Download complete installer (if you do NOT have Adobe Reader installed):
      • Use Firefox to download and SAVE the installer to your hard drive from the link in the article below
      • On the Adobe page, un-check any extra items (i.e. Free McAfee® Security Scan Plus) then click Download button
      • If you see message just under tabs, DO NOT click the Allow button, instead click below that where it says "click here to download".
      • Click "Save to File"; save to your Desktop (so you can find it)
      • After download completes, close Firefox
      • Click the installer you just downloaded and allow the install to continue
        • Note: Vista and Win7 users may need to right-click the installer and choose "Run as Administrator"
      • Download link and more information: https://support.mozilla.com/en-US/kb/Using+the+Adobe+Reader+plugin+with+Firefox#Installing_and_updating_Adobe_Reader
    • After the installation, start Firefox and check your version again.
  3. Update Java:
more options

Thanks, that worked great :)

more options

worked great, but only for whole page. how make it for selected text?

more options

Followed the steps, and restarted computer -- NOT WORKING -- View Page Source still uses Firefox's default viewer.

Rigorous details of what I did (probably no surprises here): (1) I typed "about:config" in the Firefox address box, and hit enter; I typed "view_source" in the Filter box, and hit enter. (2) I double-clicked view_source.editor.path; I was prompted to input the path into a text box. (3) I right-clicked the Notepad++ icon, and selected Properties. The Target: text box showed "C:\Program Files\Notepad++\notepad++.exe" highlighed. (4) I copy/pasted into Firefox's text box for view_source.editor.path, and clicked Ok. it now shows "C:\Program Files\Notepad++\notepad++.exe" (quote marks included). (5) I double-clicked view_source.editor.external, so that its value now shows as "true". (6) I closed all Firefox windows, and even restarted the computer.

more options

Try getting rid of the quotes.

Also test the path to the exe in Start | Run.