Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Telefonnummer anzurufen, eine SMS an eine Telefonnummer zu senden oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

Windows taskbar doesn't unhide itself when firefox is maximised.

  • 13 Antworten
  • 3 haben dieses Problem
  • 40 Aufrufe
  • Letzte Antwort von qproject101

more options

Automatically hide taskbar in desktop mode => Enabled Firefox => Maximised When cursor is moved to outer edge of screen, taskbar should unhide (Expected behaviour) but in this case it remain hidden (Reality). Firefox along with all other spinoffs give same result. Chromium based browser works perfect, and taskbar automatically unhide itself.

As OLED screen have became common as monitor, Taskbar auto-hide is must. If this issue cann't be fixed I may have to change my primary browser which I used for almost 15 years.

Kindly, look into it. If Chromium can do it, why not Firefox.

Automatically hide taskbar in desktop mode => Enabled Firefox => Maximised When cursor is moved to outer edge of screen, taskbar should unhide (Expected behaviour) but in this case it remain hidden (Reality). Firefox along with all other spinoffs give same result. Chromium based browser works perfect, and taskbar automatically unhide itself. As OLED screen have became common as monitor, Taskbar auto-hide is must. If this issue cann't be fixed I may have to change my primary browser which I used for almost 15 years. Kindly, look into it. If Chromium can do it, why not Firefox.

Ausgewählte Lösung

Hello, Everyone, For me doing this resolved the issue => I am using 'Built In Administrator account' as my primary account and its the only account on computer.

Firefox.exe > Properties > Compatibility > Change setting for all users > Change high DPI settings > Override High DPI Scaling (Application).

After this taskbar auto-hide and unhide worked as expected in FF maximised mode.

Diese Antwort im Kontext lesen 👍 1

Alle Antworten (13)

more options

With OLED screens, screen burn in is a serious and annoying issue. I understand your need to auto-hide the taskbar. Can you please attach the screenshot of your desktop window where this is occurring?

And just for troubleshooting, can you please do the following

  1. Close all running instances of Firefox
  2. In Windows 10 Settings > Taskbar Settings disable the option, Automatically hide the taskbar in desktop mode Please refer to the attached screenshot for more details.
  3. start firefox browser.
  4. Maximize the browser by using the key combination ALT + Spacebar and then selecting the option Maximize
  5. Enable the Autohide of the taskbar in desktop mode in the setting.
  6. Check if the browser takes up the entire screen

Hilfreich?

more options

If you are genuinely concerned by OLED burn-in, you should be using floating windows rather than maximized ones.

Third-party software may interfere with the taskbar autohide mechanism, try disabling graphics overlays like Nvidia's FPS counter and other third-party modules in about:third-party.

Hilfreich?

more options

@ixian, Thanks for replying => I have done what you said, using ALT+spacebar was no change. For the screenshot I have attached 2 pics of chrome and firefox behaviour respectively. In firefox cursor moved to the border doesn't doesn't brings up taskbar whereas in chorme case it does. (CLEARLY VISIBLE IN PIC)

@zeroknight, Thanks for replying => My PC has only CPU integrated graphics, no dedicated card at all, so drivers issue is not possible at all. About third party, I uploaded respective image, what should I do with them, are they causing this issue? I cann't use floating window because of decreased usable space.

In the end I just wish firefox to unhide taskbar like chrome is doing, when cursor moves to extreme end.

Hilfreich?

more options

Try changing browser.launcherProcess.enabled to false in about:config temporarily, then change it back to true and restart the browser.

Hilfreich?

more options

@zeroknight => I did Exactly as you told, but the problem still persist. Even forks like Librewolf and Floorp which are based on much older version of firefox, has the same issue. I think the problem lies in core functionality of FF, on which FF team should definitely work upon. Furthermore, no chromium based browser\forks suffer from this problem. Still, any more suggestion-troubleshoot advice is welcome and thanks for replying.

Hilfreich?

more options

Try to use normal mode and drag the window as large as possible instead of using maximized mode.

Try to rename/remove xulstore.json in the Firefox profile folder with Firefox closed.

You can use the button on the "Help -> More Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page (Root directory).

Hilfreich?

more options

@cor-el Thanks for replying => Though I have already tried it before, but did it again as you mentioned and just as before the problem still persists. Because I have just 1 PC, I cann't even verify it on other system. Does taksbar un-hide perfectely works for you guys when FF is maximised ?

Hilfreich?

more options

idsks111 said

@ixian, Thanks for replying => I have done what you said, using ALT+spacebar was no change. For the screenshot I have attached 2 pics of chrome and firefox behaviour respectively. In firefox cursor moved to the border doesn't doesn't brings up taskbar whereas in chorme case it does. (CLEARLY VISIBLE IN PIC) @zeroknight, Thanks for replying => My PC has only CPU integrated graphics, no dedicated card at all, so drivers issue is not possible at all. About third party, I uploaded respective image, what should I do with them, are they causing this issue? I cann't use floating window because of decreased usable space. In the end I just wish firefox to unhide taskbar like chrome is doing, when cursor moves to extreme end.

What @zeroknight said is also relevant. The task bar may not auto-hide due to interference from other applications or changes in the status of system icons. For example Windows Security Notification icon, Nvidia's icons, bit torrent applications, etc can also cause it.

Hilfreich?

more options

idsks111 said

@cor-el Thanks for replying => Though I have already tried it before, but did it again as you mentioned and just as before the problem still persists. Because I have just 1 PC, I cann't even verify it on other system. Does taksbar un-hide perfectely works for you guys when FF is maximised ?

I have a windows 10 22H2 computer. It is running Firefox 124.0.2. When I did the steps that I had given earlier, it worked for me. I have kept it on till now and the taskbar autohides. I am assuming that your setup is similar.

Hilfreich?

more options

Ausgewählte Lösung

Hello, Everyone, For me doing this resolved the issue => I am using 'Built In Administrator account' as my primary account and its the only account on computer.

Firefox.exe > Properties > Compatibility > Change setting for all users > Change high DPI settings > Override High DPI Scaling (Application).

After this taskbar auto-hide and unhide worked as expected in FF maximised mode.

Hilfreich?

more options

Hello, FF 125.03 on Windows 11 Pro 22H2

Auto-hide taskbar is broken for me after the update and I did change the DPI and still not working for me.

Taskbar hide but cannot bring it back up with mouse.

Hilfreich?

more options

@qproject101, Try to go deeper => Properties > Compatibility > Change setting for all users > Change high DPI settings > Override High DPI Scaling (Application)

Hilfreich?

more options

idsks111 said

@qproject101, Try to go deeper => Properties > Compatibility > Change setting for all users > Change high DPI settings > Override High DPI Scaling (Application)

Sorry, I've fixed the issue. I had Nvidia App Beta installed and to resolve the issue I disable Nvidia App > reboot and re-enable Nvidia App.

The latest update seems to break taskbar from Nvidia.

Thanks for the quick reply.

Hilfreich?

Stellen Sie eine Frage

Sie müssen sich mit Ihrem Benutzerkonto anmelden, um auf Beiträge zu antworten. Bitte stellen Sie eine neue Frage, wenn Sie noch kein Benutzerkonto haben.