Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Telefonnummer anzurufen, eine SMS an eine Telefonnummer zu senden oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

How to disable language-aware word selection when double-clicking on text for certain language?

  • 7 Antworten
  • 0 haben dieses Problem
  • 48 Aufrufe
  • Letzte Antwort von jamie94

more options

I want to disable the "language-aware word selection when double-clicking on text" feature that shipped in 122.0 (https://www.mozilla.org/en-US/firefox/122.0/releasenotes/)

This new feature is cool, but it has actually slowed down the speed at which I select text. Originally, I could double-click to select an entire sentence, but now a double-click only selects a single word.

It would be great if there was a way to disable this feature for a specific language.

Thank you.

I want to disable the "language-aware word selection when double-clicking on text" feature that shipped in 122.0 (https://www.mozilla.org/en-US/firefox/122.0/releasenotes/) This new feature is cool, but it has actually slowed down the speed at which I select text. Originally, I could double-click to select an entire sentence, but now a double-click only selects a single word. It would be great if there was a way to disable this feature for a specific language. Thank you.

Ausgewählte Lösung

This comes from bug 1854032, so try to enter about:config in the address bar and set intl.icu4x.segmenter.enabled to false.

Diese Antwort im Kontext lesen 👍 1

Alle Antworten (7)

more options

You need to use a triple-click to select a full sentence, this has been the case for quite some time.

Hilfreich?

more options

cor-el said

You need to use a triple-click to select a full sentence, this has been the case for quite some time.

That's the new case for me since 122.0

Perhaps there was an issue with the way I described it.

In the previous version, double-clicking on the text would only select the content before the comma, while triple-clicking would select everything from after the comma to before the period, which is not the result I wanted.

Hilfreich?

more options

Ausgewählte Lösung

This comes from bug 1854032, so try to enter about:config in the address bar and set intl.icu4x.segmenter.enabled to false.

Hilfreich?

more options

jamie94 said

In the previous version, double-clicking on the text would only select the content before the comma, while triple-clicking would select everything from after the comma to before the period, which is not the result I wanted.

Where are you seeing this? Can you link to an example?

Hilfreich?

more options

TyDraniu said

This comes from bug 1854032, so try to enter about:config in the address bar and set intl.icu4x.segmenter.enabled to false.

Thank you very much, this method has solved my problem.

Hilfreich?

more options

how to delete this

Geändert am von jamie94

Hilfreich?

more options

zeroknight said

jamie94 said

In the previous version, double-clicking on the text would only select the content before the comma, while triple-clicking would select everything from after the comma to before the period, which is not the result I wanted.

Where are you seeing this? Can you link to an example?

I recorded a video so you can see the difference between enabling this feature or not (it is enabled by default in version 122.0).

When the feature is disabled, double-clicking on Chinese content will select an entire passage rather than individual Chinese words, and it seems to have no effect on English text, whether it is enabled or not.

This is exactly what I need.

https://www.youtube.com/watch?v=mngcIv2fwKo

Hilfreich?

Stellen Sie eine Frage

Sie müssen sich mit Ihrem Benutzerkonto anmelden, um auf Beiträge zu antworten. Bitte stellen Sie eine neue Frage, wenn Sie noch kein Benutzerkonto haben.