Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Telefonnummer anzurufen, eine SMS an eine Telefonnummer zu senden oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

Japanese Input not appearing

  • 5 Antworten
  • 1 hat dieses Problem
  • 11 Aufrufe
  • Letzte Antwort von zeroknight

more options

Since about one year I am unable to use Japanese input only in Firefox. When I try to switch with fcitx and control+space, nothing happens. However, fcitx-mocz works everywhere else on my computer (i.e. terminal, thunderbird, other browsers, etc.). Furthermore, I uninstalled fcitx and everything associated with it and reinstalled it according to this thread: https://support.mozilla.org/en-US/questions/1367181 (just with mocz for Japanese). This also didn't change anything. Any help is appreciated! My system: Operating System: Linux Mint 20.3 Kernel: Linux 5.15.0-91-generic Architecture: x86-64 fcitx version: 4.2.9.7 Mozilla Firefox 121.0

Since about one year I am unable to use Japanese input only in Firefox. When I try to switch with fcitx and control+space, nothing happens. However, fcitx-mocz works everywhere else on my computer (i.e. terminal, thunderbird, other browsers, etc.). Furthermore, I uninstalled fcitx and everything associated with it and reinstalled it according to this thread: https://support.mozilla.org/en-US/questions/1367181 (just with mocz for Japanese). This also didn't change anything. Any help is appreciated! My system: Operating System: Linux Mint 20.3 Kernel: Linux 5.15.0-91-generic Architecture: x86-64 fcitx version: 4.2.9.7 Mozilla Firefox 121.0

Alle Antworten (5)

more options

Another user mentioned this recently however it works for me on Ubuntu 23.10.

Hilfreich?

more options

zeroknight schrieb

Another user mentioned this recently however it works for me on Ubuntu 23.10.


Unfortunately, this didn't help.

Geändert am von Paracelsus

Hilfreich?

more options

Try installing a different package format like flatpak.

Hilfreich?

more options

I've got a similar problem for over year now. I'm on MX Linux, with their packaged version of Firefox using the official binaries (firefox/mx,now 125.0~mozillabinaries-1mx23+1) as well as fcitx5-mozc. (I've also tried the ESR version from debian and I think even the flatpak) IME works like a charm (almost) everywhere else, including Thunderbird and the Tor browser. In Firefox however, it's like fcitx wasn't installed.

I took another swing at this and discovered that on a fresh Firefox profile, Japanese input does work as expected! So there has to be some setting somewhere in my profile that breaks IME. Incidentally, composing accented letters using the ` key also doesn't work in my old profile (I can't type accents at all, seemingly nothing happens when I press that key), but functions fine in a new one.

I've searched in about:settings and about:config for "input", "key" and "ime", but nothing caught my eye as a possible culprit. Please let me know if you have any idea which preferences I could try resetting! This profile has been with me for 9 years and 3 operating systems, and I'd like to avoid migrating my settings, add-ons and userchrome to a new one.

TL;DR: If your fcitx/ibus input methods don't work in Firefox despite everything being set up correctly and working everywhere else, try the following: - Go to about:profiles - Create a New Profile - Click the "Launch profile in new browser" button on the new profile - See if your input method works in the new profile

Hilfreich?

more options

Backup your profile folder and try renaming the prefs.js file to see if it is caused by an about:config setting.

Hilfreich?

Stellen Sie eine Frage

Sie müssen sich mit Ihrem Benutzerkonto anmelden, um auf Beiträge zu antworten. Bitte stellen Sie eine neue Frage, wenn Sie noch kein Benutzerkonto haben.