Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Telefonnummer anzurufen, eine SMS an eine Telefonnummer zu senden oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

Thunderbird keep asking login to gmail.

  • 2 Antworten
  • 1 hat dieses Problem
  • 905 Aufrufe
  • Letzte Antwort von Toad-Hall

more options

Hi,

I used to use Thunderbird to access Gmail, Yahoo mail and normal email account (all POP3).

I have updated (not reinstall) Thunderbird to the latest version since Gmail disabled non secure apps access.

I have changed the Authentication to OAuth by follow the instruction from your page, but the system keep asking me to login (I have grant access in Gmail).

This happens not only Gmail as well as my Yahoo mail and normal POP3 account. I am sure the password is correct and still cannot get my emails from all of my accounts.

I also notice the token/password has not been saved to the system in Saved Password session. ( I have tried to run as administrator but still doesn't work.)

What have I missed? Can still using POP3 method to get email if problem solved?

My current system is Win7 with Thunderbird 32bit installed.

Thanks!!

Hi, I used to use Thunderbird to access Gmail, Yahoo mail and normal email account (all POP3). I have updated (not reinstall) Thunderbird to the latest version since Gmail disabled non secure apps access. I have changed the Authentication to OAuth by follow the instruction from your page, but the system keep asking me to login (I have grant access in Gmail). This happens not only Gmail as well as my Yahoo mail and normal POP3 account. I am sure the password is correct and still cannot get my emails from all of my accounts. I also notice the token/password has not been saved to the system in Saved Password session. ( I have tried to run as administrator but still doesn't work.) What have I missed? Can still using POP3 method to get email if problem solved? My current system is Win7 with Thunderbird 32bit installed. Thanks!!

Ausgewählte Lösung

If still a problem: Do the following:

Let's see if this is due to something corrupted in session, password files etc.

  • Menu app icon > More Troubleshooting Information
  • Under 'Application Basics' - Profile Folder - click on 'Open Folder'
  • This opens a new window showing the contents of your current in use profile name folder.
  • Exit Thunderbird now - this is important.

Look for the following files and delete them.

  • cert8.db - obselete file
  • key3.db - obselete file
  • pkcs11.txt (This should exist but some people find it is missing)
  • secmod.db - obselete file
  • session.json
  • xulstore.json

NOTE: Do NOT delete:

  • key4.db
  • cert9.db
  • logins.json

Start Thunderbird New pkcs11.txt, session.json, xulstore.json files will get created. Enter password at prompt.

Diese Antwort im Kontext lesen 👍 1

Alle Antworten (2)

more options

You mention you have updated the Authentication Method to use 'OAuth2'. Thunderbird has made alterations so now both POP and IMAP accounts can use OAuth2 for gmail. But did you set up to allow saved cookies ?

  • Select 'Menu app icon' > 'Preferences' > 'Privacy & Security ' Under 'Web Content'
  • Select 'Accept cookies from sites'

It may also be a good idea to make exception:

These are the necessary changes to Account Settings which you may have already done.

  • Right click on gmail pop/imap account name in Folder Pane and select 'Settings'

This opens the Account Settings in new tab The pop/imap account name should be selected Look bottom right for Outgoing Server (SMTP)

  • Click on 'Edit Server _SMTP' button
  • Set Authentication Method : OAuth2
  • Click on OK

Now set the incoming authentication:

  • select 'Server Settings' for gmail account
  • Set Authentication Method : OAuth2


If this still presents a problem:

  • Menu app icon > Preferences > Privacy and Security
  • Scoll to 'Passwords'
  • Click on 'Saved Passwords'

You say the Oauth token has not been stored, but do you still have the original passwords stored? If yes, remove them.

  • Select the mailbox/imap line for that email address/user name and click on 'Remove'
  • Select the smtp line for that email address/user name and click on 'Remove'
  • Exit Thunderbird and wait a few moments for background processes to complete Start Thunderbird

If attempts for some reason keeps looking for wrong 'localhost': It means you are probably running a local server eg: Apache Switch off Apache or whatever local server you are using. Note some linux systems may have this auto installed. Then try again.

more options

Ausgewählte Lösung

If still a problem: Do the following:

Let's see if this is due to something corrupted in session, password files etc.

  • Menu app icon > More Troubleshooting Information
  • Under 'Application Basics' - Profile Folder - click on 'Open Folder'
  • This opens a new window showing the contents of your current in use profile name folder.
  • Exit Thunderbird now - this is important.

Look for the following files and delete them.

  • cert8.db - obselete file
  • key3.db - obselete file
  • pkcs11.txt (This should exist but some people find it is missing)
  • secmod.db - obselete file
  • session.json
  • xulstore.json

NOTE: Do NOT delete:

  • key4.db
  • cert9.db
  • logins.json

Start Thunderbird New pkcs11.txt, session.json, xulstore.json files will get created. Enter password at prompt.