Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

AT&T bellsouth.net login problem

  • 7 replies
  • 1 has this problem
  • 33 views
  • Last reply by Matt

more options

I have three email address, all bellsouth.net domains. If I go to the AT&T Yahoo site I can login to all three addresses without a problem. Therefore I know I have a good password and the accounts are not locked.

Last fall I lost access to all three email accounts via Thunderbird. AT&T support told me I had to establish a secure 16 character password and convert to from POP3 to IMAP servers (this proved untrue as POP3 still works). After much effort I converted all three addresses to IMAP and regained access. A few months ago one of the three address suddenly would not login via Thunderbird. AT&T technical support proved no help resolving this problem even after hours of telephone time. I can still reliably log into this account via AT&Ts Yahoo site but not via an email client like Thunderbird or OE Express. On both clients I tried both POP3 and IMAP logins, and although both work for the other two accounts, nothing works for the one problem account. Thunderbird gives the following message when I try to log in "Login to server imap.mail.att.net with username xxxxxx@bellsouth.net failed.". I used both the original password that works with Yahoo and the 16 character secure password, with the same result. I also checked the settings multiple times.

I tried everything I can think of without success. Any suggestions would be appreciated.

All Replies (7)

more options

Because ATT have a contract that they apparently do not understand with yahoo who provide a service that at best is sub standard. You have to jump through hoops to use the service you are paying for. ATT make much of using oAuth, except they have no "secret" for oAuth. So basically att customers have two choices.

Use a secure mail key instead of a password. https://www.att.com/support/article/email-support/KM1240308 to get you mail working Or Change their server information to Yahoo from the mail.att.net stuff and use the oAuth provided by Yahoo. So you change the server to imap.mail.yahoo.com and the authentication method to oAuth and your mail should come through, as long as cookies are enabled (they are by default)

more options

I never did get the problem in the first post resolved but now I cannot log into two of my three email accounts. A second email account (same bellsouth.net domain) just spontaneously stopped working, it worked one day and not the next, as as happened with all the issues over the past year or so. I have spent hours trouble shooting and verifying all settings are correct by comparing the settings associated with the one working account with the two non-working accounts. I am certain at this point there are no inadvertent spelling errors and/or typos.

Tools -> Options -> Saved Passwords... displays a dialog called "Saved Logins". All three accounts have two line items; imap://imap.mail.att.net and smtp://outbound.att.net. The 16 character alphanumeric pass word is correctly entered in both cases for each email account. All three accounts are readily accessible from Yahoo.

I would certainly appreciate some understanding of what is causing this problem. Thank you.

more options

re :All three accounts have two line items; imap://imap.mail.att.net and smtp://outbound.att.net.

If you have two lines then you have not set up the authentication method as OAuth. The incoming server name is correct for imap but the outgoing one is one used for a pop account according to the AT&T help.

Suggest you start by checking all the server settings. Make a decision on whether you want to use OAuth or Secure Mail Key as this determines the 'Authentication Method' used.

These settings are good for email addresses with any of these domains: @ameritech.net, @att.net, @bellsouth.net, @currently.com, @flash.net, @nvbell.net, @pacbell.net, @prodigy.net, @sbcglobal.net, @snet.net, @swbell.net, or @wans.net.

If you use OAuth then you will need to have cookies enabled in Thunderbird. In versions 78* or later:

  • Select 'Menu app icon' > 'Options/Preferences'
  • In 'Options/Preferences' left Pane select Privacy & Security
  • Select checkbox 'Accept cookies from sites'

Server Settings: IMAP Incoming server name: imap.mail.att.net Port : 993 Connection Security: SSL/TLS Authentication Method: OAuth2 User Name - Enter your full email address.

SMTP Outgoing server name: smtp.mail.att.net Port :465 using Connection Security: SSL/TLS Authentication Method: OAuth2 User Name - Enter your full email address.

If you do not want to set up OAuth, then set: Authentication Method: 'Normal Password' for both incoming and outgoing Create a 'secure mail key' - Each account will need it's own 'secure mail key' which you enter at the prompt instead of the Normal Password.

re :I am certain at this point there are no inadvertent spelling errors and/or typos. I helped someone recently who had spelt their username ...@bellsoouth instead of @bellsouth So it is worth checking.

After making changes, remove passwords and then restart Thunderbird. If using OAuth you will get a prompt to enter normal password to set up a token in Thunderbird and allow Thunderbird access. If using 'Normal Password' then substitiute with 'Secure Mail key' and make sure it is the correct 'Secure Mail Key' for the correct mail account/email address. If you enter the wrong one then it will not work.

Modified by Toad-Hall

more options

re :After much effort I converted all three addresses to IMAP

Please tell me that you did not just access the Account Settings and swap the server settings. It seems very odd that you have some server settings set up for imap and others set up for pop. This would not have been auto generated.

Did you create New > Existing Mail account for email address. Normally IMAP settings are located and used by default, but it is at this point you would have ensured the configuration were for IMAP, before clicking to 'Create Account'

I am concerned that you have swapped aload of server settings and not properly created the mail accounts.

more options

Thanks for the responses!

When I converted from POP3 to IMAP, due to AT&T telling me I had to do so, I disabled the POP3 accounts and then created new accounts. I then had to manually copy thousands of emails from the POP3 accounts to the new IMAP accounts and this turned out to be a very unwelcome and very time consuming task. I did not try to convert the existing accounts.

I have seen a number of suggestions to select OAuth2 instead of “Normal password” but OAuth2 is only available in the drop-down menu for the incoming server, not for the outgoing SMPT server. I do not know why my latest version of Thunderbird, 78.5.0, does not provide OAuth2 for the outgoing server. Therefore, I selected “Normal password” for both incoming and outgoing and use the 16 character alphanumeric password. I also tried just setting the incoming server to OAuth2 but that generates the error message “The IMAP server imap.mail.att.net does not support the selected authentication method.”. I have three 16 character secure passwords, one for each of the three email accounts.

I verified “Accept cookies from sites” is checked in both Thunderbird and Firefox.

I checked on numerous occasions for typos etc. I am confident there are no typos. I not only checked each specific entry multiple times, I compared each page of the two non-working accounts to the one remaining working account and, except for the part of the email address to the left of the @ symbol they are identical.

I just did what you suggested and from Tools -> Options -> Passwords removed both the imap://imap.mail.att.net and smtp://outbound.att.net passwords. I then closed and reopened Thunderbird. When requested I entered the 16 character secure password but it sat for a while with the message “Sending login information…” and then displayed “Login to server imap.mail.att.net with username xxxxxxx@bellsouth.net failed.”. I then tried my old password with the same result. Then I tried logging in using Yahoo (to verify I was not locked out) and had no issue logging in using my old password but the 16 character secure password would not work with Yahoo. I know I am using the correct 16 character secure password associated with the proper account because I made a screen print of the password and account name for each of the three accounts when I got the passwords.

Interesting, all three email accounts worked after the original conversion from POP3 to IMAP. They also worked with either my original password or the secure password. One account spontaneously just stopped successfully logging in a few months ago. Since it is not a frequently used account, I gave up spending more time than I already did trying to fix it. A week or two ago a second account also spontaneously just stopped successfully logging in. I spent most of yesterday trying to fix it with zero success. The fact that both problems occurred seemingly spontaneously indicates to me the settings are correct because they all did work at one time. The third account, and the account that is of extreme importance to me, still works but I now do not have confidence it will not just suddenly have an issue like the other two.

On another W10 computer I uninstalled Thunderbird, renamed the Thunderbird Profile folder so it would be recognized, and reinstalled Thunderbird. Even though I just downloaded the latest install file, I was unable to install an account because neither my old or 16 character secure password would work. There was also no option for OAuth2 on either server. I also could not get OE Classic 3.1 to work.

At this point I am at a loss how to access two of my three email accounts using an email client. For whatever its worth I much prefer a POP3 account but will nevertheless be happy if I can get these accounts to work with IMAP. If Thunderbird had pay per event support, I would be happy to use it. I have had these three email accounts for over twenty years so it would be very painful on a long-term basis if I lose access to them.

Thanks for the help.

more options

I just went through this mess with one of my business clients. Seems AT&T/Yahoo made a recent change that now requires the user to jump through hoops to use anything other than a web browser to access e-mail. What you need to do is manually create a secure password and use that secure password in Thunderbird. Now g-mail does this for you automatically in the background and your typical user has no clue that the "normal" password they created for the account is not being used at all by TB. But with AT&T, the user has to log in to their AT&T account with a web browser and jump through hoops to get to the right screen to create the secure password. When you create that secure password it will be displayed on your screen one time, and one time only. So make sure you copy it to something such as notepad before you close that display window. That secure password must be the one you use in TB. Your "regular" password will not work.

more options

I do not know how many time I have to says this.

For Yahoo users you simply change the authentication method to oAth2... That is all. The rest of the hoops are so Yahoo contract customers like ATT clients can access their mail.