On Aug 14th 11 PM ET/Aug 15th 03:00 UTC, due to scheduled Firefox Account server maintenance, users may not be able to sign in or create a new subscription. This is expected to last approximately 30 minutes. Status updates can be found at https://status.vpn.mozilla.org or https://status.relay.firefox.com.

Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

I am unable to add jira as a search engine on firefox 100 (new profile).

  • 11 Antworten
  • 1 hat dieses Problem
  • 20 Aufrufe
  • Letzte Antwort von vda1

more options

I had jira as my default search engine (https://jira.<mydomain>.com). This continues to work on my existing profile. But i am unable to add it on a new profile, I get an error "Firefox could not install the search engine from: https://jira.<mydomain>.com/osd.jsp"

So, i tried copying the existing profile folder and using that folder for the new profile, but firefox removes the jira search engine and gives me a warning saying that the default search engine was changed to Google (screenshot attached)

Is there a way to get this added via a hack of some kind? I wanted separate profiles so that I keep my project profiles separated - bookmarks, cookies, scripts etc.,

I had jira as my default search engine (https://jira.<mydomain>.com). This continues to work on my existing profile. But i am unable to add it on a new profile, I get an error "Firefox could not install the search engine from: https://jira.<mydomain>.com/osd.jsp" So, i tried copying the existing profile folder and using that folder for the new profile, but firefox removes the jira search engine and gives me a warning saying that the default search engine was changed to Google (screenshot attached) Is there a way to get this added via a hack of some kind? I wanted separate profiles so that I keep my project profiles separated - bookmarks, cookies, scripts etc.,
Angefügte Screenshots

Ausgewählte Lösung

I don't know why that isn't working. The <OpenSearchDescription> tag is missing the namespace (xmlns); maybe that's the problem?

Since you have the query URL, you could try setting it up manually. This requires unlocking a hidden feature that's still in development. If you want to give it a try:

Setup: Enable adding search engines by URL

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future. Since I use it myself, I feel comfortable mentioning it.

(2) In the search box in the page, type or paste browser.urlbar.update2.engineAliasRefresh and pause while the list is filtered

Firefox should display a bar with Boolean Number String and a plus sign button.

(3) Keep the selection on Boolean and click the plus sign button. If the value isn't set to true automatically, double-click false to switch it to true.

Create a New Search Engine

Open the Settings page, Search panel, and scroll down to the Search Shortcuts section.

Below the box, you should find a new Add button. Here's where the (not fully baked) magic happens:

Click Add to open a form and then set up your new engine with the name of your choice, your results page URL, and keyword of your choice, if any. The results page URL requires editing: replace

{searchTerms}

with

%s

in the URL. This is an example from another thread:

Note: there's no way to edit this new search engine so if it doesn't work, you would need to remove it and create a new one.

What do you think?

Diese Antwort im Kontext lesen 👍 1

Alle Antworten (11)

more options

See if this link can help: https://mycroftproject.com/ Just look for the search engine you want.

Hilfreich?

more options

Hey FredMcD,

Thanks for responding. That did not help though. I had been there already. The JIRA URL is not a publicly available one. https://jira.[companydomain].com

Hilfreich?

more options

You can try to copy search.json.mozlz4 from the old profile to the current profile.

You can use the button on the "Help -> More Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page (Root directory).

Hilfreich?

more options

If you open that osd.jsp file in a tab, what does it look like? You may need to call up View Source (Ctrl+U, or right-click > View Page Source) to read it.

As an example of what an OpenSource XML file often contains:

<?xml version="1.0" encoding="UTF-8"?> <OpenSearchDescription xmlns="http://a9.com/-/spec/opensearch/1.1/"> <ShortName>Startpage</ShortName> <Description>Startpage Search</Description> <InputEncoding>UTF-8</InputEncoding> <Image width="16" height="16" type="image/x-icon">https://www.startpage.com/assets/images/logo-16x16.png</Image> <Query role="example" searchTerms="cat" /> <Url type="text/html" template="https://www.startpage.com/sp/search?query={searchTerms}&cat=web&pl=opensearch&language=english"></Url> <Url type="application/x-suggestions+json" rel="suggestions" template="https://www.startpage.com/suggestions?q={searchTerms}&format=opensearch"/> </OpenSearchDescription>

If you get an error page, or HTML instead of XML, that could explain why Firefox is having a problem adding it.

Hilfreich?

more options
  1. Go to Jira index page
  2. Click within the address bar.
  3. On the bottom of a drop-down list there should be a jira icon with + sign. Just click it to add Jira search engine.

Hilfreich?

more options

cor-el said

You can try to copy search.json.mozlz4 from the old profile to the current profile. You can use the button on the "Help -> More Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page (Root directory).

Thanks cor-el, this was one of the few things i tried initially, and firefox would change it back to google and show me the message banner saying the search engine has been changed

jscher2000 - Support Volunteer said

If you open that osd.jsp file in a tab, what does it look like? You may need to call up View Source (Ctrl+U, or right-click > View Page Source) to read it.

As an example of what an OpenSource XML file often contains:

<?xml version="1.0" encoding="UTF-8"?> <OpenSearchDescription xmlns="http://a9.com/-/spec/opensearch/1.1/"> <ShortName>Startpage</ShortName> <Description>Startpage Search</Description> <InputEncoding>UTF-8</InputEncoding> <Image width="16" height="16" type="image/x-icon">https://www.startpage.com/assets/images/logo-16x16.png</Image> <Query role="example" searchTerms="cat" /> <Url type="text/html" template="https://www.startpage.com/sp/search?query={searchTerms}&cat=web&pl=opensearch&language=english"></Url> <Url type="application/x-suggestions+json" rel="suggestions" template="https://www.startpage.com/suggestions?q={searchTerms}&format=opensearch"/> </OpenSearchDescription>

If you get an error page, or HTML instead of XML, that could explain why Firefox is having a problem adding it.

thanks jscher2000, i had tried this too, and was seeing an xml file

Geändert am von vda1

Hilfreich?

more options

cor-el said

You can try to copy search.json.mozlz4 from the old profile to the current profile. You can use the button on the "Help -> More Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page (Root directory).

Thanks cor-el. I had tried this initially, but that didnt help. As soon as i relaunch firefox, it would reset the search engine to Google and show the banner at the top informing about the change

jscher2000 - Support Volunteer said

If you open that osd.jsp file in a tab, what does it look like? You may need to call up View Source (Ctrl+U, or right-click > View Page Source) to read it.

As an example of what an OpenSource XML file often contains:

<?xml version="1.0" encoding="UTF-8"?> <OpenSearchDescription xmlns="http://a9.com/-/spec/opensearch/1.1/"> <ShortName>Startpage</ShortName> <Description>Startpage Search</Description> <InputEncoding>UTF-8</InputEncoding> <Image width="16" height="16" type="image/x-icon">https://www.startpage.com/assets/images/logo-16x16.png</Image> <Query role="example" searchTerms="cat" /> <Url type="text/html" template="https://www.startpage.com/sp/search?query={searchTerms}&cat=web&pl=opensearch&language=english"></Url> <Url type="application/x-suggestions+json" rel="suggestions" template="https://www.startpage.com/suggestions?q={searchTerms}&format=opensearch"/> </OpenSearchDescription>

If you get an error page, or HTML instead of XML, that could explain why Firefox is having a problem adding it.

Thanks jscher2000, i had tried this too. When i view that URL i was seeing an xml file. Attached screenshot


TyDraniu said

# Go to Jira index page
  1. Click within the address bar.
  2. On the bottom of a drop-down list there should be a jira icon with + sign. Just click it to add Jira search engine.

Thanks for trying to solve this TyDraniu, but that is where the issue originates for me. When trying to add jira as the search engine i get the error message

Geändert am von vda1

Hilfreich?

more options

Ausgewählte Lösung

I don't know why that isn't working. The <OpenSearchDescription> tag is missing the namespace (xmlns); maybe that's the problem?

Since you have the query URL, you could try setting it up manually. This requires unlocking a hidden feature that's still in development. If you want to give it a try:

Setup: Enable adding search engines by URL

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future. Since I use it myself, I feel comfortable mentioning it.

(2) In the search box in the page, type or paste browser.urlbar.update2.engineAliasRefresh and pause while the list is filtered

Firefox should display a bar with Boolean Number String and a plus sign button.

(3) Keep the selection on Boolean and click the plus sign button. If the value isn't set to true automatically, double-click false to switch it to true.

Create a New Search Engine

Open the Settings page, Search panel, and scroll down to the Search Shortcuts section.

Below the box, you should find a new Add button. Here's where the (not fully baked) magic happens:

Click Add to open a form and then set up your new engine with the name of your choice, your results page URL, and keyword of your choice, if any. The results page URL requires editing: replace

{searchTerms}

with

%s

in the URL. This is an example from another thread:

Note: there's no way to edit this new search engine so if it doesn't work, you would need to remove it and create a new one.

What do you think?

Hilfreich?

more options

Thanks jscher2000, that helped! I was able to add the search engine (i tried it on a separate profile to make sure it works :) ) It's not perfect, but it works. [When i visit JIRA, firefox still thinks that jira is not added to the search engine list, (i.e., in the search/URL dropdown, i still get the option to add it - the green '+' sign]

I was also able to find a similar solution, by using a mozl4 editor addon.

  • using the add on, i opened the search.json.mozlz4 file from another profile, copied the contents
  • opened the search.json.mozlz4 file from the current profile and pasted the copied contents from step 1,
  • saved

The results were similar for both the solutions - i.e., jira has been added as a search engine, but firefox doesn't think that the search engine is the same when i visit any JIRA pages - I still get the option to add it.

It works for now, so i am satisfied with both the solutions

Hilfreich?

more options

It's odd that Firefox detects it but can't add it. I don't know what is causing that parsing error. If someone can pinpoint it, I'm sure it could be fixed -- although whether that means Firefox will accept impure XML or won't offer to add it in the first place, I couldn't tell you.

Hilfreich?

more options

thanks @jscher2000, i reached out to jira support team within our organization too. but no one responded - looks like they are not sure either :) but your suggestion worked. so all good for now

Hilfreich?

Stellen Sie eine Frage

Sie müssen sich mit Ihrem Benutzerkonto anmelden, um auf Beiträge zu antworten. Bitte stellen Sie eine neue Frage, wenn Sie noch kein Benutzerkonto haben.