Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Telefonnummer anzurufen, eine SMS an eine Telefonnummer zu senden oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

Page now only renders in troubleshoot mode, it worked OK, not looking like an extension problem

  • 2 Antworten
  • 1 hat dieses Problem
  • 5 Aufrufe
  • Letzte Antwort von juanriccio

more options

Hello, recently this page stopped working with Firefox. Connection to the server isn't an issue. The source appears to download just fine. It's only the rendering that's problematic.

It's a static page served locally (LAN) from the IPMI interface of my NAS/fileserver. This page used to work fine until a few months ago. Some Firefox update must have broken the rendering. I tried it in Troubleshoot Mode, and it displays OK as it used to. I tried in ordinary (not Troubleshoot) mode, disabling hardware acceleration and disabling all the extensions, but it just won't show.

Here's the full source for the page, in case it helps. Can anyone point me to some useful information?

``

<!--
;*****************************************************************;
;*****************************************************************;
;**                                                             **;
;**     (C) COPYRIGHT American Megatrends Inc. 2008-2009        **;
;**                     ALL RIGHTS RESERVED                     **;
;**                                                             **;
;**  This computer software, including display screens and      **;
;**  all related materials, are confidential and the            **;
;**  exclusive property of American Megatrends, Inc.  They      **;
;**  are available for limited use, but only pursuant to        **;
;**  a written license agreement distributed with this          **;
;**  computer software.  This computer software, including      **;
;**  display screens and all related materials, shall not be    **;
;**  copied, reproduced, published or distributed, in whole     **;
;**  or in part, in any medium, by any means, for any           **;
;**  purpose without the express written consent of American    **;
;**  Megatrends, Inc.                                           **;
;**                                                             **;
;**                                                             **;
;**                American Megatrends, Inc.                    **;
;**           5555 Oakbook Parkway, Building 200                **;
;**     Norcross,  Georgia - 30071, USA. Phone-(770)-246-8600.  **;
;**                                                             **;
;*****************************************************************;
;*****************************************************************;
-->
<html>
<head>
	<title>Megarac SP</title>
	<meta http-equiv="Content-Type" content="text/html; charset=utf-8">
	<script language="Javascript" src="index_imp.js"></script>
	<script language="Javascript" src="lib/ui.js"></script>
	<script language="Javascript" src="lib/xmit.js"></script>
	<script language="Javascript" src="lib/eLang.js"></script>
	<script language="Javascript" src="lib/events.js"></script>
	<script language="Javascript" src="str/title_str.js"></script>
	<script>
		var gLangSettingSet		= false;
		var gLangSetting		= "EN";
		var gPageDir			= "/page/";
		var gResDir				= "/res/";
		var gStrDir				= "/str/";
		var gStyleDir			= "/style/";
		var gLibDir				= "/lib/";
		var gImplDir			= "/impl/";
		var gHelpDir			= "/help/";
		var gOemDir				= "../";
		var gJavaJnlp			= "/Java/jviewer.jnlp";
		var gVideoJnlp			= "/Java/video_record.jnlp";

		onload = function() {
			gLangSetting = getBrowserLang();
			gLangSettingSet = true;
			doInit();
		}

		function loadFrames()
		{
			window.frames["headerFrame"].location.href = "." + gPageDir + 
				"header.html";
			var sessionexpire = fnCookie.read("SessionExpired");

			if ((fnCookie.read("SessionCookie") != undefined && 
				fnCookie.read("SessionCookie") != null) && 
				(sessionexpire == undefined || sessionexpire == null || 
				sessionexpire == "false")) {
				window.frames["mainFrame"].location.href = "." + gPageDir + 
					"main.html";
			} else {
				window.frames["mainFrame"].location.href = "." + gPageDir + 
					"login.html";
			}
		}
		document.write("<script language = \"Javascript\" src = \"/str/" + 
			gLangSetting + "/common_str.js\"><\/script>");
	</script>
</head>
	<frameset rows="88, *" border="0" bordercolor="rgb(192, 192, 192)" frameborder="no" framespacing="0">
		<frame src="./page/disable_javascript.html" name="headerFrame" id="HEADERFRAME" scrolling="no" noresize="true"></frame>
		<frameset cols="*, 0" id="frmHolder" border="0" bordercolor="rgb(192, 192, 192)" frameborder="no" framespacing="0">
			<frame src="./page/blank.html" name="mainFrame" id="MAINFRAME" scrolling="no" noresize="false"></frame>
			<frame src="./page/blank.html" name="helpFrame" id="HELPFRAME" scrolling="auto" noresize="false"></frame>
		</frameset>
	</frameset>
</html>
``

Hello, recently this page stopped working with Firefox. Connection to the server isn't an issue. The source appears to download just fine. It's only the rendering that's problematic. It's a static page served locally (LAN) from the IPMI interface of my NAS/fileserver. This page used to work fine until a few months ago. Some Firefox update must have broken the rendering. I tried it in Troubleshoot Mode, and it displays OK as it used to. I tried in ordinary (not Troubleshoot) mode, disabling hardware acceleration and disabling all the extensions, but it just won't show. Here's the full source for the page, in case it helps. Can anyone point me to some useful information? `` <pre><nowiki><!-- ;*****************************************************************; ;*****************************************************************; ;** **; ;** (C) COPYRIGHT American Megatrends Inc. 2008-2009 **; ;** ALL RIGHTS RESERVED **; ;** **; ;** This computer software, including display screens and **; ;** all related materials, are confidential and the **; ;** exclusive property of American Megatrends, Inc. They **; ;** are available for limited use, but only pursuant to **; ;** a written license agreement distributed with this **; ;** computer software. This computer software, including **; ;** display screens and all related materials, shall not be **; ;** copied, reproduced, published or distributed, in whole **; ;** or in part, in any medium, by any means, for any **; ;** purpose without the express written consent of American **; ;** Megatrends, Inc. **; ;** **; ;** **; ;** American Megatrends, Inc. **; ;** 5555 Oakbook Parkway, Building 200 **; ;** Norcross, Georgia - 30071, USA. Phone-(770)-246-8600. **; ;** **; ;*****************************************************************; ;*****************************************************************; --> <html> <head> <title>Megarac SP</title> <meta http-equiv="Content-Type" content="text/html; charset=utf-8"> <script language="Javascript" src="index_imp.js"></script> <script language="Javascript" src="lib/ui.js"></script> <script language="Javascript" src="lib/xmit.js"></script> <script language="Javascript" src="lib/eLang.js"></script> <script language="Javascript" src="lib/events.js"></script> <script language="Javascript" src="str/title_str.js"></script> <script> var gLangSettingSet = false; var gLangSetting = "EN"; var gPageDir = "/page/"; var gResDir = "/res/"; var gStrDir = "/str/"; var gStyleDir = "/style/"; var gLibDir = "/lib/"; var gImplDir = "/impl/"; var gHelpDir = "/help/"; var gOemDir = "../"; var gJavaJnlp = "/Java/jviewer.jnlp"; var gVideoJnlp = "/Java/video_record.jnlp"; onload = function() { gLangSetting = getBrowserLang(); gLangSettingSet = true; doInit(); } function loadFrames() { window.frames["headerFrame"].location.href = "." + gPageDir + "header.html"; var sessionexpire = fnCookie.read("SessionExpired"); if ((fnCookie.read("SessionCookie") != undefined && fnCookie.read("SessionCookie") != null) && (sessionexpire == undefined || sessionexpire == null || sessionexpire == "false")) { window.frames["mainFrame"].location.href = "." + gPageDir + "main.html"; } else { window.frames["mainFrame"].location.href = "." + gPageDir + "login.html"; } } document.write("<script language = \"Javascript\" src = \"/str/" + gLangSetting + "/common_str.js\"><\/script>"); </script> </head> <frameset rows="88, *" border="0" bordercolor="rgb(192, 192, 192)" frameborder="no" framespacing="0"> <frame src="./page/disable_javascript.html" name="headerFrame" id="HEADERFRAME" scrolling="no" noresize="true"></frame> <frameset cols="*, 0" id="frmHolder" border="0" bordercolor="rgb(192, 192, 192)" frameborder="no" framespacing="0"> <frame src="./page/blank.html" name="mainFrame" id="MAINFRAME" scrolling="no" noresize="false"></frame> <frame src="./page/blank.html" name="helpFrame" id="HELPFRAME" scrolling="auto" noresize="false"></frame> </frameset> </frameset> </html> ``</nowiki></pre><br>

Geändert am von cor-el

Alle Antworten (2)

more options

What is wrong with the rendering ?

Can you attach a screenshot?


You can create a new profile as a quick test to see if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

more options

Thanks for your reply, @cor-el!

No need for a screenshot: the screen is totally blank.

The new profile solves the problem. However, I would like to keep this one. I have many extensions installed, with individual preferences and configs I would hate to lose. So I'm hoping to locate the problem. What's weird is that manually disabling the extensions or hardware acceleration doesn't solve it.

That's why I said it doesn't look like an extension problem; although the hardware acceleration thing shouldn't matter, either. The page contains no animations or fancy graphics - just a few static images.

Uncertain if I should mark your reply as an answer that solves the problem yet. I think I'll wait a bit, hoping to get the magic suggestions that helps me find the culprit :-)

Thanks again

EDIT: At the very least I can make a new default profile in a different window when I need to access the NAS IPMI interface. So your reply does solve the problem, in a way.

Geändert am von juanriccio