Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

New Firefox Update Bookmarks Toolbar (Show more bookmarks) | Double Space Problem

  • 16 Antworten
  • 4 haben dieses Problem
  • 153 Aufrufe
  • Letzte Antwort von gmwestall

more options

I updated my firefox to the latest version : Version 92.0 Now in Bookmarks Toolbar (Show more bookmarks) i have a problem about double Space between bookmarks. This is really really annoying. How can i fix that double space issue?

I tried browser.proton.contextmenus.enabled > false (disables Proton UI of context menus) Did not work for me.

Ausgewählte Lösung

Note that best is to leave the Boolean browser.proton prefs at their default.

Are you using code in userChrome.css to lower the space or did you rely on browser.proton.contextmenus.enabled ?

If you use code in userChrome.css then you need to add a min-height rule.

Add CSS code to the userChrome.css file.


menupopup > menuitem, menupopup > menu {
 padding-block: 2px !important; /*adjust: 0px-4px*/
 min-height: 22px !important; /*adjust: 21px-24px or unset*/
}

*|*:root {--arrowpanel-menuitem-padding: 2px 8px !important;}

In Firefox 69 and later you need to set this pref to true on the about:config page to enable userChrome.css and userContent.css in the chrome folder.

Diese Antwort im Kontext lesen 👍 0

Alle Antworten (16)

more options

As you see in the attached image spaces are more than usual. Please help to fix this annoying issue.

Hilfreich?

more options

Ausgewählte Lösung

Note that best is to leave the Boolean browser.proton prefs at their default.

Are you using code in userChrome.css to lower the space or did you rely on browser.proton.contextmenus.enabled ?

If you use code in userChrome.css then you need to add a min-height rule.

Add CSS code to the userChrome.css file.


menupopup > menuitem, menupopup > menu {
 padding-block: 2px !important; /*adjust: 0px-4px*/
 min-height: 22px !important; /*adjust: 21px-24px or unset*/
}

*|*:root {--arrowpanel-menuitem-padding: 2px 8px !important;}

In Firefox 69 and later you need to set this pref to true on the about:config page to enable userChrome.css and userContent.css in the chrome folder.

Hilfreich?

more options

Hi dear friend, There is no userChrome.css file in my firefox profile folder & i did n't enable it. So why did i face this annoying issue after update firefox? Is there another way to fix this issue without creating and manipulating any css file?

Hilfreich?

more options

It seems this is a bug in firefox Version 92.0. By changing browser.proton.contextmenus.enabled nothing happened in my browser. So i put it as true and close it.

Geändert am von Vortex.Cubes.CEO

Hilfreich?

more options

In Firefox 92 you can only reduce the menu spacing via userChrome.css. In Firefox 93 (current Beta/DE) they have added support to reduce the menu spacing via "Density: Compact" on the Customize page.

You can select "Density: Compact mode" in Firefox 89+. Note that this mode is currently not actively supported and isn't present as a Density choice in Customize by default.

Hilfreich?

more options

I test this : about:config => browser.compactmode.show = true In Firefox 92 Nothing happened about those spaces. Why did they change those spaces in Firefox 92?

Hilfreich?

more options

Those spaces were already added some versions ago as part of the Proton redesign.

In the current Firefox 92 release Compact mode doesn't support the menu spacing. You need to wait for the next release (93) to have support for this feature.

Hilfreich?

more options

Attempting to fnd a solution to this problem which occurred after update to ver. 92 is frustrating and indicative of the apparent dismissive attitude of the "dufus" who foisted the nonsense upon us. A change like this should be told to, and warned of prior to download of the new version---along with a means of changing easily back to single spacing. "If it ain't broke, don't fix it" should be the working attitude.

Hilfreich?

more options

Dear cmziembo would you please explain more? Those spaces are really annoying. I do n't want to manipulate firefox css. Should i wait for new version? Why did they do that in version 92?

Hilfreich?

more options

I use Compact Mode to save screen space but it no longer has an effect on the bookmark spacing. Screen space should be for content.

I'm not a touch-screen user so having more space between UI objects isn't useful. It's detrimental, actually. My Bookmark Toolbar dropdown menus often have many entries, so this change in Firefox 92 forces me to scroll my eyes and move my mouse too much, slowing my workflow.

I sincerely hope that Compact Mode in 93 truly will add support for compact bookmark menus. Having to hack things via a css file is NOT my idea of of a user-friendly interface.

Hilfreich?

more options

I should say specially thanks to cor-el Because of answers and help. Finally i forced fix those spaces with css file. I am waiting for FireFox 93 to check Compact Mode about this space issue.

Geändert am von Vortex.Cubes.CEO

Hilfreich?

more options

Now i updated to FF 93.0 (64 bit) How can i remove that double space in this version. There is no "Density" option in about:config

Hilfreich?

more options

The preference in about:config is browser.compactmode.show After you have made that true, you need to go to the Customize page (right-click a toolbar) and select Density > Compact. It only affects the Bookmarks, evidently.

Hilfreich?

more options

Thanks a lot...

Hilfreich?

more options

Here's an update on the change in Firefox 93 with the "Compact Mode" density setting (Compact mode workaround in Firefox):

  1. Bookmarks Toolbar folder drop-downs: Starting in Fx93, Compact Mode density tightens these up
  2. Bookmarks Menu button () drop-down: Starting in Fx93, Compact Mode density tightens this up --
  3. Top menu bar (File, Edit, View, History, Bookmarks, Tools, Help) drop-downs: Compact Mode density has no effect
  4. Right-click context menus: Compact Mode density has no effect
  5. Bookmarks Sidebar (Ctrl+B, or on Mac, Command+B): Already compact / no change

If you are accustomed to accessing bookmarks on the Menu Bar on Windows, one option would be to add the Bookmarks Menu button at the right end of the menu bar:


Otherwise, there are unofficial and unsupported workarounds, such as: https://www.userchrome.org/firefox-89-styling-proton-ui.html#menuspacing

Hilfreich?

more options

I have solved the problem, at least until the next update. Go to about:config and change this

      browser.uidensity 0 to a value of 1

Hilfreich?

Stellen Sie eine Frage

Sie müssen sich mit Ihrem Benutzerkonto anmelden, um auf Beiträge zu antworten. Bitte stellen Sie eine neue Frage, wenn Sie noch kein Benutzerkonto haben.