Where did you install Firefox from? Help Mozilla uncover 3rd party websites that offer problematic Firefox installation by taking part in our campaign. There will be swag, and you'll be featured in our blog if you manage to report at least 10 valid reports!

Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Telefonnummer anzurufen, eine SMS an eine Telefonnummer zu senden oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

With Firefox 89.0, Facebook notification appears as "MODAL" dialog. Is this intentional?

  • 1 Antwort
  • 3 haben dieses Problem
  • 2 Aufrufe
  • Letzte Antwort von Chelmite

more options

I have upgraded to Firefox 89.0 (64-bit) several days ago.

The new look is interesting to say the least.

However, I am more irritated with a functional change or something.

I access Facebook via Firefox on Windows 10 PC.

Facebook reports arrival of new posts from FB friends or comments to my posts.

It used to be that these reports appeared as non-modal dialog and so I can ignore them and type in something into FB window freely.

With Firefox 89.0, I suddenly notice that these reports appear as MODAL dialog and I have to clear them before I can type anything into FB window.

Is this behavioral change intended by the developer?

Just wondering.

Should I report to bugzilla?

I have upgraded to Firefox 89.0 (64-bit) several days ago. The new look is interesting to say the least. However, I am more irritated with a functional change or something. I access Facebook via Firefox on Windows 10 PC. Facebook reports arrival of new posts from FB friends or comments to my posts. It used to be that these reports appeared as non-modal dialog and so I can ignore them and type in something into FB window freely. With Firefox 89.0, I suddenly notice that these reports appear as MODAL dialog and I have to clear them before I can type anything into FB window. Is this behavioral change intended by the developer? Just wondering. Should I report to bugzilla?

Alle Antworten (1)

more options

The problem is fixed by using gnome-tweaks. Select the Windows tab on the left. Then turn off Attach Modal Dialogs. Problem solved.

That setting is hard to find. I've been cursing at it for at least a month. It would be nice if the setting could also be found inside of the Mozilla software. At best, it could toggle the settings. At worst, it could display the instructions on how to run gnome-tweaks.