Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

firefox can't open links on new tabs

more options

when open links on 2 or more tabs the new ones crash and don't open link. if "troubleshoot mode" is on, it works fine.

Ausgewählte Lösung

Thanks, I can see from the following page of stats that 2/3 of the similar reports for the past week are on your distro:

https://crash-stats.mozilla.org/signature/?product=Firefox&signature=mozilla%3A%3Aipc%3A%3AFatalError%20%7C%20mozilla%3A%3Adom%3A%3APContentChild%3A%3AOnMessageReceived

There is a bug linked (on the Bugzilla tab) that has this interesting comment:

But then there's bug 1674038 comment #1, which if I understand correctly is reporting it happened reliably… but only with add-ons enabled? I can't think of anything right now that would explain that.
Not about add-ons, I think: the fact that Safe Mode avoided this crash was probably simply because in Safe Mode [we (currently) disable the shared font list](https://searchfox.org/mozilla-central/rev/03224522336f60a1a61a87e1fcd4feb0a0315a9b/gfx/thebes/gfxPlatformFontList.cpp#486-489) and just use the legacy per-process font management. So there'd be no list of `sharedFontListBlocks` being sent in the SetXPCOMProcessAttributes message.

Source: https://bugzilla.mozilla.org/show_bug.cgi?id=1664151#c12

That code seems to check the following preference, so you could try toggling this to see whether it helps:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste gfx.e10s.font-list.shared and pause while the list is filtered

(3) Double-click the preference to switch the value from true to false

I suspect that won't take effect until the next time you quit and restart Firefox.

If that doesn't help, is there an Arch Linux forum where people might be discussing this problem and know of a workaround?

Diese Antwort im Kontext lesen 👍 1

Alle Antworten (7)

more options

That's interesting. So Firefox's Safe/Troubleshoot Mode makes a bunch of temporary changes:

  • it deactivates extensions
  • it disables hardware acceleration of graphics
  • it doesn't load any userChrome.css/userContent.css files
  • it disables the "Just in Time" JavaScript compiler
  • probably some things I'm forgetting

You can easily test disabling extensions in regular mode using the Add-ons page (Ctrl+Shift+A).

The hardware acceleration setting is hidden under Performance Settings: Firefox's performance settings. That requires restarting Firefox to take effect.

If you have a userChrome.css file, you probably recall there's an about:config preference that controls whether Firefox loads it: toolkit.legacyUserProfileCustomizations.stylesheets

Finally, there are preferences related to the script compilers but I don't remember what they are at this point.

Hilfreich?

more options

Hi, thanks for answering.

'You can easily test disabling extensions in regular mode using the Add-ons page (Ctrl+Shift+A)' It's a fresh install of firefox and don't seem to have installed extensions.

'The hardware acceleration setting is hidden under Performance Settings: Firefox's performance settings. That requires restarting Firefox to take effect.' When disabled hardware acceleration it seems to work fine but crashed after 3rd tab. Will test better.

'If you have a userChrome.css file, you probably recall there's an about:config preference that controls whether Firefox loads it: toolkit.legacyUserProfileCustomizations.stylesheets' toolkit.legacyUserProfileCustomizations.stylesheets has a false value.

Hilfreich?

more options

Have you gotten the Mozilla Crash Reporter dialog and submitted crash reports? If so, please share some of the report IDs with us. More info on where to find those in this article: Firefox crashes - asking for support.

Hilfreich?

more options

Actually, let me clarify your original question: you are opening the same URL in multiple tabs and it can be opened in two tabs, but not three tabs?

Hilfreich?

more options

'you are opening the same URL in multiple tabs' Same URL and diferents

'it can be opened in two tabs' Only the first tab is working, if i open a link in new tab or open a 2nd tab and type an URL, it crash with the message in the image.

'Have you gotten the Mozilla Crash Reporter dialog and submitted crash reports?' Yes, this are the ID's from last 3: bp-49419d13-88fe-4d4e-bbb5-f23160210606 bp-4f21564b-63aa-4fa9-b6fc-021910210606 bp-24193dda-1d2a-4c30-bc19-46d680210606

Hilfreich?

more options

Ausgewählte Lösung

Thanks, I can see from the following page of stats that 2/3 of the similar reports for the past week are on your distro:

https://crash-stats.mozilla.org/signature/?product=Firefox&signature=mozilla%3A%3Aipc%3A%3AFatalError%20%7C%20mozilla%3A%3Adom%3A%3APContentChild%3A%3AOnMessageReceived

There is a bug linked (on the Bugzilla tab) that has this interesting comment:

But then there's bug 1674038 comment #1, which if I understand correctly is reporting it happened reliably… but only with add-ons enabled? I can't think of anything right now that would explain that.
Not about add-ons, I think: the fact that Safe Mode avoided this crash was probably simply because in Safe Mode [we (currently) disable the shared font list](https://searchfox.org/mozilla-central/rev/03224522336f60a1a61a87e1fcd4feb0a0315a9b/gfx/thebes/gfxPlatformFontList.cpp#486-489) and just use the legacy per-process font management. So there'd be no list of `sharedFontListBlocks` being sent in the SetXPCOMProcessAttributes message.

Source: https://bugzilla.mozilla.org/show_bug.cgi?id=1664151#c12

That code seems to check the following preference, so you could try toggling this to see whether it helps:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste gfx.e10s.font-list.shared and pause while the list is filtered

(3) Double-click the preference to switch the value from true to false

I suspect that won't take effect until the next time you quit and restart Firefox.

If that doesn't help, is there an Arch Linux forum where people might be discussing this problem and know of a workaround?

Hilfreich?

more options

Thank you very much!! This solved the issue.

Hilfreich?

Stellen Sie eine Frage

Sie müssen sich mit Ihrem Benutzerkonto anmelden, um auf Beiträge zu antworten. Bitte stellen Sie eine neue Frage, wenn Sie noch kein Benutzerkonto haben.