X
Tippen Sie hierhin, um die Version dieser Website für Mobilgeräte aufzurufen.

Hilfeforum

Thunderbird fails to properly insert pasted images

Veröffentlicht

When I copy an image from the web and paste it into an outgoing email, the program appears to work fine at first, but the recipient only gets a useless link.

After many hours, I found that I can manually double click each and every photo and check "send image as attachment" and it will work properly, but only for that one image. Because the images look fine on my end, its very easy to forget to do this and my recipients think I'm nuts for sending them a link that doesn't work without a password or the image was moved.

Other than going back to a previous version, is there a way to make this work properly by default?

When I copy an image from the web and paste it into an outgoing email, the program appears to work fine at first, but the recipient only gets a useless link. After many hours, I found that I can manually double click each and every photo and check "send image as attachment" and it will work properly, but only for that one image. Because the images look fine on my end, its very easy to forget to do this and my recipients think I'm nuts for sending them a link that doesn't work without a password or the image was moved. Other than going back to a previous version, is there a way to make this work properly by default?

Ausgewählte Lösung

Try adding this boolean preference in the config editor.

mail.compose.attach_http_images

…and make sure it is set to true.

Diese Antwort im Kontext lesen 0

Mehr Details zum System

Anwendung

  • User-Agent: Mozilla/5.0 (Windows NT 5.1; rv:48.0) Gecko/20100101 Firefox/48.0

Weitere Informationen

Zenos 2265 Lösungen 12258 Antworten
Veröffentlicht

I'd never be sure that would work.

How do you copy your images in the first place? How do you add them to your message?

My conservative and cautious approach would be to copy the image to a graphics program, and then copy/paste/insert/attach from there. That forces a local copy of the image into existence, on your computer, and so there's no doubt about whether you're working with an image or a link. I'd also use Insert|Image and make sure that attachment checkbox was ticked.

I'd never be sure that would work. How do you copy your images in the first place? How do you add them to your message? My conservative and cautious approach would be to copy the image to a graphics program, and then copy/paste/insert/attach from there. That forces a local copy of the image into existence, on your computer, and so there's no doubt about whether you're working with an image or a link. I'd also use Insert|Image and make sure that attachment checkbox was ticked.
Veröffentlicht

Fragesteller

What I do is (in FireFox) right click on the image and then select "Copy Image". In Thunderbird, I click on the spot where I want the image inserted and then right click and select "Paste".

This creates the illusion that the image was properly inserted into the email. By double clicking the pasted image in thunderbird, it will come up with an "Image Properties" box. Under the "Location" tab, there is a check box "Attach this image to the message".

If I check that, it will properly send the actual image data with the email. If I forget, it sends a useless link instead.

Copying into Paintbrush first will likely remove any link information, but that's a real pain when you have multiple images. If that was the only way, I would go back to a previous version for sure.

So the problem remains, how do I get the "Attach this image to the message" checkbox to default as checked so I don't have to remember to check it manually.

What I do is (in FireFox) right click on the image and then select "Copy Image". In Thunderbird, I click on the spot where I want the image inserted and then right click and select "Paste". This creates the illusion that the image was properly inserted into the email. By double clicking the pasted image in thunderbird, it will come up with an "Image Properties" box. Under the "Location" tab, there is a check box "Attach this image to the message". If I check that, it will properly send the actual image data with the email. If I forget, it sends a useless link instead. Copying into Paintbrush first will likely remove any link information, but that's a real pain when you have multiple images. If that was the only way, I would go back to a previous version for sure. So the problem remains, how do I get the "Attach this image to the message" checkbox to default as checked so I don't have to remember to check it manually.
Zenos 2265 Lösungen 12258 Antworten
Veröffentlicht

Ausgewählte Lösung

Try adding this boolean preference in the config editor.

mail.compose.attach_http_images

…and make sure it is set to true.

Try adding this boolean preference in the config editor. mail.compose.attach_http_images …and make sure it is set to '''true'''.
Veröffentlicht

Fragesteller

Setting mail.compose.attach_http_images to true seems to have fixed it.

I might add that to access the config editor, go to Tools > Options, select the Advanced panel, select the General tab, and click Config Editor.

Setting mail.compose.attach_http_images to true seems to have fixed it. I might add that to access the config editor, go to Tools > Options, select the Advanced panel, select the General tab, and click Config Editor.