Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

How can I disable the "How to change default browser in Windows 10" page

  • 2 Antworten
  • 3 haben dieses Problem
  • 94 Aufrufe
  • Letzte Antwort von ShortRound

more options

Hi all

I'm trying to customize Firefox for our company. My approach was to copy a fake profile (profile.default folder, profiles,ini, autoconfig.js, config.cfg) on each client. It's working pretty well so far but after each "installation" I got this annoying "How to change default browser in Windows 10" page. Is there any configuration parameter for this page that would allow me to skip it? Please find the content of my config.cfg file below:

try {

// Disable Reset Prompt when Profile is older than 60days lockPref("browser.disableResetPrompt", true)

// Disable updater lockPref("app.update.enabled", false);

// make absolutely sure it is really off lockPref("app.update.auto", false); lockPref("app.update.mode", 0); lockPref("app.update.service.enabled", false);

// Disable Add-ons compatibility checking lockPref("extensions.lastAppVersion");

// Don't show 'know your rights' on first run lockPref("browser.rights.3.shown", true);

// Don't show WhatsNew on first run after every update lockPref("browser.startup.homepage_override.mstone","ignore");

// Set default homepage - users can change defaultPref("browser.startup.homepage", "data:text/plain,browser.startup.homepage=http://LO2DashboardCH/dashboard|http://LO2ConsoleCH/console");

// Disable slow startup notification lockPref("browser.slowStartup.notificationDisabled", true);

// Enable DoNotTrack lockPref("privacy.donottrackheader.enabled", true);

// Disable save sign-on information lockPref("signon.rememberSignons", false);

// Disable tabs warn on open lockPref("browser.tabs.warnOnOpen", false);

// Disable the internal PDF viewer lockPref("pdfjs.disabled", true);

// Disable plugin checking // lockPref("plugins.hide_infobar_for_outdated_plugin", true); // clearPref("plugins.update.url");

// Disable health reporter lockPref("datareporting.healthreport.service.enabled", false);

// Disable health reporting lockPref("datareporting.healthreport.uploadEnabled", false);

// Disable crash reporter lockPref("toolkit.crashreporter.enabled", false); Components.classes["@mozilla.org/toolkit/crash-reporter;1"].getService(Components.interfaces.nsICrashReporter).submitReports = false;

// Disable warn on closing tab lockPref("browser.tabs.warnOnClose", false); lockPref("browser.tabs.warnOnCloseOtherTabs", false);

// Disable check default browser lockPref("browser.shell.checkDefaultBrowser", false);

// Disable default browser button lockPref("pref.general.disable_button.default_browser", true);

} catch(e) { displayError("lockedPref", e); }

Thanks in advance Chris

Ausgewählte Lösung

hi, chris - you'll probably want to set "browser.usedOnWindows10" to "true" in your config file.

Diese Antwort im Kontext lesen 👍 2

Alle Antworten (2)

more options

Ausgewählte Lösung

hi, chris - you'll probably want to set "browser.usedOnWindows10" to "true" in your config file.

more options

Hi Philipp

Thats correct, thank you. I thought I already tried that but perhaps it didn't apply or I made mistake. However, my question has been answered.

best regards Chris