Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

google in firefox keeps changing english language setting, how to fix this?

  • 3 Antworten
  • 6 haben dieses Problem
  • 13133 Aufrufe
  • Letzte Antwort von cor-el

more options

I would like google in firefox ALWAYS stay in English language wherever I travel. Before I used Opera browser and there was no such question. I tried alot of web search with no definite solution. Do I have to go back to Opera again. I found out that there are so may people out there suffering from the same problem. Opera shouldn't be the only solution.

Ausgewählte Lösung

Do you mean this:

Google.com will redirect to a local site when you're traveling, based on geolocation using data about your current ISP connection. To bypass that, you can use

https://www.google.com/ncr

(NCR = no country redirect)

This sets a cookie that Firefox sends to Google.com with every request so Google remembers that you don't want to be redirected. If you clear Google cookies, either manually or at shutdown or using an add-on, then you have to set the ncr cookie again the next time it happens.

Diese Antwort im Kontext lesen 👍 2

Alle Antworten (3)

more options

Sometimes, the computers current location can override user setting. Check your computer, and Firefox language settings.

Type about:preferences#content<enter> in the address bar.

On the bottom of the page, find Languages. To its right, press the Choose button. Make sure the correct language and district is selected.

more options

Ausgewählte Lösung

Do you mean this:

Google.com will redirect to a local site when you're traveling, based on geolocation using data about your current ISP connection. To bypass that, you can use

https://www.google.com/ncr

(NCR = no country redirect)

This sets a cookie that Firefox sends to Google.com with every request so Google remembers that you don't want to be redirected. If you clear Google cookies, either manually or at shutdown or using an add-on, then you have to set the ncr cookie again the next time it happens.

more options

You can find Google search engines, including a 'No country redirect' version, on the Mycroft Project website.