X
Tippen Sie hierhin, um die Version dieser Website für Mobilgeräte aufzurufen.
Scheduled maintenance: Monday, March 30, between 3:30pm and 5:30pm UTC. This site will have limited functionality while we undergo maintenance to improve your experience. If an article doesn’t solve your issue and you want to ask a question, we have our support community waiting to help you at @firefox on Twitter

Hilfeforum

Dieses Thema wurde geschlossen und archiviert. Bitte stellen Sie eine neue Frage, wenn Sie Hilfe benötigen.

My PDF files are now identified as Firefox HTML documents, how to fix it?(only icons changed, extension is still .pdf)

Veröffentlicht

After I uninstalled Firefox, all icons returned to usual PDF icons and files were identified as "PDF" files, but when I installed Firefox (31.0) again, all PDF files again are identified as "Firefox HTML document". Extensions do not change, they are always .pdf, and files automatically open in Adobe Acrobat, but icons became "firefox HTML documents" icons and it is very confusing.

After I uninstalled Firefox, all icons returned to usual PDF icons and files were identified as "PDF" files, but when I installed Firefox (31.0) again, all PDF files again are identified as "Firefox HTML document". Extensions do not change, they are always .pdf, and files automatically open in Adobe Acrobat, but icons became "firefox HTML documents" icons and it is very confusing.

Ausgewählte Lösung

this runs for my XP Home:

Control Panel > Folder Options > File Types > New > "PDF" overwrite.

Diese Antwort im Kontext lesen 30

Mehr Details zum System

Installierte Plugins

  • Shockwave Flash 14.0 r0
  • Next Generation Java Plug-in 10.65.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.07
  • A plugin to detect whether the Adobe Application Manager is installed on this machine.
  • iTunes Detector Plug-in
  • VLC media player Web Plugin 2.1.3
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin

Anwendung

  • Firefox 31.0
  • User-Agent: Mozilla/5.0 (Windows NT 5.1; rv:31.0) Gecko/20100101 Firefox/31.0
  • Hilfe-URL: https://support.mozilla.org/1/firefox/31.0/WINNT/en-US/

Erweiterungen

  • Block site 1.1.8 ({dd3d7613-0246-469d-bc65-2a3cc1668adc})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Adobe Acrobat - Create PDF 2.0 (web2pdfextension@web2pdf.adobedotcom) (inaktiv)
  • Norton Toolbar 2014.7.5.2 ({2D3F3651-74B9-4795-BDEC-6DA2F431CB62}) (inaktiv)
  • Norton Vulnerability Protection 12.2.0.5 - 1 ({BBDA0591-3099-440a-AA10-41764D9DB4DB}) (inaktiv)

JavaScript

  • incrementalGCEnabled: True

Grafiken

  • adapterDescription: Mobile Intel(R) 965 Express Chipset Family
  • adapterDescription2:
  • adapterDeviceID: 0x2a02
  • adapterDeviceID2:
  • adapterDrivers: igxprd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'tryNewerDriver', u'6.1400.1000.5218']
  • directWriteEnabled: False
  • directWriteVersion: 0.0.0.0
  • driverDate: 12-19-2007
  • driverDate2:
  • driverVersion: 6.14.10.4906
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'tryNewerDriver', u'6.1400.1000.5218']
  • numTotalWindows: 1
  • webglRendererMessage: [u'tryNewerDriver', u'6.1400.1000.5218']
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Basic

Veränderte Einstellungen

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 1048576
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size_cached_value: 1048576
  • browser.cache.frecency_experiment: 4
  • browser.places.importBookmarksHTML: False
  • browser.places.smartBookmarksVersion: 7
  • browser.search.useDBForOrder: True
  • browser.sessionstore.upgradeBackup.latestBuildID: 20140716183446
  • browser.startup.homepage: http://quotes.ino.com/chart/index.html?s=FOREX_EURUSD&v=s&t=l&a=0&w=5
  • browser.startup.homepage_override.buildID: 20140716183446
  • browser.startup.homepage_override.mstone: 31.0
  • browser.tabs.warnOnClose: False
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 31.0
  • gfx.blacklist.direct2d: 3
  • gfx.blacklist.layers.direct3d10: 3
  • gfx.blacklist.layers.direct3d10-1: 3
  • gfx.blacklist.layers.direct3d9: 3
  • gfx.blacklist.layers.opengl: 3
  • gfx.blacklist.stagefright: 3
  • gfx.blacklist.suggested-driver-version: 6.1400.1000.5218
  • gfx.blacklist.webgl.angle: 3
  • gfx.blacklist.webgl.msaa: 3
  • gfx.blacklist.webgl.opengl: 3
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1406483107
  • places.history.expiration.transient_current_max_pages: 80278
  • plugin.disable_full_page_plugin_for_types: application/pdf,application/vnd.adobe.xfdf,application/vnd.fdf,application/vnd.adobe.xdp+xml
  • plugin.importedState: True
  • privacy.sanitize.migrateFx3Prefs: True
  • storage.vacuum.last.index: 0
  • storage.vacuum.last.places.sqlite: 1406403129

Verschiedenes

  • User JS: Nein
  • Barrierefreiheit: Nein
cor-el
  • Top 10 Contributor
  • Moderator
17846 Lösungen 161529 Antworten
Veröffentlicht

Did you try to change that icon?

  • Control Panel > Folder Options > File Types
Did you try to change that icon? *Control Panel > Folder Options > File Types

Fragesteller

The problem is that Windows Explorer sees files with .pdf extension as "Firefox HTML documents" and assigns appropriate firefox icon. (though, as I mentioned, extension remains .pdf and when double-clicked files automatically open in Adobe Acrobat). This problem could be solved only by making the system to see .pdf files as PDF files (and not as Firefox document). If system will continue to see the .pdf files as Firefox documents then changing the icon for Firefox documents to the PDF icon will not resolve anything (since now all Firefox documents will have PDF icon)

The problem is that Windows Explorer sees files with .pdf extension as "Firefox HTML documents" and assigns appropriate firefox icon. (though, as I mentioned, extension remains .pdf and when double-clicked files automatically open in Adobe Acrobat). This problem could be solved only by making the system to see .pdf files as PDF files (and not as Firefox document). If system will continue to see the .pdf files as Firefox documents then changing the icon for Firefox documents to the PDF icon will not resolve anything (since now all Firefox documents will have PDF icon)

Fragesteller

PROBLEM SOLVED : Firefox profile on my new computer was actually copied from my old computer and I came to conclusion that problem was in copied profile. So I uninstalled Firefox from new computer. Then completely emptied (!!!) the Profiles folder in Application Data>>Mozilla>>Firefox>>Profiles. Reinstalled Firefox and problem disappeared (I only copied bookmarks from old computer, not all profile). Now PDF files have correct icon and are seen by system as Adobe Acrobat Documents.


See also post here

Additional link added by a moderator. The solution above is not a general solution for everyone. My post under includes an explanation and potentially useful information including links to workarounds. ~J99

PROBLEM SOLVED : Firefox profile on my new computer was actually copied from my old computer and I came to conclusion that problem was in copied profile. So I uninstalled Firefox from new computer. Then completely emptied (!!!) the Profiles folder in Application Data>>Mozilla>>Firefox>>Profiles. Reinstalled Firefox and problem disappeared (I only copied bookmarks from old computer, not all profile). Now PDF files have correct icon and are seen by system as Adobe Acrobat Documents. ---------- == See also post [/questions/1012676#answer-613907 here]== Additional link added by a moderator. The solution above is not a general solution for everyone. My post under includes an explanation and potentially useful information including links to workarounds. ~J99

Geändert am von John99

Lynn761 0 Lösungen 2 Antworten
Veröffentlicht

I located the application data referred to in the solution with difficulty; I deleted the profile files as recommended and reinstalled Firefox; but my pdf files were still labeled as type: Firefox html document. Then I went to Firefox Options>Applications and changed all Actions for the pdf files to Adobe Reader. My pdf files still appeared as Firefox html documents and would open firefox every time I clicked on them. Then I right clicked on one of these firefox html documents and chose "open with Adobe reader". That particular file, as well as every other firefox html document on my computer changed to Adobe pdf with the Adobe icon.

I located the application data referred to in the solution with difficulty; I deleted the profile files as recommended and reinstalled Firefox; but my pdf files were still labeled as type: Firefox html document. Then I went to Firefox Options>Applications and changed all Actions for the pdf files to Adobe Reader. My pdf files still appeared as Firefox html documents and would open firefox every time I clicked on them. Then I right clicked on one of these firefox html documents and chose "open with Adobe reader". That particular file, as well as every other firefox html document on my computer changed to Adobe pdf with the Adobe icon.

Geändert am von Lynn761

cor-el
  • Top 10 Contributor
  • Moderator
17846 Lösungen 161529 Antworten
Veröffentlicht

Why do you want to delete all Firefox profile folders?

This thread is about Firefox registering as the default handler for PDF files if none such application is already registered. This has nothing to do with the Firefox profile folder as this only involves one or more registry keys.


Note that the "AppData" folder in Windows Vista and later Window 7+ versions and the "Application Data" folder in XP/Win2K are hidden folders.

You can use this button to go to the currently used Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder)
Why do you want to delete all Firefox profile folders? This thread is about Firefox registering as the default handler for PDF files if none such application is already registered. This has nothing to do with the Firefox profile folder as this only involves one or more registry keys. ---- Note that the "AppData" folder in Windows Vista and later Window 7+ versions and the "Application Data" folder in XP/Win2K are hidden folders. *http://kb.mozillazine.org/Show_hidden_files_and_folders You can use this button to go to the currently used Firefox profile folder: *Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder)
John99 971 Lösungen 13138 Antworten
Veröffentlicht

The latest release Firefox 31 (for Windows) has changed so that it may open some video and also .pdf files if it thinks nothing else can.

If you right click the files you will get the option to open them with another application instead of Firefox. You can change the choice (see links under).

Firefox 31 is not converting or renaming your files. All it is doing is registering with the Windows OS as an application that is able to open the files and Windows then changes the file's icons accordingly.

This should only occur if no other application has already registered your .pdf files.

Some of the following links may be useful

The latest release Firefox 31 (for Windows) has changed so that it may open some video and also .pdf files if it thinks nothing else can. If you right click the files you will get the option to open them with another application instead of Firefox. You can change the choice (see links under). Firefox 31 is not converting or renaming your files. All it is doing is registering with the Windows OS as an application that is able to open the files and Windows then changes the file's icons accordingly. This should only occur if no other application has already registered your .pdf files. Some of the following links may be useful * [https://www.mozilla.org/en-US/firefox/31.0/releasenotes/ Firefox 31 release notes] (Mentions the change) <br /> <sup>This was bug 452254 - Register for audio/video .ogg and .pdf file handlers if nothing else has </sup> * How to change or select which program starts when you double-click a file in Windows XP http://support.microsoft.com/kb/307859 (Also explains how to display file extensions) * http://windows.microsoft.com/en-gb/windows/change-default-programs (Win 7 or Vista) * http://pcsupport.about.com/od/fixtheproblem/ht/default-program-windows-7.htm a tutorial with further links including for other Windows versions
Lynn761 0 Lösungen 2 Antworten
Veröffentlicht

I right clicked on one of my pdf files that was labeled Firefox html document with the intention of using the "Open with..." option to change the default program used to open the file. The "Open with" option was not visible. This particular file was in my "Scansnap" folder, a folder used by my Scansnap scanner to drop pdf files into. Eventually I opened a different folder and right clicked on another pdf file/firefox html document; this time the "Open with " option showed up and I selected "Adobe Reader". Magically, that file and every other pdf on my computer (including those in my Scansnap folder) was relabeled as Adobe pdf with the Adobe icon. They now open with Adobe Reader and Firefox does not open when I click on them. Problem Solved. Thank you.

I right clicked on one of my pdf files that was labeled Firefox html document with the intention of using the "Open with..." option to change the default program used to open the file. The "Open with" option was not visible. This particular file was in my "Scansnap" folder, a folder used by my Scansnap scanner to drop pdf files into. Eventually I opened a different folder and right clicked on another pdf file/firefox html document; this time the "Open with " option showed up and I selected "Adobe Reader". Magically, that file and every other pdf on my computer (including those in my Scansnap folder) was relabeled as Adobe pdf with the Adobe icon. They now open with Adobe Reader and Firefox does not open when I click on them. Problem Solved. Thank you.
cor-el
  • Top 10 Contributor
  • Moderator
17846 Lösungen 161529 Antworten
Veröffentlicht

Note that on Window XP you may have to hold down the Shift key while right-clicking to make the "Open with" option appear in the context menu.

Note that on Window XP you may have to hold down the Shift key while right-clicking to make the "Open with" option appear in the context menu.
Robinson3 1 Lösungen 1 Antworten
Veröffentlicht

Ausgewählte Lösung

this runs for my XP Home:

Control Panel > Folder Options > File Types > New > "PDF" overwrite.

this runs for my XP Home: Control Panel > Folder Options > File Types > New > "PDF" overwrite.

Hilfreiche Antwort

Thanks Robinson3 ! The most economical solution. Not only worked for PDF files but also for other similar problem. Of all offered solutions this looks the most bang on. Hope, the problem will not return (but even if it returns the solution is so fast and simple).

I did exactly the following (all steps included) :

Control Panel > Folder Options > File Types > New > PDF>Advanced> >Associated File Type, and choose "Adobe PDF reader"

Thanks Robinson3 ! The most economical solution. Not only worked for PDF files but also for other similar problem. Of all offered solutions this looks the most bang on. Hope, the problem will not return (but even if it returns the solution is so fast and simple). I did exactly the following (all steps included) : Control Panel > Folder Options > File Types > New > PDF>Advanced> >Associated File Type, and choose "Adobe PDF reader"
jmz007 0 Lösungen 2 Antworten
Veröffentlicht

Props 2 U...this actually works!!!

Props 2 U...this actually works!!!
Pharteon 1 Lösungen 4 Antworten
Veröffentlicht

This happened to me as well. You need to reassign Adobe Acrobat or Adobe Reader as the default PDF handler...

Open up Adobe Reader (not Acrobat, if you have it on your system); go to "Edit", "Preferences", "General"; at the bottom of the General settings screen to the right "Select Default PDF Handler"; pull down and choose the PDF handler (e.g., Adobe Acrobat or Adobe Reader).

The other options described above and in other threads did not fix the problem for me.

This happened to me as well. You need to reassign Adobe Acrobat or Adobe Reader as the default PDF handler... Open up Adobe Reader (not Acrobat, if you have it on your system); go to "Edit", "Preferences", "General"; at the bottom of the General settings screen to the right "Select Default PDF Handler"; pull down and choose the PDF handler (e.g., Adobe Acrobat or Adobe Reader). The other options described above and in other threads did not fix the problem for me.

Geändert am von Pharteon

AliceWyman
  • Moderator
241 Lösungen 2619 Antworten
Veröffentlicht

Pharteon, Thanks for posting your solution, which is the same fix that another user posted on 8/21/14 in /questions/1014919#answer-618531

This is a known bug that will be fixed in a future Firefox release:

  • Bug 1069375 - Firefox 31 registers as PDF handler even when another handler is already registered

... which is a duplicate of:

  • Bug 1049521 - Be less aggressive about non-primary file type associations in Firefox on Windows

Since the original poster js.bigata has marked this question solved I'll close this thread.

Pharteon, Thanks for posting your solution, which is the same fix that another user posted on 8/21/14 in [/questions/1014919#answer-618531] This is a known bug that will be fixed in a future Firefox release: *[https://bugzilla.mozilla.org/show_bug.cgi?id=1069375 Bug 1069375] - Firefox 31 registers as PDF handler even when another handler is already registered ... which is a duplicate of: *[https://bugzilla.mozilla.org/show_bug.cgi?id=1049521 Bug 1049521] - Be less aggressive about non-primary file type associations in Firefox on Windows Since the original poster js.bigata has marked this question solved I'll close this thread.