Flash funktioniert nicht richtig oder lässt sich nicht aktualisieren

Dieser Artikel wird nicht länger gewartet, darum ist dessen Inhalt möglicherweise veraltet.

Wenn Sie eines dieser Symptome beim Flash-Plugin in Firefox bemerken, gibt es vielleicht einen Konflikt mit einer alten Version von Adobes Flash-Plugin oder der DLM-Erweiterung:

  • Flash-Inhalte funktionieren nicht richtig, verhalten sich seltsam oder erzeugen Fehler
  • Auch nach der Installation der aktuellen Flash-Version sehen Sie den Hinweis, dass Sie aktualisieren sollten (z.B. auf Mozillas Plugin-Testseite).

Dieser Artikel beschreibt, wie Sie die Probleme lösen können, die durch veraltete Flash-Versionen hervorgerufen werden. Allgemeine Informationen über Flash finden Sie im Artikel Flash-Plugin – aktuell halten und Probleme beheben.


Prüfen, ob verschiedene Versionen von Flash vorhanden sind

So finden Sie heraus, ob Sie mehr als eine Flash-Version installiert haben:

  1. Klicken Sie oben im Firefox-Fenster auf das MenüKlicken Sie oben in der Menüleiste auf das Menü Extras und wählen Sie Add-ons. Das Add-ons-Fenster wird sich öffnen.
  2. Gehen Sie zum Abschnitt Plugins.
  3. Suchen Sie nach Einträgen mit dem Namen Shockwave Flash.

Adobes DLM-Erweiterung entfernen

Wenn Sie nicht mehrere Versionen von Flash sehen, haben Sie vielleicht die Adobe DLM-Erweiterung installiert, die verhindern kann, dass sich Flash auf die neueste Version aktualisiert:

  1. Klicken Sie oben im Firefox-Fenster auf das MenüKlicken Sie oben in der Menüleiste auf das Menü Extras und wählen Sie Add-ons. Das Add-ons-Fenster wird sich öffnen.
  2. Gehen Sie zum Abschnitt Erweiterungen.
  3. Suchen Sie nach einem Eintrag mit dem Namen Adobe DLM.
  4. Wenn Sie Adobe DLM sehen, klicken Sie darauf, um es zu markieren, und klicken Sie dann auf Deinstallieren. Bestätigen Sie, dass Sie die Erweiterung entfernen möchten.

    2367f15a1bf70628ff8c7ad76567f6fe-1284196961-479-1.png

  5. Klicken Sie dann auf Firefox neu starten im oberen Teil des Add-ons-Fensters.

Folgen Sie der Anleitung unter Das Flash-Plugin manuell installieren, nachdem Sie die Adobe DLM-Erweiterung deinstalliert haben.


Versionen im Plugin-Verzeichnis von Firefox entfernen

Wenn Sie mehrere Versionen von Flash sehen, prüfen Sie nach, ob eine Version im Plugin-Verzeichnis von Firefox installiert ist:

  1. Klicken Sie oben im Firefox-Fenster auf die Schaltfläche Firefox und wählen Sie dort den Eintrag Beenden.Klicken Sie oben im Firefox-Fenster auf das Menü Datei und wählen Sie dort den Eintrag Beenden.Klicken Sie in der Menüleiste auf das Menü Firefox und wählen Sie dort den Eintrag Firefox beenden.Klicken Sie oben im Firefox-Fenster auf das Menü Datei (oder auf die Schaltfläche Firefox, falls keine Menüleiste sichtbar ist) und wählen Sie dort den Eintrag Beenden.

    Klicken Sie auf die Menüschaltfläche New Fx Menu und wählen Sie dann BeendenBeenden Firefox 29 Schließen .

  2. Gehen Sie zum Plugin-Verzeichnis von Firefox (z.B. C:\Programme\Mozilla Firefox\plugins).
  3. Falls Sie eine Datei namens npswf32.dll sehen, löschen Sie sie.

Falls die Datei npswf32.dll wieder auftaucht, obwohl Sie sie schon einmal gelöscht haben, öffnen Sie Firefox und sehen Sie nach, ob Sie weiterhin verschiedene Versionen von Flash aufgelistet sehen. Wenn Sie weiterhin verschiedene Versionen haben oder die Datei npswf32.dll nicht mehr existiert, folgen Sie dem nächsten Lösungsvorschlag in diesem Artikel.

Flash deinstallieren und wieder neu installieren

Hinweis: Der Deinstallationsassistent von Adobe wird Flash aus allen Browsern löschen - inklusive dem Internet Explorer. Sie werden möglicherweise darauf aufmerksam gemacht, Flash wieder zu installieren, wenn Sie eine Webseite öffnen, die Flash verlangt, wie z.B. Adobes Testseite.

Wenn Sie immer noch sehen, dass Shockwave Flash mehr als einmal in der Liste der Plugins aufgelistet ist:

  1. Folgen Sie der Anleitung von Adobe, wie Sie das Flash-Plugin deinstallieren können.
  2. Nachdem Sie den Deinstallationsassistenten von Adobe ausgeführt haben, lesen Sie im Artikel Das Flash-Plugin manuell installieren weiter, wie Sie Flash wieder installieren können.

Nachdem Sie das getan haben, prüfen Sie wieder, ob mehrere Versionen von Flash installiert sind.

Mehrfach vorhandene Plugins manuell entfernen

Wenn Sie immer noch mehrere Versionen von Flash installiert haben, nachdem Sie die Schritte von oben befolgt haben Wenn Sie sehen, dass mehr als einmal Shockwave Flash in Ihrer Liste der Plugins steht, entfernen Sie die Dateien der alten Versionen manuell.


Einstellungen ändern

Stellen Sie Firefox so ein, dass es anzeigt, wo Plugins installiert sind:

  1. Tippen Sie in die Adressleiste about:config und drücken Sie die EingabetasteReturn.

    • Die Warnung „Hier endet möglicherweise die Gewährleistung!“ erscheint beim Aufruf von about:config. Klicken Sie auf Ich werde vorsichtig sein, versprochen!, um fortzufahren.

      about_config_win_fx4 about:config - Linux - Fx18 about_config_mac_fx4

      about:config - Fx29 - Linux about:config - Fx29 - Mac about:config - Fx29 - Win8
  2. Tippen Sie in das Textfeld neben Filter den Wert plugin.expose_full_path ein.
  3. Doppelklicken Sie auf die Einstellung plugin.expose_full_path, um seinen Wert auf true zu setzen.

    2367f15a1bf70628ff8c7ad76567f6fe-1284196961-479-4.png 2367f15a1bf70628ff8c7ad76567f6fe-1284196961-479-3.png 2367f15a1bf70628ff8c7ad76567f6fe-1284196961-479-2.png


Speicherort der alten Plugins feststellen

Öffnen Sie als nächstes die Seite mit der Auflistung aller installierten Plugins in Firefox und stellen so fest, wo die alten Versionen von Flash installiert sind:

  1. Geben Sie about:plugins in die Adressleiste von Firefox ein. Die Seite mit der Auflistung der installierten Plugins wird geöffnet.
  2. Suchen Sie die Einträge mit Shockwave Flash. Merken Sie sich alle Speicherorte, die neben Datei stehen, bis auf den der neuesten Flash-Version (z.B. C:\Programme\Mozilla Firefox\plugins/usr/lib/mozilla/plugins/Applications/Firefox.app/Contents/MacOS/firefox/plugins).

    2367f15a1bf70628ff8c7ad76567f6fe-1284196961-479-5.png

Alte Plugin-Versionen entfernen

Wenn Sie festgestellt haben, wo sich die alten Versionen befinden, können Sie sie löschen:

  1. Klicken Sie oben im Firefox-Fenster auf die Schaltfläche Firefox und wählen Sie dort den Eintrag Beenden.Klicken Sie oben im Firefox-Fenster auf das Menü Datei und wählen Sie dort den Eintrag Beenden.Klicken Sie in der Menüleiste auf das Menü Firefox und wählen Sie dort den Eintrag Firefox beenden.Klicken Sie oben im Firefox-Fenster auf das Menü Datei (oder auf die Schaltfläche Firefox, falls keine Menüleiste sichtbar ist) und wählen Sie dort den Eintrag Beenden.

    Klicken Sie auf die Menüschaltfläche New Fx Menu und wählen Sie dann BeendenBeenden Firefox 29 Schließen .

  2. Löschen oder benennen Sie jede Datei um, die mit alten Versionen des Flash-Plugins in Verbindung stehen.


Deinstallation nachprüfen

Überprüfen Sie schließlich, ob alle überflüssigen Versionen von Flash gelöscht wurden, und setzen Sie den folgenden Wert auf seinen Vorgabewert zurück:

  1. Geben Sie about:plugins in die Adressleiste von Firefox ein. Die Seite mit der Auflistung der installierten Plugins wird geöffnet.
  2. Kontrollieren Sie, ob alle Versionen von Flash außer die aktuelle entfernt wurden. Wenn nicht, merken Sie sich den Speicherort der überflüssigen Version, der neben Datei steht, schließen Sie Firefox und löschen Sie dann die Datei.
  3. Tippen Sie in die Adressleiste about:config und drücken Sie die EingabetasteReturn.

    • Die Warnung „Hier endet möglicherweise die Gewährleistung!“ erscheint beim Aufruf von about:config. Klicken Sie auf Ich werde vorsichtig sein, versprochen!, um fortzufahren.

      about_config_win_fx4 about:config - Linux - Fx18 about_config_mac_fx4

      about:config - Fx29 - Linux about:config - Fx29 - Mac about:config - Fx29 - Win8
  4. Tippen Sie in das Textfeld neben Filter den Wert plugin.expose_full_path ein.
  5. Doppelklicken Sie auf die Einstellung plugin.expose_full_path, um seinen Wert auf false zu setzen.
Diese netten Menschen haben geholfen, diesen Artikel zu schreiben: Wawuschel. Auch Sie können helfen – erfahren Sie, wie.