Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

firefox hangs when searching on google or connecting to websites.

  • 10 svar
  • 6 har dette problem
  • 605 visninger
  • Seneste svar af frankwu

more options

I have tried to disable hardware acceleration, refresh firefox, reinstall, and nothing works. It hangs every single time when searching on google or connecting to websites. This really sucks because I have used firefox since the beginning and don't want to have to stop now..

I have tried to disable hardware acceleration, refresh firefox, reinstall, and nothing works. It hangs every single time when searching on google or connecting to websites. This really sucks because I have used firefox since the beginning and don't want to have to stop now..

Valgt løsning

For anyone that has similar issues, it ended up being Kaspersky Antivirus. That was causing an issue with the browser extension, because it forces the extension into the browser, and if you don't actually install the extension it causes all sorts of performance problems. Once I installed the kaspersky extension, it works great.

Læs dette svar i sammenhæng 👍 14

Alle svar (10)

more options

Could you test in Firefox's Troubleshoot Mode? In that mode, Firefox temporarily deactivates extensions, hardware acceleration, any userChrome.css/userContent.css files, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is running:

You can restart Firefox in Troubleshoot Mode using either:

  • "3-bar" menu button > Help > Troubleshoot Mode...
  • (menu bar) Help menu > Troubleshoot Mode...

and OK the restart. A small dialog should appear. Click the Open button.

If Firefox is not running:

Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.) A small dialog should appear. Click the Open button.

Note: Don't use the Refresh without first reviewing this article to understand what will be deleted: Refresh Firefox - reset add-ons and settings.

Any improvement?

more options

One other initial thought:

Although most people are not intentionally using a proxy server, Firefox may discover one set up in your system settings. Sometimes forcing Firefox to ignore those settings helps with weird connection issues. Here's how:

Open the Settings page using either:

  • "3-bar" menu button > Settings
  • (menu bar) Tools > Settings
  • type or paste about:preferences into the address bar and press Enter/Return to load it

In the very tiny search box at the top of the page, type proxy and Firefox should filter to the "Network Settings" section of the page.

Click the Settings button, change the top setting to "No Proxy" and then click the OK button at the bottom of the dialog to save your change.

Any difference?

more options

I have tried to run in troubleshoot mode to no avail, and also with the proxy settings disabled, tried turning off hardware acceleration, nothing seems to work. I even tried reinstalling it...

more options

Is there any pattern to the sites that work and the sites that don't work?

For Google, there was a problem many months ago where it worked fine up to a point and then became non-responsive. Gmail would show an "Oops" message when you tried to do anything from your Inbox.

At that time, the problem was linked the "zero round trip resumption" feature, which is intended to speed up website connections. (Explainer post by CloudFlare) However, there seemed to be some kind of compatibility issue. You could try the workaround from back in the day and see whether it makes any difference:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

(2) In the search box in the page, type or paste security.tls.enable_0rtt_data and pause while the list is filtered

(3) Double-click the preference to switch the value from true to false

After that, try Google again. Any improvement?

more options

The issue is when searching with Google specifically. Other websites seem to work fine... When I hit the enter button after typing a search, it's like the browser freezes for 5 seconds or so, the text cursor stops flashing even, then it begins to start reading and communicating after that, and sometimes a search can take anywhere from 5 to 30 seconds, which is extremely frustrating! I hate other search engines, so just switching isn't my preference by any means. I tried your suggestion above and it seemed like it may have made it even worse, so I switched it back.

more options

Valgt løsning

For anyone that has similar issues, it ended up being Kaspersky Antivirus. That was causing an issue with the browser extension, because it forces the extension into the browser, and if you don't actually install the extension it causes all sorts of performance problems. Once I installed the kaspersky extension, it works great.

more options

This was driving me crazy i recently got into doing everything i can to stay safe online and i thought i messed something up ive tried quite literally everything and never thought it would be my AV i was dreading going to chrome or opera thanks this saved me a headache

more options

I'm glad I could help someone else that was struggling with the same issues!

more options

Hi,

i also have these issues, reproducable with ubuntu 22.04, not using snap, using ppa (v120.0)

https://ppa.launchpadcontent.net/mozillateam/ppa/ubuntu jammy

uninstalled snap (tells me it is not installed as i did this before, just to test if there is anything left),uninstalled the ppa version and reinstalled ppa version.

created clean profile with "firefox -P" in terminal, disabled HW acceleration and opened google authentification (after access https://drive.google.com).

wonder about these messages in my terminal:

[Parent 9996, Main Thread] WARNING: Failed to call GetIdletime(): GDBus.Error:org.freedesktop.DBus.Error.AccessDenied: An AppArmor policy prevents this sender from sending this message to this recipient; type="method_call", sender=":1.131" (uid=1000 pid=9996 comm="/usr/lib/firefox/firefox -P " label="firefox (enforce)") interface="org.gnome.Mutter.IdleMonitor" member="GetIdletime" error name="(unset)" requested_reply="0" destination=":1.61" (uid=1000 pid=2263 comm="/usr/bin/gnome-flashback " label="unconfined")

'glib warning', file /build/firefox-3GB2FH/firefox-120.0+build2/toolkit/xre/nsSigHandlers.cpp:187
    • (firefox:9996): WARNING **: 09:16:31.444: Failed to call GetIdletime(): GDBus.Error:org.freedesktop.DBus.Error.AccessDenied: An AppArmor policy prevents this sender from sending this message to this recipient; type="method_call", sender=":1.131" (uid=1000 pid=9996 comm="/usr/lib/firefox/firefox -P " label="firefox (enforce)") interface="org.gnome.Mutter.IdleMonitor" member="GetIdletime" error name="(unset)" requested_reply="0" destination=":1.61" (uid=1000 pid=2263 comm="/usr/bin/gnome-flashback " label="unconfined")

ATTENTION: default value of option mesa_glthread overridden by environment. MESA: error: Failed to query drm device. libEGL warning: egl: failed to create dri2 screen ATTENTION: default value of option mesa_glthread overridden by environment. MESA: error: Failed to query drm device. libEGL warning: egl: failed to create dri2 screen ATTENTION: default value of option mesa_glthread overridden by environment. ATTENTION: default value of option mesa_glthread overridden by environment. MESA: error: Failed to query drm device. libEGL warning: egl: failed to create dri2 screen ATTENTION: default value of option mesa_glthread overridden by environment.

why mesa is called here...mesa IS hw acceleration which i have disabled in options...

i have a dell g5 15 with an intel + nvidia graphics card and installed the nvidia-driver-535 from the ubuntu-repo. This driver is still in default-mode

root@frank-G5:~# prime-select query on-demand

more options

in my case it was caused by apparmor (using firefox 120 from ppa in ubuntu 22.04)

https://bugs.launchpad.net/ubuntu/+source/apparmor/+bug/2044304