Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Windows 10 NOT Windows 8

  • 25 svar
  • 3 har dette problem
  • 99 visninger
  • Seneste svar af Rhonda

more options

Firefox continues to indicate I am using Windows 8. I have NEVER used Windows 8 in my liftetime. I use Windows 10 and after locating the program compatibility location to change to Windows 10, Windows 10 isn't an option. I changed my OS to 10 in your box below. Why? I don't understand this.

Firefox continues to indicate I am using Windows 8. I have NEVER used Windows 8 in my liftetime. I use Windows 10 and after locating the program compatibility location to change to Windows 10, Windows 10 isn't an option. I changed my OS to 10 in your box below. Why? I don't understand this.

Alle svar (20)

more options

Here is additional information regarding Firefox and the incorrect information. My OS is NOT Windows 8. See uploaded image.

Nyttig?

more options

How are you viewing that so it shows as Windows 8? You have to give steps on how your seeing this.

Nyttig?

more options

Rhonda said

Firefox continues to indicate I am using Windows 8. I have NEVER used Windows 8 in my liftetime. I use Windows 10 and after locating the program compatibility location to change to Windows 10, Windows 10 isn't an option. I changed my OS to 10 in your box below. Why? I don't understand this.

In your Question Details > More System Details your User Agent appears to be Mozilla/5.0 (Windows NT 6.2; Win64; x64; rv:105.0) Gecko/20100101 Firefox/105.0

The NT 6.2 identifies as Windows 8 as per https://en.wikipedia.org/wiki/Windows_NT

Either your User Agent was modified by an Extension or manually by preference in Firefox or you are running Firefox 105.0 in Windows 8 Compatibility Mode on Windows 10 for some reason. My bet is on compatibility mode.

https://support.microsoft.com/en-us/windows/make-older-apps-or-programs-compatible-with-windows-10-783d6dd7-b439-bdb0-0490-54eea0f45938 https://support.mozilla.org/en-US/kb/how-reset-default-user-agent-firefox

Nyttig?

more options

Check that you do not run Firefox in compatibility mode. You can open the Properties of the Firefox desktop shortcut via the right-click context menu and check the "Compatibility" tab. Make sure that all items are deselected in the "Compatibility" tab of the Properties window.

Nyttig?

more options

You can check out at the browserspy website how websites see your browser:

Nyttig?

more options

James and Cor-el

Yes this is my user agent: Mozilla/5.0 (Windows NT 6.2; Win64; x64; rv:105.0) Gecko/20100101 Firefox/105.0 (Selected from your link)

BUT, it doesn't matter what version of Firefox I use now or have used, It has shown Windows 8 since, I believe, when Firefox updated to 100 or earler.

I have checked the compatibility mode as instructed by Cor-el and ALL of the items are DESELECTED.

I have gone into Windows Troubleshooting Settings/Program Compatibility and I have selected several different programs such as MS Edge, Firefox, Acrobat, Trend Micro Maximum Security, Word and others. I selected "Try Recommended Settings" it showed Windows Compatibility Mode: Windows 8 on EVERY SINGLE program I selected.

Then I selected "TroubleShoot Program" then was asked "Which Version did this Program Run on Before"? OPTIONS: Windows 8, Windows 7, Windows Vista (Service Pack 2), BUT WINDOWS 10 NOT AN OPTION.

I wouldn't know how to change USER AGENT if my life depended on it. Thanks for your patience while I have taken several hours to check as many locations and options as possible from your recommendations and my searching.

By the way, I still Cannot get into Firefox without "Permission to Allow this Program to Make Changes to YOUR computer". WHY IS THIS HAPPENING AND COULD IT HAVE ANYTHING TO DO WITH Windows 8 not 10??

Thank you, Rhonda

Nyttig?

more options

What security software are you running besides Windows Defender?

Nyttig?

more options

jonzn4SUSE

I use Trend Micro Maximum Security which I have used for approximately 10 years.

Thanks for the question.

Nyttig?

more options

Jonzn4SUSE James Cor-el

I have attached the page showing everything I am currently logged into.

PLEASE note Firefox 105 OS 8

Thank you

Nyttig?

more options

Have you tried disabling Trend Micro and rebooting to see if you have the same issue?

Nyttig?

more options

Did you check the general.useragent prefs on the about:config page ?

Nyttig?

more options

Cor-el,

As a matter of fact, I did go to about-config-editor-firefox. I changed my OS from Windows 8 to Windows 10, however it automatically went back to Windows 8.

There should be NO reason my PC indicates Windows 8. As I've stated several times, Windows 8 has NEVER been on this PC. I started with Windows 7, then your Support Staff downloaded Windows 10 on September 26, 2019. And that's that!

Then one day, Firefox indicated I was using OS 8! Why I DO NOT know. Probably some update glitch, but I cannot fix it.

WHO can fix this problem that I did not initiate?

PLEASE, I don't know how this is affecting my PC other than it's slower than slow.

Thank you so much, Rhon

Nyttig?

more options

Do you have enabled "Resist Fingerprinting" if you check this pref on the about:config page?

Nyttig?

more options

I cannot find anything titled firefox-protection-against-fingerprinting, even using the link you provided. I did go to Windows Settings, however and I am attaching the Windows Specifications which shows that my PC is a Windows 10 OS.

This probably isn't going to help, but I Need Some Help to fix whatever happended. I have never been in any of the "links" you have provided, so how could I have possibly changed the information to OS 8?

Please Help

Nyttig?

more options

Rhonda said

I cannot find anything titled firefox-protection-against-fingerprinting, even using the link you provided.

I think you misunderstood.

Type about:config (with a colon : and not a period) in the Location (address) bar as you would type in say www.example.com

In the search bar on top of about:config page type in fingerprinting and look for the privacy.resistFingerprinting preference. If it is not set as false, look on right side and click on arrow to reset it to default.

edit: scrolling to bottom of https://support.mozilla.org/en-US/kb/firefox-protection-against-fingerprinting article it explains how to do this also.


This article explains the basics of how to use about:config https://support.mozilla.org/en-US/kb/about-config-editor-firefox

Also another about: url that is useful is about:about as it lists all about: urls for the version.

Ændret af James den

Nyttig?

more options

OK, I see that this has been suggested before and apparently didn't apply/help.


You can also check that you do not run Firefox in compatibility mode for Windows 8.

You can open the Properties of the Firefox desktop shortcut via the right-click context menu and check the "Compatibility" tab. Make sure that all items are deselected in the "Compatibility" tab of the Properties window.

Ændret af cor-el den

Nyttig?

more options

I checked the source code and using RFP still reports the OS as Windows 10 in the user agent in current releases, so that can't be the problem.

That only leaves the general.useragent.override pref in about:config and running Firefox in compatibility mode or an extension.

Can you attach a screen shot the show that "Compatibility" tab in the Properties ?


Boot the computer in Windows Safe Mode with network support to see if that has effect.

Nyttig?

more options

James,

I did not misunderstand. I have typed about:whatever hundreds of times, I am aware about: requires a colon and not a period. I typed in fingerprinting, then looked for privacy.resistFingerprinting and it IS set as "false".

Thanks, Rhon

Nyttig?

more options

TO: Cor-el

I hope you can see these. Apparently, I am using OS 8 on Firefox. I can't even imagine that to be the case, but hopefully these photos I sent can help you to help me.

Thanks,

Nyttig?

more options

Hi Rhonda,

Have you tried to uninstall Firefox by going to https://support.mozilla.org/en-US/kb/uninstall-firefox-from-your-computer? If so, I recommend downloading an official copy of Firefox from the Microsoft Store. Alternatively, if you prefer Winget, try installing Firefox with "winget install 9NZVDKPMR9RD" (current MS Store ID at time of writing).

Nyttig?

  1. 1
  2. 2
Stil et spørgsmål

Du skal logge ind på din konto for at svare på et indlæg. Start et nyt spørgsmål, hvis du ikke har en konto endnu.