Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Amazon Video Error: "Mozilla Firefox update required"

  • 2 svar
  • 1 har dette problem
  • 11 visninger
  • Seneste svar af cor-el

more options

Full Text of Error Message Pop-Up:

"A later version of Mozilla Firefox is required for Prime Video. To update, click the menu button (three horizontal stripes) on the web browser toolbar, click Help, About Firefox, and then click Restart to update Firefox."

Like I don't know how to update a browser...

I've been getting this same error for the past three weeks; since the last v89.x. Now I'm getting it with v90.0, v90.1, v90.2. Amazon says it's not their problem. My FF browsers at the office (same versions) work fine. I come home to errors.

Any ideas on the cause?

Before this error, I tried to watch a video in HD, but that error suggested I needed some anti-piracy tech (HDCP?).

Full Text of Error Message Pop-Up: ''"A later version of Mozilla Firefox is required for Prime Video. To update, click the menu button (three horizontal stripes) on the web browser toolbar, click Help, About Firefox, and then click Restart to update Firefox."'' Like I don't know how to update a browser... I've been getting this same error for the past three weeks; since the last v89.x. Now I'm getting it with v90.0, v90.1, v90.2. Amazon says it's not their problem. My FF browsers at the office (same versions) work fine. I come home to errors. Any ideas on the cause? Before this error, I tried to watch a video in HD, but that error suggested I needed some anti-piracy tech (HDCP?).

Alle svar (2)

more options

Chrome and Edge work fine. But I won't use them.

more options

Make sure you have the latest Widevine 4.10.2209.1 version installed.

Try to toggle DRM off/on to see if that makes Firefox (re)load DRM components.