Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox search setting.

  • 4 svar
  • 1 har dette problem
  • 20 visninger
  • Seneste svar af jscher2000

more options

Why does the Firefox browser keep changing my search engine to default when I want Google after I've changed it? It keeps happening? I change it to Google then it returns to default. It's happens a lot. Thanks. Cheers...

Valgt løsning

Kiki is on the right track: Firefox doesn't come with a search engine called "Default" so most likely that is being injected by one of your add-ons.

You can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either:

  • Command+Shift+a (Windows: Ctrl+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Extensions. On the right side, find the "Manage Your Extensions" heading.

If there is at least one extension before the next heading -- "Recommended Extensions" -- please continue:

Then cast a critical eye over the list below that heading. Any extensions Firefox installs for built-in features are hidden from this page, so everything listed here is your choice (and your responsibility) to manage. Anything suspicious or that you just do not remember installing or why? If in doubt, disable (or remove). For your privacy and security, don't let mystery programs linger here.

Any improvement?

If you cannot access the Extensions panel or it is blank:

You can restart Firefox in its Safe Mode to temporary deactivate all the add-ons so they cannot interfere with the cleanup process. Either:

  • "3-bar" menu button > "?" Help button > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart.

A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Can you regain control of your Firefox?

Læs dette svar i sammenhæng 👍 0

Alle svar (4)

more options

Hey heycody64,

Just to make sure we're on the same page, are you talking about Firefox for iOS or Firefox desktop?

more options

I'm using a Macbook Air with the Firefox browser.

more options

Moving this to Firefox dekstop, then.

That problem usually caused by extentions/malware. I'd recommend following the solution provided here to fix it.

more options

Valgt løsning

Kiki is on the right track: Firefox doesn't come with a search engine called "Default" so most likely that is being injected by one of your add-ons.

You can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either:

  • Command+Shift+a (Windows: Ctrl+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Extensions. On the right side, find the "Manage Your Extensions" heading.

If there is at least one extension before the next heading -- "Recommended Extensions" -- please continue:

Then cast a critical eye over the list below that heading. Any extensions Firefox installs for built-in features are hidden from this page, so everything listed here is your choice (and your responsibility) to manage. Anything suspicious or that you just do not remember installing or why? If in doubt, disable (or remove). For your privacy and security, don't let mystery programs linger here.

Any improvement?

If you cannot access the Extensions panel or it is blank:

You can restart Firefox in its Safe Mode to temporary deactivate all the add-ons so they cannot interfere with the cleanup process. Either:

  • "3-bar" menu button > "?" Help button > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart.

A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Can you regain control of your Firefox?