Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Roblox not launching

  • 12 svar
  • 1 har dette problem
  • 12 visninger
  • Seneste svar af arrowoodben

more options

With the new Firefox update Roblox has stopped launching correctly. When I click on a game I want to play in the Roblox website, and pop-up shows up asking where I want to launch the game link. I go into my application, select Roblox, then click open link in this application. The problem is that instead of launching the game in Roblox, it just opens the Roblox website in a new tab. This problem is specific to Firefox, Chrome and Safari work just fine.

Alle svar (12)

more options

There was an issue launching the Roblox game client in Firefox 78.0.1, but it should be fixed in a patch that was released today (Firefox 78.0.2). Make sure that Firefox is up to date.

If you continue to have issues, you may want to try uninstalling Roblox and installing it again. See How to Uninstall Roblox.

Hope this helps.

Nyttig?

more options

I made sure my Firefox was up to date and also uninstalled and reinstalled Roblox but I'm still having the same issue.

Nyttig?

more options

You can try these steps in case of issues with web pages:

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Remove the Cookies" for websites that cause problems:

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data: "Manage Data"

"Clear the Cache":

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Clear Data -> Cached Web Content: Clear

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window

Nyttig?

more options

You can also try to set this pref to true on the about:config page to see if that has effect.

  • security.allow_disjointed_external_uri_loads = true

Nyttig?

more options

I tried all of those things, but none of them have solved the issue.

Nyttig?

more options

If you check the Applications list on the Preferences page, is your preference for the roblox-player links getting recorded correctly there? Either:

  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the search box at the top of the page, type roblox and Firefox should filter to the "Applications" section and highlight the roblox entry in the scrolling list.

Nyttig?

more options

In that menu roblox-player is set to always ask, and when i set it to "use roblox" I still have the same problem.

Update: I powered up an old windows machine and downloaded Firefox to see if I'd have to same issue, but it launched games just fine.

Nyttig?

more options

arrowoodben said

jscher2000 said

If you check the Applications list on the Preferences page, is your preference for the roblox-player links getting recorded correctly there? Either:
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it
In the search box at the top of the page, type roblox and Firefox should filter to the "Applications" section and highlight the roblox entry in the scrolling list.

In that menu roblox-player is set to always ask, and when i set it to "use roblox" I still have the same problem.

Update: I powered up an old windows machine and downloaded Firefox to see if I'd have to same issue, but it launched games just fine.

Hi arrowoodben, thank you for checking that. So either way, Firefox doesn't respond?

What is the current value of the preference mentioned earlier in the thread:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste disj and pause while the list is filtered

(3) If the security.allow_disjointed_external_uri_loads preference has a value of false, double-click it to restore the (current) default value of true (78.0.1 reverted this from false to true)

More info on about:config: Configuration Editor for Firefox.

Nyttig?

more options

I followed your steps, and security.allow_disjointed_external_uri_loads was already set to true so I don't think that's whats causing the problem.

Nyttig?

more options

Sometimes the settings file that stores download handling preferences becomes corrupted. You can rename the file and have Firefox rebuild it. Here's how:

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" Help > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter/Return

In the first table on the page, on the Profile Folder row, click the "Show in Finder" button. If Finder highlights an icon with a semi-random name like a1b2c3d4.default, double-click it to display the contents of that profile folder.

Leaving that window open, switch back to Firefox and Quit, either:

  • "3-bar" menu button > Quit
  • (menu bar) Firefox Quit

Pause while Firefox finishes its cleanup, then rename handlers.json to something like handlersOLD.json.

Start Firefox back up again and it should rebuild the file based on the Firefox and system defaults. Any improvement?

Nyttig?

more options

I'm not sure whether on Mac this protocol handler data is stored in about:config like this is normally the case on Linux, but you can do a search on the about:config page.

Nyttig?

more options

Once again followed your steps but I am still experiencing the same problem.

Nyttig?

Stil et spørgsmål

Du skal logge ind på din konto for at svare på et indlæg. Start et nyt spørgsmål, hvis du ikke har en konto endnu.